Intel true 10bits/HEVC/HDR support... ?

  • I did delete the folder ".kodi" after updating and rebooted. Maybe that was not enough.

    just grab 2 usb sticks. use the custom libreelec installer from their download page and install SMP's image on one. boot with both inserted and install on the other. Easy


    i copied over the userdata/* files (smashed for quick testing but ugly) to SMP's build but from what i can see the DB structure is different/ in a diff location along with other settings from v9 to v10.

  • Switch PRIME Render Method to EGL.

    tried to do that but there is no option under player section to do this. On your intel build there is.


    i tried changing:

    guisettings.xml: <setting id="videoplayer.useprimerenderer" default="true">1</setting>


    from 0 to 1 but there was still a black screen

  • just grab 2 usb sticks. use the custom libreelec installer from their download page and install SMP's image on one. boot with both inserted and install on the other. Easy

    Thanks, that was a good idea. I did that and had it running quite quickly!


    I did a short test and HDR is working out of the box on my NUC7i5BNK. I have to test it more thoroughly tho, but this is great! Thanks alot for the work!

  • just grab 2 usb sticks. use the custom libreelec installer from their download page and install SMP's image on one. boot with both inserted and install on the other. Easy

    More easy: use one stick and type run once on syslinux boot prompt.

  • Yes thank you. I actually did that first. But for being able to test better in the next days I think I will want to have a persistent installation.

  • run is persistent and equivalent to an installation. live will boot a not persistent system in RAM.


    You can change between run, live and installer any time without losing the persistent data.

  • Hey smp , is there a latest build with the LE 10.0BETA3 + HDR patches + latest Kodi 19.1 + latest Kodi patches?


    Mine works brilliantly, but crashes (reboots) at least 3 times per day. I know this is BETA and this is totally expected, but just want to see if there are any newer versions of software that may be a little more stable.


    I am currently using: LibreELEC-Generic.x86_64-10.0-devel-20210524004323-f9d2c33.img


    Thx so much for your hard work!

  • Build in post #698 is the latest and greatest. And probably the last one from me, at least until lrusak resume his work on HDR. No idea why it crashes for you, those builds are rock stable on my J4105 box.

  • Build in post #698 is the latest and greatest. And probably the last one from me, at least until lrusak resume his work on HDR. No idea why it crashes for you, those builds are rock stable on my J4105 box.

    Brilliant, thx! Yeah it is strange, all the freezes/reboots. I have kodi crash logs, I will go through them when I get a chance

  • Hi


    I confirm functionality # 698 on my i3-9100 + ASROCK Fatal1ty Z370 Gaming-ITX, which has HDMI [email protected], but I set the output to [email protected], because then my Philips TV works on 12-bit colour depth. I watch movies mainly 24FPS.


    Gemini J5005 also works without problems for me :)


    BIG thanks smp ! :thumbup:


    (sorry for my gooenglish:)


    I went a little crazy and I'm looking at 11600 and ITX B560m mainly for native 2.0, but I'll probably still wait :)

  • I am having issues playing certain MP4 files in this build.

    Software decoding does not seem to work with DRM PRIME. Disable "Allow using DRM PRIME decoder" and it will play.