weird samba speeds on Rock64

  • First of all i want to say that this is not a complaint AT ALL, im very happy with what this community does with libreelec, that being said to my "issue":


    As the title say i get weird samba speeds on the rock64 latest alpha and i want to know if there is any idea to improve things a bit at least, the thing is like this:

    libreelec working as a "NAS" and windows 10 as client

    copy file FROM libreelec TO w10 desktop = 30MB/s average

    copy file FROM w10 desktop TO libreelec = 90MB/s average

    Not that it matters but the w10 computer have an ssd and the rock64 have an hdd thru usb

    Some notes to keep in mind:

    - hdparm super basic test:

    Code
    1. hdparm -Tt /dev/sda
    2. /dev/sda:
    3. Timing cached reads: 1500 MB in 2.00 seconds = 750.25 MB/sec
    4. Timing buffered disk reads: 328 MB in 3.01 seconds = 109.00 MB/sec

    - the EXACT same hardware setup but with OMV on the rock64 was giving me an average of 70MB/s LE->W7 (cant remember the other direction) also keeping in mind that w10 to LE gives me 90MB/s average makes me think that hardware and network are fine

    - transfer tests were done with about 7gb information in 2-3 files top to rule out any caching both omv or LE can be doing

    - both systems are freshly installed, i didnt touch ANY option at all in any of them exept that i tried forcing SMB2 and SMB3 on LE and made no difference at all, now its back to the defaul 2/3


    I think that this needs some smb.conf fine tuning maybe but i cant find specific information googling so i came here for help, any ideas? 30MB/s seems suspiciously close to what a usb2 port gives BUT on the other hand the other direction gives 90MB/s...maybe some mount option?


    Im not looking to outspeed OMV but at least 60MB/s LE->W10 since i transfer stuff a lot more on that direction


    Thanks in advance for ANY help/ideas :D

  • Do you have any other SBC like a RPi to compare the results? It will confirm if it's a RK issue or more generic and something that needs to be looked into.

  • CvH

    Changed the title of the thread from “weird samba speeds on LibreELEC-RK3328.arm-8.90.006-rock64.img.gz” to “weird samba speeds on Rock64”.
  • Power...the problem on sbc is 95% of the time related to power...is said external drive powered? i had super random crashes (yea, specially with torrent clients curioulsy) until i got myself a powered usb3 hub and used it (drive to the powered hub, hub to the rock64)

  • i'm not saying this is spam. But this is spam./shrug


    Im having weird crashes on a new rock64 [solved]

  • While it is very close to the definition of spam (unsolicited mesage/mail) i cant see what i can achieve/gain "spaming" about an issue on one forum and about another on other forum, unrelated issues...also you quoted the other dude post, do you mean that im both? what will i gain doing that? im not selling anything, if at all i can hurt said product while seeking with help with issues (i dont even want to name it again, i dont want to """spam""")

    Again, yea, i ask for help when i need it, isnt that what a forum is for?

    PD: even worst, the other post is over 6 month old, 2 messages over 6 month appart is hardly spam IMHO

    PD2: WTF that other dude copied my post from the other thread!! what is that? a bot? i even forgotten the exact text since its over 6 month old so it didnt click as mine, sorry about the ranting but no, im not nadhim

  • btw 5schatten if you still need testers for your rock64 RR build i can test stuff on my second one, i have a spare microsd and i use that one only for libreelec anyway...

  • For what it is worth I see ~30MB/s from Windows 10 to my Rock64 (both directions) over a samba share.

    -Written by a team of angry monkeys.