FiveNinjas Slice Playback issues LibreElec

  • Hi.

    I thought I would start a new thread as the previous one regarding LibreElec hasn’t been active for a while.

    I have a FiveNinjas Slice which I upgraded to LibreElec when the Movie database scrubbers stopped working.

    Everything seemed fine, albeit the interface is a little slower than the Slice version, however recently I’ve had issues with smooth playback of some of my blu-ray rips that I’ve done using Make MKV. I’ve not check my whole library but it seems to be with films that are around 35Mb/s.

    The issue is that playback freezes after an indeterminate amount of time and then starts again. It freezes between 0.5 and 5 seconds but without any buffering icons appearing on screen.

    I suspected my network at first as I have recently replaced my HomeHub5 router with a MikroTik Routerboard but not convinced this is the issue and it’s hard to be certain as I’ve not had the opportunity to watch many movies this year so don’t know exactly when the issue started but I’m sure I’ve watched the film in question before without any issues.

    My set up is, and apologies if it’s too detailed, Internet into Netgear modem into MikroTik hap router. Gigabit router NIC connected to Netgear ProSafe GS116 (1Gb/s). Into this is connected my Synology NAS where my films are stored and a cable run from this switch under the house to my living room to another Netgear ProSafe switch (1Gb/s). Connected to this is the Slice as well as a PS4, Sky box, Apple TV, etc.

    The Slice has the NAS connected via NFS. According to the on screen debug log the CPU is running at 97-100% when playing the film back. I decided to copy the film to the internal storage to eliminate network issues. When copying the film, using the Kodi interface, I saw that the transfer speed didn’t get much above 4-5MB/s, similar to the speed when playing the film.

    When playing the film from the internal drive it playbacks without any issue and the CPU is only running at 70-85%. I connected my laptop to the same local switch that the Slice is connected to and was able to copy the file from the NAS at over 40MB/s. I’ve also swapped network cables and ports on the switch. Checking the port lights on the switch it says the Slice is only connected at 100Mb/s, is this correct that the Slice NIC is only 100Mb capable?

    I’ve tried saving an advencedsettings.xml to the userdata folder but whatever settings used, buffermode, memorysize, readfactor, seemed to make the issue more frequent rather than better.

    The results seem to point that the network connection of the Slice isn’t good enough to maintain playback although it’s interesting that I don’t get any buffering notifications and the CPU is running higher than during local playback.

    I’ve uploaded 2 log files, the first is from when playing the film over the network and the other when playing off the local HDD, I did a restart between playing the 2 files. I’ve also uploaded a screengrab of the network traffic from the NAS which shows the fluctuation in data rates, interestingly some of the freezes coincide with the peaks on the screen grab but have also happen on dips. There is a video too from a previous viewing where the data seems to drop around the freezes.




    Screen shot and movie

    Downloading from DiskStation

    Can you tell from the logs if it is a network data rate issue that is causing the problem and what I might be able to do to find a solution please?

  • Is your Slice based on the original CM1 or upgraded to CM3?

    There is a BIG difference in performance.

    I think the Slice 9 offering above is only for the CM3 at the moment?

    I have both a CM1 (running 8.2.3) & a CM3 (running the 9 as above) both using a Synology NAS.

    I get similar symptoms with the CM1 and no problems with the CM3 configuration.

    I hope that the Slice 9 upgrade for CM1 might address some of the hardware shortcomings for this application.

  • I would second the CM3 upgrade, a much better user experience all round, though you'll have to sort out a heatsink.

    Have you tried switching between the ethernet and the supplied wifi dongle to see if theres a difference? also does this happen on SD content?

    Havent streamed any blurays but have streamed HD broadcasts via wifi with no issues on CM3.

  • The Slice NIC is 10/100 which isn't the best, but should be enough for streaming BR rips as long as the network doesn't have other issues and you're not contending the USB bus (which the NIC is connected to) with other devices. Kodi cache settings can smooth out occasional wireless issues but should never be required or used with Ethernet (if they achieve anything you have a bad network). I didn't try with a USB GB NIC but that's the trick used with Pi 3B+ to improve throughput (with some additional CPU load as a result).

    The original SliceOS skin was never forward ported to newer Kodi versions. Estuary is reasonably light. Older Confluence has fans who claim it's lighter and it's still maintained in the Kodi repo if you wanted to install it. There are also some other deliberately light skins. Experiment and see if there's something better.

    As others have said, CM3 is a worthwhile performance upgrade, especially if things are CPU bound.

  • Cheers, thanks for all the suggestions.

    I'm assuming swapping the CM1 for a CM3 is fairly straight forward? I'l check the forums later for a guide but will dig out the WiFi dongle (if i can find it) and try that first and also try and see if I can force my laptop to a 100Mb connection (rather than 1Gb) to the switch the Slice is connected to and see what sort of transfer speeds are possible between it and the NAS.

    I tried installing and running iPerf but the client on the Slice fail to connect to the server on the Synology so I hoping a simple SMB copy from the NAS to my laptop will be sufficient to rule out the network.

    I'll look at a lighter skin too, although once booted and idle, the CPU is around 40-50%

  • Also if you haven't already, remove the supplied RF remote dongle, I'm sure that's caused me to have performance issues to.

    Good luck!

  • Hi.

    I've tried removing the RF remote dongle and it made no difference. I've tried lower bit rate movies and they playback okay. I connected my laptop to the same switch and forced it to connect at 100Mb/s and copied the film I'm having problems with and got constant speeds around 11MB/s, so no issues with the network on a 100Mb.

    I couldn't find the box for the Slice which still had the WiFi dongle in so plumped to buy a CM3 and do an upgrade. I've downloaded the LibreELEC USB-SD Creator however, I only have a Mac so not sure how I flash the eMMC as it doesn't appear when I connect the slice to my laptop. Does anyone know how to do this?

  • I never figured the process on macOS either .. so I cheat with Win7 in a virtual machine in vmware Fusion. If you know someone with a Windows box that'd be quickest, but if not you can download Oracle Virtualbox (free) and a Linux OS like Ubuntu (free) to image the CM3 card.