[Plex Media Server in Docker] How to access /storage ?

  • Another angle of this, some responsibility lies with the one mounting data to an "unknown" app ;) But doing chown when necessary sound like a good idea, it would solve startup issues with RO files.

    First time I used Plex btw. It's great and all that but apparently it doesn't support playing from RAR archives. Unfortunately I didn't know this before I bought the Plex app.

    Hmm.. couldn't this be an opportunity for this plugin? Beat standard Plex by adding this. I'm sure you can figure out some clever solution adding RAR support here, using Kodi or some layer extracting on the fly or something. From reading several forums etc it would definitely be big news! ;)

  • (My emphasis on a few lines there)

    I'm having precisely this problem with mine, I've just started using LibreElec, I'm so very very impressed so far, but stuck at this point, identical issues. (I use SMB, not NFS)

    My SMB pointers in my XML file, in Kodi, which are obviously working for Kodi - as soon as I configure them to be the 'redirects' for Plex in the Plex config, will stop the Plex docker executing and running.

    I can confirm this by SSH in, then typing in

    docker image ls


    docker container ls

    The container is pulled down, but it's not running, unless I reset those settings to default, then it's listed as running.

    So what's the easy solution?

  • Did you read the answer and how it was solved in the next post?

    You cannot use nfs:// or smb:// locations as mount points with docker. You need to mount those smb locations on LE first and use those locations

  • aka systemd mounts; look at the example mount files in /storage/.config/system.d/

  • Thanks both of you guys, to clarify, I imagine this means there's no way to do this (currently) in LibreElec front end interface, need to be smarter users SSH'ing in and what have you?

    (I'm ok with that, I just was curious if there's a simple solution)

    EDIT: Also, does anyone know, the precise command syntax I can do, for testing in the SSH session, before writing the file?

    I do not have a user / pass (guest access) so it's a little bit unclear in the doco, hence wanting to fiddle

  • Kodi can use SMB from within Kodi. Plex (in docker) cannot access mounts via Kodi. So mount in the OS and then configure both Kodi and Plex to use the same /storage/mountpoint(s) for the remote SMB/NFS shares.

  • Kodi can use SMB from within Kodi. Plex (in docker) cannot access mounts via Kodi. So mount in the OS and then configure both Kodi and Plex to use the same /storage/mountpoint(s) for the remote SMB/NFS shares.

    Thank you for replying again!

    Sorry for more dumb questions,......... I've found a tuturial on how to mount an SMB, including editing several files and rebooting.

    However, I'm curious if I can just do testing first and mount an SMB share, without a reboot? (initially)

    I've tried this command, which IS working on my Raspberry Pi.
    mount -t cifs // /tmp/bob

    It's not working on LibreElec though :/

    It's spitting back "invalid argument" at me.

    So I figure the synatx for the mount command, in LibreElec is different (slightly) to the syntax of mount command in tutorials I'm finding across the web, for Linux.

    Hopefully this thread helps someone else too.

    Edited once, last by FeFiFoFum ().

  • Read post #24 again. Follow the comments in the files.

    I'm asking what the syntax is, to manually mount them, just temporarily for testing, without a reboot.

    Following the standard process using the mount command regular syntax is resulting in

    "invalid argument"

    Is this not possible?

  • I'm having trouble and I'm flowing instructions to the letter at this point?

    cd /storage/.config/system.d

    nano storage-MediaOnARRAY.mount

    Filename I've even done, case sensitive!

    LibreELEC:~/.config/system.d # systemctl enable storage-MediaOnARRAY.mount

    Created symlink /storage/.config/system.d/multi-user.target.wants/storage-MediaOnARRAY.mount → /storage/.config/system.d/storage-MediaOnARRAY.mount.

    Bear in mind also! This exact command works flawlessly, for a temporary mapping. So clearly the path and credentials and permissions are all correct:

    "mount -t cifs -o username=XXXXX,password=YYYYYY // /storage/MediaOnARRAY"

    So where to now? I'm lost, any tips?

  • I have googled and found the command:

    systemctl start <filename>.mount


    LibreELEC:~/.config/system.d # systemctl start storage-MoviesOnARRAY.mount

    Job for storage-MoviesOnARRAY.mount failed.

    See "systemctl status storage-MoviesOnARRAY.mount" and "journalctl -xe" for details.

    Which spat this out for me:

    systemctl status storage-MoviesOnARRAY.mount

    This makes no sense, the password is 1000% the correct one?

    I've even remade a new file and tried again, no go.

    My password has punctuation in it, does it not like ! ^ # % etc?

  • and in the interest of helping others, it's fixed - it was indeed quotation marks for the complicated password.

    Also please bear in mind, you need to put the password AND the username in quotation marks, if a quotation mark is required.

    Thanks for enduring my posts, hopefully google indexes and helps people :)