Google Chrome addon no audio

  • When I use the Google Chrome add on I have no audio.

    I tried to configure the option custom audio device in the add on setting but I could not figure out what to fill in.

    Can any one give my instruction how to fill in the option custom audio device to make audio work.

  • I have fixed the problem. I wrongly configured the custom audio option.

    My wife is now happy that we now can use Ziggo GO

    So I will not try out your suggestion because if I break it again I have a unhappy wife -:)

  • I have the custom audio option configured with HDMI:card=PCH. Otherwise I don't have audio with my NUC, HDMI is on alsa 0,3 and 0,7, I don't have any other analog output devices. I would like to add some shortcuts to favorites directly (ZiggoGo / Spotify for example), so I tried to use Chromelauncher. I can't get audio to work though.

    To try to fix it I edited the of chromelauncher, I added --alsa-output-device=plughw:0,3 (or 0,7) this won't help. I don't understand why I have to configure the audio output in the Chrome add-on anyway, shouldn't one of my HDMI outputs be the ALSA default because I don't have analog?

    Any insights on how to get this to work or any other way to create shortcuts?

  • It is the custom audio option of the CHrome add-on settings. These options get loaded when /storage/.kodi/addons/ is started. But when I use Chrome-launcher these options seem to be overriden. If I am correct, the value that I put in the custom audio field is directly loaded in the $ALSA_DEVICE variable.

    I think the problem lies in the Chrome-launcher addon, it does not recognize the location of Google-Chrome. So I have to manualy tell it where it is, but /storage/.kodi/addons/ is not recognised as chrome. So I select the actual Chrome location, thus al the tweaks in chrome-start are not carried over.

    Maybe I should to try to stop and start pulseaudio like it is in /storage/.kodi/addons/


    I have it running now on my laptop (live usb) which does have an analog output, I made no custom config or script changes. I'm going to run this live-usb on my NUC tonight to see if it works. If not, it probably has to do with the custom audio.


    I have tested the live-usb, no audio when used on my NUC. So I started to check the chrome-launcher files to see if I could find a starting point to begin fixing this. As I found out if you use a custom path to Chrome, which is needed with your Chrome addon, the is completely skipped. Thus the chrome-start of your add-on is called on opening of a url. But in this case all the chrome_OPTS variables are not loaded. Which is a problem if you need to use a custom audio device to get sound. To get around this I hardcoded the options, which is not a long term solution becasue this might be overwritten with a future update. For now, I have shortcuts in Kodi Favorites and working audio :) .

    # start chrome

    # $chrome_OPTS \

    LD_PRELOAD=/usr/lib/ $ADDON_DIR/chrome-bin/chrome \

    --alsa-output-device=plughw:0,3 --enable-gpu-rasterization --enable-accelerated-2d-canvas --ignore-gpu-blacklist --enable-accelerated-video \

    --no-sandbox \

    --user-data-dir=$ADDON_HOME/profile \

    --test-type [email protected] \

    2>&1 | tee $ADDON_LOG_FILE

    Edited 3 times, last by lexi81 ().

  • Hi there. I'm using beta version of Leia through Libreelec. I've installed the Chrome add on from the repository but it has no sound. I've used the custome audio mapping you guys have stated here and still nothing. I'm using HDMI, can you please help me.

  • Same here exactly. My Chrome installation shows the dependency as missing and not available. Unsure if that has some thing to do with this issue

    Edited 2 times, last by JDDart ().

  • Same problem on my NUC5CPYH with v8.90.007 ALPHA.

    Will have to try the bash script previously mentioned and new 8.90.008 ALPHA...

  • Tried 8.95.3 (9 beta 3) still same issue : No sound when using HDMI output.

    HOWEVER, i have the exact same Intel NUC5CPYH PC in another room using analog output and it is working fine right out of the box.

    Tried 2.0, 5.1, 7.1 with and without passthrough still no go with HDMI.

    Note that this audio setup is working fine with latest stable release and Chromium ??...

    Edited once, last by Ti-Paul ().

  • get system tools addon from libreelec repo

    open and type aplay -l

    shows list of your output devices...

    make note of the one that you are going to use

    nano /storage/.kodi/browser_addon/chrome/bin/chrome_start

    there is a alsa section and where it says:

    chrome_OPTS="$chrome_OPTS --alsa-output-device=$ALSA_DEVICE"

    chrome_OPTS="$chrome_OPTS --alsa-output-device=plughw:x,y"

    and add the device and id in it

    save and exit

    make sure you have the keep sound alive option OFF

    and it should work,,,

    if not working at first try, go through the entries for your output device one by one...shouldn't be to many

    Lenovo M73 tiny
    8 Gig Ram
    650 gig snail slow hard drive
    LibreELEC v.9

    Edited once, last by Darkyputz: removed duplicate --alsa-output-device=plughw:x,y" ().