Posts by lexi81

    It is the custom audio option of the CHrome add-on settings. These options get loaded when /storage/.kodi/addons/browser.chrome/bin/chrome-start is started. But when I use Chrome-launcher these options seem to be overriden. If I am correct, the value that I put in the custom audio field is directly loaded in the $ALSA_DEVICE variable.


    I think the problem lies in the Chrome-launcher addon, it does not recognize the location of Google-Chrome. So I have to manualy tell it where it is, but /storage/.kodi/addons/browser.chrome/bin/chrome-start is not recognised as chrome. So I select the actual Chrome location, thus al the tweaks in chrome-start are not carried over.


    Maybe I should to try to stop and start pulseaudio like it is in /storage/.kodi/addons/browser.chrome/bin/chrome-start.


    [EDIT]

    I have it running now on my laptop (live usb) which does have an analog output, I made no custom config or script changes. I'm going to run this live-usb on my NUC tonight to see if it works. If not, it probably has to do with the custom audio.


    [EDIT2]

    I have tested the live-usb, no audio when used on my NUC. So I started to check the chrome-launcher files to see if I could find a starting point to begin fixing this. As I found out if you use a custom path to Chrome, which is needed with your Chrome addon, the script.sh is completely skipped. Thus the chrome-start of your add-on is called on opening of a url. But in this case all the chrome_OPTS variables are not loaded. Which is a problem if you need to use a custom audio device to get sound. To get around this I hardcoded the options, which is not a long term solution becasue this might be overwritten with a future update. For now, I have shortcuts in Kodi Favorites and working audio :) .


    # start chrome

    # $chrome_OPTS \

    LD_PRELOAD=/usr/lib/libGL.so $ADDON_DIR/chrome-bin/chrome \

    --alsa-output-device=plughw:0,3 --enable-gpu-rasterization --enable-accelerated-2d-canvas --ignore-gpu-blacklist --enable-accelerated-video \

    --no-sandbox \

    --user-data-dir=$ADDON_HOME/profile \

    --test-type [email protected] \

    2>&1 | tee $ADDON_LOG_FILE

    I have the custom audio option configured with HDMI:card=PCH. Otherwise I don't have audio with my NUC, HDMI is on alsa 0,3 and 0,7, I don't have any other analog output devices. I would like to add some shortcuts to favorites directly (ZiggoGo / Spotify for example), so I tried to use Chromelauncher. I can't get audio to work though.


    To try to fix it I edited the script.sh of chromelauncher, I added --alsa-output-device=plughw:0,3 (or 0,7) this won't help. I don't understand why I have to configure the audio output in the Chrome add-on anyway, shouldn't one of my HDMI outputs be the ALSA default because I don't have analog?


    Any insights on how to get this to work or any other way to create shortcuts?

    That might indeed be the case. I have enabled the gpu override setting in flags and now it is says hardware decoding is enabled. But when playing a video it still does software decode. Quality is enough for the occaisional stream I watch though.


    Thanks!

    I have installed #0626 which should have Chrome. But the repo has not been rebuild yet. I installed your last zip again and things are different now. See Photo. Intel is selected in settings.

    I've run the final installation method zip. Chrome runs, widevine seems correctly installed as I can stream video on ziggogo.tv. It doesn't use hardware decoding though. I'm running millhouse LE9, a build without xorg (or did I misunderstand that change). In the GPU output I see that hardware decoding is disabled, yet it doesn't say unavailable. So it should be possible on my hardware, this is an oldish celeron NUC 847dye. When I run Cloudready ChromeOS and install Widevine I can stream full HD without issues in Chrome.


    Anything I can do to get this sorted out?