Geniatech Mygica HDStar DVB-S2 USB HD not working

  • ??

    dmesg | grep dvb is not working or is not outputing anything ?

    Never mind... Everything seems to be OK now... it might be something wrong I did.

    I can Confirm this IMG is working 100%, Thanks again.

    Edited once, last by Softlander ().

  • CvH I'm wondering, Is it possible to use the remote control supplied with the tt-4600 for example with libreelec?

    I've created a keymap for the S2-4600 about two years ago, but not used it (and never tested with LE9). Use ir-keytable -c -w <file> to load.

    There are some issues: all keys are using two different key codes (handled by the keymap) and there is a fast autorepeat than cannot be configured.

  • I've created a keymap for the S2-4600 about two years ago, but not used it (and never tested with LE9). Use ir-keytable -c -w <file> to load.

    There are some issues: all keys are using two different key codes (handled by the keymap) and there is a fast autorepeat than cannot be configured.

    thanks a lot mglae you have saved me a huge time writing that keytable file and it works with the IMG that is used in this thread. I have read the wiki carefully and found that there is no working keytable file that is ready to be used so I had to jump to "the hard way" part of that tutorial and when I have reached to the part where I have to relate every scancode to its Linux keycode I knew the amount of job you have done to write the keytable.

    Anyway, yes it has only one issue and that is the "Autorepeat", I have tried to disable for example 0xd43 for KEY_1 and leave only 0x543 active as they are both scancodes for key number 1 but it didn't work. I still for example scroll more than one line on TV channel list when I have only pressed the "Down" key one time only. I think I will start a new thread asking about this issue.

  • Hi everybody,

    this is my first post, very glad to be here...

    Could a kind soul check if his/her HD Star can tune and demultiplex correctly

    low symbol rates (under 15000 KSym/s) transponders with this driver ?

    I am still using it under Windows and it works ok for 22000/27500/30000 KSym/s DTH transponders,

    while it tunes correctly many feeds with 7200/9874 SR but provides no data...

    I wrote to Geniatech and they are looking into it (and they did it ! Now the Windows driver works for low SRs as well....).

    Thank you in advance.

    Edited once, last by nokia-lover: Geniatech provided me with an update Windows driver which works also for low SR transponders. ().

  • Sorry, I can only test it using symbol rates of 22000, 23000 and 27500 KSym/s. I have noticed a similar issue when transponders use Forward Error Correction of 3/4. I can tune into the transponder, but the feed is full of audio and visual distortions. My TV manages to tune into the same transponders without any issue, but it doesn't have any record function.

  • Hi, I have Terratec Cinergy S2 USB rev.4 and only with alpha 7 and newest dev build from Millhouse with Crazy Cat dvb drivers device almost properly working except some transponders with 3/4 FEC , same issue post #95, i don't tested this step by step transponder by transponder fec by fec symbol rate but channels with fec 3/4 and symbol rate 27500 have many errors "BER" and watching is immposible, i checked on dmesg output and device is attached but something is maybe with message "ds3k_firmware_ondemand: Waiting for firmware upload (2) "dvb-fe-ds3103.fw" and message "usb 1-2: DVB: adapter 0 frontend 0 frequency 0 out of range (95000..2150000), I tested this card on 3 antenas with diseqc and without, also maybe firmware or drive not supporting some features dvbs2 specification. I know driver for this card is fresh...also tested minisatip with no luck...

  • Perhaps this firmware >> dvb-fe-ds3103.fw file is missing in /lib/firmware/ in x86_64 build and even not uploading to this place from /storage/.config/firmware/ copied before via ssh/scp, in newest build from today and previous alpha, How to copy this firmware manually ??

  • i tried your method and i don't see this firmware in /lib/firmware folder after restart pc, before i tried firmware from openelec dvb-firmware repository with original name dvb-fe-ds3103.fw , if libreelec have specified DIR for firmware files in this location "/storage/.config/firmware this mechanism for firmware location not working in latest build... or something else is not this way...

  • today i tested on debian buster build from here "" and in demsg i have also this message even firmware dvb-fe-ds3103.fw is placed in /lib/firmware/ direcotory

    [ 263.718208] dw2102: su3000_power_ctrl: 1, initialized 1

    [ 263.810176] ds3k_firmware_ondemand: Waiting for firmware upload (dvb-fe-ds3103.fw)...

    [ 263.810178] ds3k_firmware_ondemand: Waiting for firmware upload(2)...

    [ 306.254962] ds3k_firmware_ondemand: Waiting for firmware upload (dvb-fe-ds3103.fw)...

    [ 306.254965] ds3k_firmware_ondemand: Waiting for firmware upload(2)...

  • Method for firmware uploading

    1. create directory /storage/my-firmware/lib/firmware

    ssh [email protected] ENTER / PASSWORD "libreelec" //default password

    mkdir /storage/my-firmware

    mkdir /storage/my-firmware/lib

    mkdir /storage/my-firmware/lib/firmware

    2. create file

    nano /storage/.cache/kernel-overlays/90-my-firmware.conf

    with code:


    / save file with ctrl+shift (:wq)

    3. copy firmware from other computer to libreelec:

    scp /path/to/dir/with/firmware/file/firmware_name.fw [email protected]:/storage/my-firmware/lib/firmware/

    ENTER / PASSWORD "libreelec" //default password

    reboot libreelec

    check /lib/firmware

    4. ssh [email protected] ENTER / PASSWORD "libreelec" //default password

    5. ls /lib/firmware

    if firmware is listed you done all ok


  • use that file and rename it to dvb-fe-ds3103.fw


    the file was renamed at the kernel sources -> crazycat uses the old name

    pls report if this works, if so i push a fix

    this not fixed this problem with fec 3/4 symbolrate 27500000

    I found this :

    updatelee / v4l-updatelee / Pull request #4: some fixes for Linux 4.9-rc6 — Bitbucket

    • [media] ds3000: Extended chip ident check. Thanks crazycat.
    • [media] dw2102: Combine SU3000 (and OEM) support. Thanks crazycat. fixes Geniatech SU3000 v3.0 hardware, by providing a method to detect Montage ds3000 or m88ds3103 demod. Then attaching the proper demod module. SU3000 v3.0 hardware has ts2022/m88ds3103 chips on board and the ds3000 module previously wasn't working with this hardware. We now attach the proper m88ds3103 demod for rev3, and ds3000 for the older versions.

    but when i tried compile this kernel i have this

    updatelee / v4l-updatelee / issues / #10 - compiling error. — Bitbucket


  • Been trying to get my tuner to work and with the images and drivers from here I got it to being recognized in tvh but I'm unable to scan for channels any ideas?