problem second monitor

  • Hi,


    I installed libreelec on a usb pen, I tried to boot on a notebook which is connected to a 42-inch samsung tv with a vga cable.

    The system starts without problems, only I can not see it in full screen on the TV.

    I tried to connect in ssh and run the following commands:

    xrandr - output LVDS1 --off && xrandr - output VGA1 --mode 1920x1080 --rate 60.00

    but the result is always the same, how can I do?


  • Kodi only supports clone mode for multiple monitors, so if your notebook only has 1366x768 for example, then that will be the leading screen resolution. Perhaps you can somehow turn off your notebook screen and make the TV the primary display.

  • but the result is always the same, how can I do?

    first...what Klojum said is 100% correct.


    Normally on laptops, depending on the specific manufactor and model, you can use some keypress-combination with the FN-keys and some of the F-keys (F1, F2....) to switch monitor outputs.


    Possible options might be:


    - expanded: the screen is exanded over 2 monitors

    - internal only: the 2nd monitor output on your laptop is disabled

    - external only: the laptop screen is disabled and only the additionally connected monitor is in use

    - mirrored: both screens are showing the same


    I guess you are using "mirrored". Either try to switch the monitor outputs to use "external only" or provide the output of the command:


    xrandr | pastebinit


    to see which monitors are currently active. Then we might be able to turn specific montors on or off.

  • Hi, i tried to switch off the internal monitor with the FN-Keys but don't works it always remain in mirrored state


    then i tried with the command: xrandr --output LVDS1 --off


    and it worked, the internal monitor powered off, but the external monitor don't change it


    so i tried with the command: xrandr --output VGA1 --mode 1920x1080 --rate 60.00 but don't change it


    In the afternoon i'll try the command "xrandr | pastebinit" and i'll post the result


    thks

  • Once you have the correct sequence, perhaps you can put the commands in the autostart.sh file so LibreELEC can boot with them.

  • i tried the command xrandr | pastebinit, in attachment the screenshot ,


    the monitor set it isn't correct because the tv is 40'', how can i do to set it?


    and how can i do to set it at the boot?


    thks



  • Kodi evaluates what to use at start, so turning the display off after Kodi starts won't result in Kodi dynamically reconfiguring itself. Stop Kodi, run the command, start Kodi again and it should only detect the active panel. If that works we can script it at startup.

  • If your notebook / laptop does not have an hdmi port, it may not support 1920 X 1080. Can you select 1920 X 1080 in the laptop's display settings ?


    What's the make and model of your laptop ?

    Is your TV 720p or 1080p ?

  • hi chewitt, after i'll try


    systemctl stop kodi

    xrandr --output LVDS1 --off && xrandr --output VGA1 --mode 1920x1080 --rate 60.00

    systemctl start kodi


    this is correct?


    thks