Test LibreELEC images with KODI-18 for S9xxx

  • friend balbes150 I repeat again the degree of difficulty and gigantic!


    1- aml_autoscript.zip does not install the same unplugged, and does not reboot

    2- I tried to install aml_autoscript.zip via pen driver reboot plus goes to debug screen with error.

    3- I tried to install only the zip file aml_autoscript.zip via SD and pen driver error again!

    4- I edited the uEnv.ini file: dtb_name = / dtb / meson-gxl-s905d-ki-pro.dtb

    5 - I edited the extlinux file in the same way: dtb_name = / dtb / meson-gxl-s905d-ki-pro.dtb

    6- rename the file: meson-gxl-s905d-ki-pro.dtb to dtb.img and put it in the root of the card!

    but not boot at all.


    All options without success!


    balbes150 If you have any more ideas on how to solve this friend

    I'm your beta test!

    Thank you.


    Error Photos aml_autoscript.zip


    It is useless knowledge if not shared the world.

  • ..to activate the multiboot via aml_autoscript.zip you need to boot android and use the "update&backup" app there. choose aml_autoscript.zip from the card(inserted after android boot) and the box should after some seconds try to boot from external media. All attempts to update via recovery directly seem not to work..

  • ..to activate the multiboot via aml_autoscript.zip you need to boot android and use the "update&backup" app there. choose aml_autoscript.zip from the card(inserted after android boot) and the box should after some seconds try to boot from external media. All attempts to update via recovery directly seem not to work..

    The same thing happens here

    I waited up to 15 minutes.

    Unsuccessfully!

    It is useless knowledge if not shared the world.

  • Hmm, strange. Which android version is on your device? Did you try to boot other os like armbian or something other from card/USB? On a friends box he had problems with LE(other build hence other cpu) too, but those were away after (successfully) trying to boot an armbian for that device. Maybe that attempt works(with suitable armbian) for you on that picky s905d-box too?!

    Others reported it depends on sd-card if the could boot another system. Did you try other card(s) too?
    All I can say is, that for me(and my neighbours) LE(and armbian of course) work on several s905x/s905w devices pretty well and is there easy to install and use...

  • Thanks friends for help shippy , turgus  :thumbup::thumbup:

    (Not possible with the balbes150 compilation)

    I use Coreelec + Libreelec perfectly!

    All versions

    I have tried all possible methods mentioned here.

    (I'll try to initialize an armbian)

    I also tried this maneuver quoted in the Coreelec forum.

    I always use good quality SD card sandisk ultraHD 16GB

    My box KI Pro (S905D)

    Thank you all.

    It is useless knowledge if not shared the world.

    Edited once, last by erbas ().

  • Dostum bana Türkçe olarak yardımcı olabilir misin?


    Ya da başka kanaldan iletişime geçebilirim senle, Telegram, Whatsapp, Skype.

    Hangisi uyarsa.


    Sevgiler...

  • No problem 😃 Did you solve your boot issue though?


    Also, it's preferable to use Rufus (not Etcher or Win32DiskImager) to burn your image. For a while I had a problem booting from USB sticks. Today I took CE Forum recommendation (which wasn't clearly explained earlier) and used Rufus- my USB stick now boots.


    Even on a box with internally installed old CE version, the USB stick boots, eventually. It gave me problems ( alternate flashes of box and CE boot screens, then dark screen), but then it booted in Kodi safe mode !

  • No problem 😃 Did you solve your boot issue though?


    Also, it's preferable to use Rufus (not Etcher or Win32DiskImager) to burn your image. For a while I had a problem booting from USB sticks. Today I took CE Forum recommendation (which wasn't clearly explained earlier) and used Rufus- my USB stick now boots.


    Even on a box with internally installed old CE version, the USB stick boots, eventually. It gave me problems ( alternate flashes of box and CE boot screens, then dark screen), but then it booted in Kodi safe mode !

    Not possible with the balbes150 compilation

    With Libreelec or coreelec perfectly!

    I have always used Openelec successfully libreelec

    My only problem is in the balbes150 version

    It is useless knowledge if not shared the world.

  • Follow this excellent tutorial of the Khadas forum simple and practical

    Instructions: Activating Multi-Boot - Khadas VIM - Khadas Community

    This way Multi-Boot has been successfully installed:thumbup:


    I burned the LibreELEC-S905.arm-9.1-devel-20190123095652-2f2cce8.img.gz image with rufus-3.1, I edited the uEnv.ini file with my existing dtb folder meson-gxl-s905d-ki-pro.dtb

    Even so the image does not leave the screen mecool!:thumbdown:

    If I try to activate the Multi-Boot again using the files of the boxed SD card it shuts off and does not reboot!

    balbes150  

    It is useless knowledge if not shared the world.

  • Wetek uses its (special) multi-boot system. Previously, I sent this user a special additional file that allows you to run the system on Wetek in multi-boot mode. This has nothing to do with your model.



    Turn off TV box and add in manual in the first partition (FAT) the file "dtb.img". On the media there is a directory dtb from where you can take the files and copy them to the root of the renaming of "dtb.img".

    This item is no longer used. Instead, you need to edit the file " uEnv.ini" (the details there is in this topic).

  • If you have any more ideas on how to solve this friend

    I'm your beta test!

    All the instructions on how to activate multiboot exactly says that you need to use the toothpick method or the Android application (Update&backup) to start the activation of multiboot. Attempted to run the recovery or TWRP will not be able to be activated.



    The same thing happens here

    I waited up to 15 minutes.

    Unsuccessfully!

    After activation, the system automatically tries to start LE. If you have not correctly configured which DTB to use , the system will not be able (after auto-activating multi-boot) to continue starting LE.



    I edited the uEnv.ini file with my existing dtb folder meson-gxl-s905d-ki-pro.dtb

    DTB's test which is added AFL1, I didn't check his work. Maybe he's not working. Check the run with different DTB.



    Even so the image does not leave the screen mecool!

    You are sure that your equipment is working DTB ? Do you know other users (or have seen the description) with the same model as you who have a kernel 4 (LE or Armbian) running ?

  • Hi, on my tx3 mini I got no sound with all 4.x Kernels. Also a usb sound card did not work either. Using an older 3.14 sound works properly both ways(usb and av). Is there a trick I'm missing to get sound in addition to video on monitor?!

  • I uploaded a test version for Odroid C2 to the website 20190124.

    For use. After burning the image to the Sd card, it is necessary to edit the file "/extlinux/extlinux.conf " - specify the DTB for Odroid C2 in it. Checked on your Odroid C2. The standard audio output via HDMI does not work yet. Works USB sound cards (I checked several different models, everything works). USB WiFi works (I tested on one simplest option I have). KODI interface does not slow down at 1080p, the mouse works fast. The wired network works. Please check the operation of the standard remote control for Odroid C2.

  • On newest build the usb sound works nicely, but the Ethernet needs every time to be reactivated after reboot in libreelec settings. Is there a way to avoid that? Also I got problems watching some streams via Zattoo-HQ Plugin(Zattoo live tv works), but that needs some further testing(and comparing settings with box running older LE version). Test box for fresh version is as always x96mini 2/16G (armbian on eMMC)

  • Thanks, the new image works with usb sound! Will there be also a arm version to use amazon vod/netflix?!