Test LE images with Kodi-19 for S9xxx

  • S9xxx with triple x means that my S905 is just not supported.

    try Index of / -> LibreELEC-AMLGX.arm-9.80-nightly-DATE-box.img.gz

    then edit the uEnv.ini


    best guess

    dtb_name=/dtb/meson-gxbb-p201.dtb

    or

    dtb_name=/dtb/meson-gxbb-mecool-ki-plus.dtb

    or

    dtb_name=/dtb/meson-gxbb-kii-pro.dtb

    or

    dtb_name=/dtb/meson-gxbb-mecool-kii-pro.dtb


    maybe that works, the images from balbes are different to the LE ones, maybe that helps already

  • I have a Khadas Vim3 and I have just installed the following image:


    "LibreELEC-ARMv8.aarch64-9.80-devel-20200811062231-f9264f5-amlg12.tar"


    I have my device connected to the network via LAN but the network never comes online (see the attached image). Previous version of the software used to work though.


    I can confirm that the LAN cable is working 100% since I tested it with another device. Many thanks.

  • hi. ALL

    can anyone help me with the choice of version for x96 max +



    - CPU: Amlogic S905X3 64-bit Quad Core ARM® Cortex™ A55;

    - GPU: G31™ MP2;

    - Android 9.0 OS;

    - RAM/ROM: 4GB/64GB;

    - Support HD: [email protected], 4K @60fps, UHD, HDR+;

    - Support HD: DLNA/Airplay;

    - Support HD 2.1, USB3.0, USB2.0;

    - Support 2.4GHz Wifi/2.4G+5.8GHz Dual Wifi, BT4.1;


    I tried this LibreELEC-AMLGX.arm-9.80-nightly-DATE-box

    and a few different dtb options but doesn't boot from pendrive



    thank you!.

  • Pay attention. Starting from version 20200826, the configuration order for the used DTB changes.

    Please note that the algorithm for initial configuration of the system for startup has changed. Instead of a file "uEnv.txt", is now used the file "/extlinux/extlinux.conf " . The rules for editing a file remain the same.

    You no longer need to manually add the u-boot.ext file , it is included in the image.

  • Edits made as mentioned above for mecool KI Pro: ok boot

    I immediately received an error, which apparently and in the usb usb ports do not work to complete the installation with usb remote.


    Can help balbes150

    Code
    1. LABEL LibreELEC
    2. LINUX /KERNEL
    3. FDT /dtb/amlogic/meson-gxl-s905d-p230.dtb
    4. APPEND boot=LABEL=LIBREELEC disk=LABEL=STORAGE quiet console=ttyAML0,115200n8 console=tty0 systemd.debug_shell=ttyAML0

    There is no dtb suitable for K1 Pro as in previous builds, I used meson-gxl-s905d-p230.dtb

    It is useless knowledge if not shared the world.

    Edited once, last by erbas ().

  • Pay attention. Starting from version 20200826, the configuration order for the used DTB changes.

    Please note that the algorithm for initial configuration of the system for startup has changed. Instead of a file "uEnv.txt", is now used the file "/extlinux/extlinux.conf " . The rules for editing a file remain the same.

    You no longer need to manually add the u-boot.ext file , it is included in the image.

    This sounds good, much improvement but I see that beelink dtbs are removed for some reason.

    I will follow up with the new changes.


    Thanks

  • chewitt I wonder if the constructions LibreELEC-AMLGX.arm-9.80-nightly-20200809-63dfb3b-box.img.gz

    Last construction will be updated: 20200809

    Thank you.

    It is useless knowledge if not shared the world.

  • With LibreELEC-ARMv8.aarch64-9.80-devel-20200828054510-729c262-amlgx.img, there is a new usb driver which crashes. I see major reorganizations in the dtb files.



    Any tips?


    Anyways, someone broke usb support in the kernel.. Re: [PATCH 1/1] usb: dwc3: meson-g12a: fix shared reset control use — Linux USB; I'm going back to the previous release until this is fixed.

    Edited once, last by phlp11 ().

  • Thanks to the help of LE developers (@narmstrong @warpme etc), managed to build a test version of the image for g12 (s905x2\s922), which uses Panfrost (the test image is located in the 20200907 folder) I hope that the next test image LE will contain a complete set for all platforms, including the g12.. :)

  • For my particular TV the images have the same problem as the armbian images.

    The HDMI is buggy. It switches to the unsupported mode [email protected] where the screen flickers like crazy. It also takes over ALL HDMI input modes on my AVR. I posted about this in the armbian forum. (pioneer 50 inch plasma + s905x3 TV box)