[8.2.4.1] LibreELEC Kodi Krypton - S905 & S912 devices

  • Hi, I have a tanix tx9 pro s912 with lp ram model and I install libreelec 8.2.2.3 because I try other one and it doesn't work. I have a black square on the boot and stuck on it. I tried few version and few dtb.

    I would like to install latest version because I have stuttering due to subtitles. I added the the advancedsettings with dirty region and I have still stuttering. Have you an idea of what I need to do?

  • Whats the latest build available for u9h? On mine is says Libreelec (wrxtasy-kszaq) 8.2.5-chroma.42w.10bit

  • Whats the latest build available for u9h? On mine is says Libreelec (wrxtasy-kszaq) 8.2.5-chroma.42w.10bit

    You are correct. This is the latest version available for download from mega link provided few posts above. I'm running it on my Minix U9-H without any problems with "standard" 1080p and 2160p HDR content as well.

  • I don't know which CE versions you tried, but guessing from what you wrote earlier it's 8.95.6. That version uses Kodi Leia RC2 which doe not need Whitelist at all.

    Stable version CE 9.0 is available and now it works on my S912 box

    Previous versions where partly faulty.


    Know waiting for mainline

  • Glad that it finaly works for you.

    Must say that I never experienced any unsolvable problem on beta versions

    ODROID N2_S922 4G - 1GB Ethernet, X92_S912_q201 3/32G - 1GB Ethernet Box_Android 7.1.2, Mocool KM8_S905X 2/16 0.1GB Ethernet Box_Android 8.0, X96Mini_S905W 2/16G 0.1GB Ethernet Box_Android 7.1.2

  • Glad that it finaly works for you.

    Must say that I never experienced any unsolvable problem on beta versions

    Can only tell You that beta versions didn´t play most 4k HDR videos on my S912 box.

    My S905X boxes are still running stable LE version.

    But I´m not using IPTV, DVB-S, DVB-T and other special thinks (plex, docker etc.) only watching video/music from NAS.

  • Well, I use my X92 box at home and on the move, and most of the time I use HBO Go Eu and Netflix Kodi addons.

    Netflix at 720p (Sw decode) and HBO Go Eu (1080p Hw decode) work perfectly.

    Prefer these addons to my smart tv apps because of my intensive use of subtitles which are a disgrace on my tv apps.

    ODROID N2_S922 4G - 1GB Ethernet, X92_S912_q201 3/32G - 1GB Ethernet Box_Android 7.1.2, Mocool KM8_S905X 2/16 0.1GB Ethernet Box_Android 8.0, X96Mini_S905W 2/16G 0.1GB Ethernet Box_Android 7.1.2

  • Well, I use my X92 box at home and on the move, and most of the time I use HBO Go Eu and Netflix Kodi addons.

    Very different user profile - different requirements - not comparable.

    Yes I know, some users want to use a cheap amlogic box like a personal computer :cool:

  • Very different user profile - different requirements - not comparable.

    Yes I know, some users want to use a cheap amlogic box like a personal computer :cool:

    Don't see why not use it when it does everything I need, and cheep is only another plus :)

    ODROID N2_S922 4G - 1GB Ethernet, X92_S912_q201 3/32G - 1GB Ethernet Box_Android 7.1.2, Mocool KM8_S905X 2/16 0.1GB Ethernet Box_Android 8.0, X96Mini_S905W 2/16G 0.1GB Ethernet Box_Android 7.1.2

  • Hi and thanx for the great job!

    I got a MINIX U1 with LibreELEC-S905.arm-8.2.4.2-S905Test-1529136339.img.gz and everything is working fine, except 2 Points:

    - when i play a channel on Live TV 1080p, it shows only black screen and in the right corner of the OSD Menu the symbols are flickering.
    other channels work fine.
    - under Network it shows my Connections and adresses, except my DNS doesnt show up.

    The only AMLOGIC Extras i activated is the Force RGB, cause the used TV is a old Philipps.

    Am i using the right Image and is there a way to get my 1080p channels working in RGB Mode?

    And is it normal that my DNS is not diplayed?


    thnx!

  • Don't see why not use it when it does everything I need, and cheep is only another plus :)

    Hello all, been reading over the posts and content on the site am glad this is such a helpful community. Was wondering if I could get some info as I have become a little confused on how to proceed. Just purchased a X96 mini 2g/16g for my wife's home office TV and looking to run a stable version of LE on it. Which build should I run and where can I find it, and do I need a special dtb.img? I will be running LE off of a SD card. Thanks for the help in advance and I do apologize for the noobie questions, I just don't want to brick the device.

  • Hi, I have a tanix tx9 pro s912 with lp ram model and I install libreelec 8.2.2.3 because I try other one and it doesn't work. I have a black square on the boot and stuck on it. I tried few version and few dtb.

    I would like to install latest version because I have stuttering due to subtitles. I added the the advancedsettings with dirty region and I have still stuttering. Have you an idea of what I need to do?

    To complete my post I try something.

    I installed LE version 8.5.2-chroma.422.10bit.img.

    I tried with q201_3g_1gbit q201_3g q201_2g

    And no one works. Stuck on boot screen with black square.

    I use the same LE with q201_3g from version 8.2.2.3 and it works but have same stuttering with subtitles. I think that it's logic because it's the dtb that increase gpu to fix the issue.


    For information I installed coreelec and I use q201_3g_1gbit. With LE I can't use 1gbit version.


    Si I think that it's an issue between dtb file and my device.


    If anyone have a solution plzase help me.

  • Fabrice95 you can try this in "advancedsettings.xml"


    <advancedsettings>

    <gui>

    <algorithmdirtyregions>0</algorithmdirtyregions>

    </gui>

    </advancedsettings>


    if you dont have one, you must create a plain text file - name as mentioned above - an copy the code into it. Then drop the *.xml into the USERDATA folder and reboot kodi.


    This helps me on my S912 (Beelink Ultimate GT1). Stutters are gone now.

    Based in GERMANY — working in cigar business — part time freelance webdesigner — PS4 Console Gamer and TV Show Junkie :cool:


    S912 with CE on NAND — S905x with CE on SD-Card (with EmulationStation&KODI shanti‘s build) - Odroid N2 with CE on emmc and EmuELEC on SD-Cad — 4K 65“ Sony — 4K Onkyo DD/DTSHD/ATMOS Receiver



  • Hello all, been reading over the posts and content on the site am glad this is such a helpful community. Was wondering if I could get some info as I have become a little confused on how to proceed. Just purchased a X96 mini 2g/16g for my wife's home office TV and looking to run a stable version of LE on it. Which build should I run and where can I find it, and do I need a special dtb.img? I will be running LE off of a SD card. Thanks for the help in advance and I do apologize for the noobie questions, I just don't want to brick the device.

    I suggest you install CoreElec latest stable version 9.0 with Kodi Leia 18 on your new box. You can find every info here

    Take care, there are new versions of X96 mini boxes that differ from old X96 boxes like mine, and they need a different dtb.img file.

    ODROID N2_S922 4G - 1GB Ethernet, X92_S912_q201 3/32G - 1GB Ethernet Box_Android 7.1.2, Mocool KM8_S905X 2/16 0.1GB Ethernet Box_Android 8.0, X96Mini_S905W 2/16G 0.1GB Ethernet Box_Android 7.1.2

  • Already try this. Unfortunately not working on my device. :-(

  • Already try this. Unfortunately not working on my device. :-(

    I believe You did somethin wrong, because Your dtb is not working etc.

    My S912 box - there is no stuttering subtitle using external .srt files running LE 8.5.2-chroma.422.10bit or CE 9.0 nightly 20190222

  • I believe You did somethin wrong, because Your dtb is not working etc.

    My S912 box - there is no stuttering subtitle using external .srt files running LE 8.5.2-chroma.422.10bit or CE 9.0 nightly 20190222

    I think so. But I don't know what because I installed successfully LE 8.2.2.3 and also Coreelec.

    What I did :

    Flash usb drive LE 8.5.2 with Rufus.

    Choose dtb from oclock s912 folder on mega (q201 3g 1gbit and also q201 3g)

    Copied it on flash drive.

    Delete existing dtb.img

    Renanme q201 3g file to dtb.img.

    Connect USB drive.

    On Android terminal : reboot update

    Black square on boot screen