nfs.mount not working

  • Please can someone steer me in the right direction. Here is my .mount file

    But it doesn't work.


    I SSH into the Minix and enabled the mount with the command "systemctl enable storage-4KMovies2.mount and the 4KMoviesUSB1 folder appears in the storage area within Kodi, but it's empty.

    Can anyone help?

  • i don't use the .mount file, just the old fashion way to manually mount via le. no issues encountered. then i just put it at the autostart.sh


    mount -t nfs 192.168.1.1:/tmp/mnt/sda1/Movies /storage/videos -o nolock

  • First....the // at: What=//192.168.1.100/i/4KMoviesUSB1


    are not needed as those are only necessary for SMB mounts. So please change it to:


    What=192.168.1.100/i/4KMoviesUSB1


    Then rename the script to


    storage-i-4KMoviesUSB1.mount


    see: Mounting network shares [LibreELEC.wiki]


    Quote

    Important: you need to use the filename for the definition file according to the folder where you want to mount your share .


    In our case storage-recordings.mount represent path → /storage/recordings.


    If you like an subfolder storage-recordings-tv.mount represent path → /storage/recordings/tv.


    You try to mount that: What=//192.168.1.100/i/4KMoviesUSB1


    So you path looks like: <ip>/<subfolder>/<source_folder>


    Therefore you need to replace the "/" for sub- and source-folders to "-" for the path that it looks like: storage-i-4KMoviesUSB1.mount

    No need for the IP in the script name.

  • Still not working. Here is the file named storage-i-4KMoviesUSB1.mount


    I sent the command - systemctl enable storage-i-4KMoviesUSB1.mount over SSH but all I get is another empty folder in the storage folder on the Minix. What am I missing? Also, how do I go about deleted the growing list of non working mounts?

    Edited once, last by CvH: fixed bb code ().

  • Just a thought. My NFS shares set up in Hanewin NFS Server go to the root of each hard drive. In this instance it is to i:\


    Is that causing the issue?

  • Well, I tried another file called storage-i.mount


    But that doesn't work either. I assume I'm doing something wrong but I can't see it!

  • could you please show us the content for the exports file. If there's any. 100% no clue how this Hanewin works.


    In this instance it is to i:\

    Normally, ^ ^ those are Windows drives and should have nothing to do with NFS at all. I don't have a clue how this Hanewin works under Windows. If you are generally using Windows and you don't have anything else available than that, I would recommend SMB as shares and mount that.

  • haneWIN NFS Server Exports file looks like this

    Code
    1. D:\ -public
    2. E:\ -public
    3. F:\ -public
    4. G:\ -public
    5. I:\ -public
    6. J:\ -public
    7. K:\ -public

    Essentially I am sharing the root of all but the boot drive on the server.

  • Perhaps you could take a quick look at this page

    Sorry, no.


    I don't use Windows anymore for a very good reason. I have a Windows running at home, but not using it much anymore. And I won't install some niche software to get a NFS server running on an OS which should better use SMB.


    Kodi and LibreELEC botth can handle SMB shares pretty fine. So my recommandation would be: drop that NFS server thingy on Windows and try SMB instead.

  • Fair enough.

    I originally stopped using SMB shares in favour of NFS as I was told it was better.

    Perhaps things have changed since then.


    In your opinion would I be better off using SMB shares and mounting them in OS with a script?

  • If you want to run NFS, try an Ubuntu Linux (Server) approach. Installing Ubuntu and setting up an NFS server and its mounts/shares is done in (under) 15 minutes, once you know how. I've been using Kodi + Ubuntu NFS for years now without a glitsch.

  • Thanks guys. I'll give SMB shares another go, however everything is now working well since I resolved my gigabit ethernet problem.


    What benefits will I see when mounting them in OS rather than Kodi?

  • For standard video usage in Kodi, virtually none, if all things work as advertised.

    But some people also use other tools/addons/paths where an OS mount is more practical.

  • It is not necessary at all to mount them at OS level, Kodi is doing it quite fine for SMB/NFS.


    You only need it if you want to mount some remote path for recording or other stuff where you need access to some Nas from outside Kodi.


    Btw in the past NFS was the only way to go for Kodi as it only used SMB1 (real real real old Samba version) that was heavily bugged. Now with LE8.2 it uses Samba 2 btw 3 that fixes that problems. So currently its no difference if you use SMB or NFS, if you use Windows for "NAS" use SMB, if you use Linux you can go with both.

  • Excellent info thanks.


    I knew I had changed to NFS for a reason those years ago. I wasn't aware of the update that addressed the issues until now. I'll change back to SMB tonight.