[S905] Device trees

  • Thanks. I'll try, I'm on 160622, with LE 005 in SD. What dtb file do you use for 006?


    NONE, for thje sdcard I just used the files from the img, all my issues start when I TRY any other dtb

    3 NUC's, 3 Pi's, Android Beelink R38, Odroid C2, 2 original XboX's and now a Amlogic T95m S905 2/8

  • KII Pro: KII Pro 2G 16G dtb.zip


    As an FYI - the gxbb_p200_2G_100M.dtb, gxbb_p200_2G_100M_RealtekWiFi.dtb and gxbb_p200_k2_pro.dtb files booted but wifi did not work.


    As a second note, these are sample boxes I am using to test an ATSC version of the KII Pro - and Videostrong shipped them with the M8S+ 4K android firmware. I have asked them for that dtb and will submit once I receive.


    Thanks!


    -- @kszaq Just to clarify...can I extract the dtb.img file from exisiting firmware and use directly on the sd card, or do you need to modify it first?

  • edit4ever AFAIK K2 Pro doesn't have a Realtek WiFi and device trees in download folder have been reported to work. You may have a different WiFi chip that is not supported yet and for this you should post your logs in an existing WiFi issues thread or create a new one.


    Whether you can use device tree from existing firmware it depends if it's been compiled for the same kernel version that is used in my LE builds. Device tree source folder for 7.0.2.007 is here: linux/arch/arm64/boot/dts/amlogic at amlogic-3.14.y-openwetek · kszaq/linux · GitHub ans here is my repository with device tree patches: GitHub - kszaq/s905-device-trees: Patch against https://github.com/kszaq/linux/tree/amlogic-3.14.y-openwetek/arch/arm64/boot/dts/amlogic


    What I do is I convert dtb to dts with dtc tool, compare manually and create a patch.


  • What I do is I convert dtb to dts with dtc tool, compare manually and create a patch.


    Thanks for the info...I'll see about making a version once I get the original firmware. In the meantime, ethernet is working with gxbb_p200_2G_beelink_minimxIII.dtb


    Might be time to pop the box and look inside to see what chips are in play! :-)

  • edit4ever I had a look at the tree you posted and it looks like you should be able to use a device tree that is already supplied with my images, i.e. you don't need to replace it. I think you might get booting issues with that device tree because your bootloader doesn't support multi-device device tree blobs and that's what supplied image is. I will later try to provide separate device trees so you can try using one.


  • I think you might get booting issues with that device tree because your bootloader doesn't support multi-device device tree blobs and that's what supplied image is.


    Your thought got me thinking about the strange firmware that was loaded on this box (listed as a M8S+ 4K)


    As a result - I went ahead and loaded the Acemax KII Pro firmware (using USB Burning Tool) and sure enough...once it booted back up, no wireless or lan connection was available in Android. So I believe that Videostrong is using different hardware for wifi and lan than Acemax is.


    The challenge now is to get Videostrong to provide their device tree or at least the M8S+ 4K firmware that they used (which looks like it may have come from Acemax anyway)...but they haven't been very responsive in the last few days.


    In the meantime - I can still get up and running on lan with your LE 007 and the minimxIII dtb. Maybe I'll try to custom build a dtb while I wait for the Videostrong response.

  • kszaq - I finally got a hold of the M8S+ 4K file from Videostrong. Actually, they have been quite helpful with information and files.


    m8s+4k.zip


    So while I have a KII Pro with custom ATSC hardware - they are using the firmware from the M8S+ 4K as it matches the components used in my build. It's not clear, but this may be the configuration of future KII builds, but they haven't finished the firmware yet - or it may be a one off for testing.


    From what I can tell - the biggest difference seems to be in the wifi section with references for the aml_broadcm_wifi and wifi_power and of course the gigabit ethernet. Maybe others, but let me know if you need anything else to generate the dtb.


    Thanks!


  • This is from s905_107L1_sdcard.zip


    For my box: Beelink Mini MX (2GB):
    ** URL removed ***


    Have you tried 7.0.2.007 with gxbb_p200_1Gbit already?
    Such works for my Mini MX G.

    player : Mini MX-G p200_2G & Inphic Spot i7 PRO p212 & Khadas VIM2 q200
    monitor : iiyama ProLite E2283HS
    speaker : UE Boom 2
    dvb-t : PCTV microStick (79e)
    firmware : android | LE 64bit | balbes 3in1 | gentoo

  • Thanks kszaq !


    Unfortunately it didn't work. In fact, that dtb didn't even show wireless networks in LE network settings.


    I appreciate your effort in trying to solve this, but know you have other priorities to work on. (Like DVB internal tuners!) ;)


    I have reached out to Videostrong to see what sort of "magic" they have done to this wifi installation and will continue to experiment on my end.

  • Hello,


    How do you extract/decompile dtb.img to dts fıle?
    I am using mini m8s II dtb.img file from posts #3 & #61.


    dtc -I dtb dtb.img -O dts -o minim8sii.dts
    When I issue above command both files give me "FATAL ERROR: the blob has incorrect magic number"


    thanks

  • Looks like you have a multi-dtb file. Maybe there's a tool for that but what I do is I look for D0 0D FE ED magic in Hex editor and then use dd to cut the file. For example, first device tree is always at 0x800 so you want need run dd bs=2048 skip=1 if=source.dtb of=dest.dtb.