LibreELEC 9.0 / Kodi 18.X for Minix X8,X8H,X8H+

  • I want to remind the questions (my box is Minix X8H+):

    1. When it stay in sort of "standby", background services (f.e. transmission) will be working?

    2. Can we put box in "standby" by press only one button on remote (and/or boxes hardware button)?

    3. Is there any way for put box in "standby" without TV-off?

    4. Is there any way for wake up the box without turn on TV?

    1. i don't think so as the box seems to reboot

    2. LE can't suspend or hibernate?




    datrh · GitHub

    my github :

    LE9-Kodi18.6 => this is the one to use

    now using Apple-TV 4k

  • boot from internal fixed (new bootloader patch)

    will update the images + the needed instructions soon

    datrh · GitHub

    my github :

    LE9-Kodi18.6 => this is the one to use

    now using Apple-TV 4k

  • your builds do not load. a permanent error in mounting the file system. boot loader patched. assemblies balbes150 and demetris are loaded normally. in assembly demetris at mounting it turns out libreelec_disk, and at you storage, there can be an error from for it?

  • There's something wrong with the labeling of your SD/USB

    "libreelec_disk" was a label used with libreelec 8.2

    libreelec now use :

    even balbes150 uses this setting in his script :


    you may try this and it may be possible to boot from SD :

    • browse the SD and delete s805_autoscript
    • download this modded s805_autoscript (s805_autoscript) and copy it on the SD

    in this compiled s805_autoscript, "STORAGE" has been replaced by "LIBREELEC_DISK"

    let me know

    datrh · GitHub

    my github :

    LE9-Kodi18.6 => this is the one to use

    now using Apple-TV 4k

    Edited 2 times, last by datrh ().

  • The problem was solved by replacing sd card. Everything was loaded. I will test. Thanks for your work.

  • I am a little confused as what build to use for my Beelink 905 box. What is happening, is Libreelec dead on this box?

    Raspberry Pi 4, Harmony Remote, GPIO IR

  • the build works pretty good, the only issue i have is that my remote doesn't work :(, i can use cec but i want my ir remote working.

    It seems that the IR isn't even loaded, could that be?

    I have a Beelink MiniMX III II

    i did put the working remote.conf in the config folder and also used correct dtb.

    Edited once, last by cHarOn ().

  • It seems that the IR isn't even loaded, could that be?

    need to check as i don't use the ir remote with my U1

    edit : yep not enabled

    # Amlogic IR remote support (yes / no)


    need to be tested.

    there's certainly a reason why it wasn't activated

    datrh · GitHub

    my github :

    LE9-Kodi18.6 => this is the one to use

    now using Apple-TV 4k

  • tested the new build but no difference, seems like am_remote still not included

    oh and another thing, your build has only access to inputstream.adaptive-2.2.25, but not a big issue because inputstream.adaptive- from coreelec works in your build :)

    Edited once, last by cHarOn ().

  • during the dev , kszaq has switch to meson-ir.

    i've reverse his latest changes about ir remote and test it but it doesn't help.

    #2 updated : info about ir remote

    datrh · GitHub

    my github :

    LE9-Kodi18.6 => this is the one to use

    now using Apple-TV 4k

  • systemctl stop kodi
    systemctl stop eventlircd

    ir-keytable -c -p all -t

    then i can get remote to work but thats using lirc :( but better then nothing, but i would really like if it would use amremote because with lirc the ir is not very responsive

  • Hello!!

    I was able to use installtointernal and everything worked great for a few days... then I inserted LAKKA's (your build) and it didn't boot (something about corruption). I tried again by using the toothpick and still I got the same message.

    Then removed the card again and... cannot boot anymore. It stops on a prompt mount_flash.

    From this prompt I was able to "mount /dev/system /flash" and "exit" and then it starts.

    I went on to find that the labels were erased...

    So I used e2label and I rebooted... still nothing, I had to manually mount /flash.

    I inserted the original SD-CARD I used before switching to internal memory and it booted correctly. I then re-run "installtointernal" but still I need the card inserted to boot...

    I got this information:

    LibreELEC:/var/media # blkid

    /dev/loop0: TYPE="squashfs"

    /dev/mmcblk0p1: SEC_TYPE="msdos" LABEL="LIBREELEC" UUID="1309-4440" TYPE="vfat" PARTUUID="04cb1538-01"

    /dev/mmcblk0p2: LABEL="STORAGE" UUID="42f242f9-b4b3-487e-8266-0fd07cc56ebf" TYPE="ext4" PARTUUID="04cb1538-02"

    /dev/cache: UUID="57f8f4bc-abf4-655f-bf67-946fc0f9f25b" TYPE="ext4"

    /dev/system: LABEL="LIBREELEC" UUID="9c03d2ed-3c38-491d-90a0-cde8ab29611b" TYPE="ext4"

    /dev/data: LABEL="STORAGE" UUID="84b7ef57-0332-4e13-a45e-bba2e201bf8b" TYPE="ext4"

    /dev/mtdblock0: PTUUID="00001369" PTTYPE="dos"

    /dev/mmcblk0: PTUUID="04cb1538" PTTYPE="dos"

    LibreELEC:/var/media # mount

    rootfs on / type rootfs (rw)

    devtmpfs on /dev type devtmpfs (rw,relatime,size=822060k,nr_inodes=92054,mode=755)

    proc on /proc type proc (rw,relatime)

    sysfs on /sys type sysfs (rw,relatime)

    /dev/system on /flash type ext4 (ro,noatime,data=ordered)

    /dev/data on /storage type ext4 (rw,noatime,data=ordered)

    /dev/loop0 on / type squashfs (ro,relatime)

    securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)

    tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)

    devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)

    tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)

    tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)

    cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/usr/lib/systemd/systemd-cgroups-agent,name=systemd)

    tmpfs on /var type tmpfs (rw,relatime)

    mqueue on /dev/mqueue type mqueue (rw,relatime)

    debugfs on /sys/kernel/debug type debugfs (rw,relatime)

    tmpfs on /tmp type tmpfs (rw,nosuid,nodev)

    /dev/mmcblk0p1 on /var/media/LIBREELEC type vfat (rw,nosuid,nodev,noexec,noatime,fmask=0133,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,utf8,errors=remount-ro)

    /dev/mmcblk0p2 on /var/media/STORAGE type ext4 (rw,nosuid,nodev,noexec,noatime,data=ordered)

    From this output I would think I'm using internal for /flash and /storage, am I wright?

    Do you know why it doesn't boot without the card?

    Is it possible to have a LAKKA image that I could use to dual boot my MINIX?

    Thanks a lot!

  • I installed this image on my Minix X8H+ and it works correctly, but when I put a movie and go forward or backward, it freezes.