LibreELEC 9.0 / Kodi 18.X for Minix X8,X8H,X8H+

  • Hi


    Not sure anyone experiences this.


    Currently i am using LibreELEC-X8-X8H.arm-LE9-Kodi_18.3.img.


    Minix-X8H is running two HDD (Toshiba 2TB 3.5' HDD and Toshiba 1TB 2.5' HDD)


    However, there is a issues with 1TB 2.5" HDD, thus i have replaced with WD My Passport 2TB 2.5" HDD formatted in NTFS format using Windows 10 Pro. Here is the result of troubleshooting


    1. Connect Toshiba 2TB HDD and WD 2TB 2.5" HDD = LibreELEC failed to boot-up


    2. Connect Toshiba 2TB HDD, upon successful LibreELEC boot-up

    Then connect WD 2TB HDD = Kodi detected the HDD and able play video

    Try reboot = LibreELEC failed to boot-up


    3. Connect WD 2TB HDD only = Licbreelec fail to boot-up


    Base on the diagnostic above, i could more or less conclude that whenever WD 2TB HDD that causing the problem. Just couldn't figure out the issues.


    May i know what could went wrong?

    Potentially Minix (Hardware) or LibreELEC doesn't support the storage, previously i was running combined storage of 3TB.


    Seeking help, thank in advance.

    Edited once, last by humantoz: Typo error ().

  • the Minix boots with a 3TB storage already connected to the usb port or you boot the Minix and then you attach the 3 TB storage?

  • Dear datrh


    Testing as bellow


    1. Connect Toshiba 2TB HDD and Toshiba 1TB 2.5" HDD = LibreELEC successfully boot-up


    2. Connect Toshiba 2TB HDD and WD 2TB 2.5" HDD = LibreELEC failed to boot-up


    2. Connect Toshiba 2TB HDD, upon successful LibreELEC boot-up

    Then connect WD 2TB HDD = Kodi detected the HDD and able play video

    Try reboot = LibreELEC failed to boot-up


    3. Connect WD 2TB HDD only = Licbreelec fail to boot-up


    I have confirm that WD 2TB is working condition as i can use the HDD on Windows 10 Pro.

  • Hi, after installing libreelec and running the kodi ... when I start the movie it runs smoothly .... but after trying to jump or stop it freezes. Any advice? I tried versions 18.3 and 18.6..the same problem. I tried using the ares wizard to change the cache did not help

  • humantoz... If you have access to a linux box you may want to try and format and partition the WD drive under Linux as i have had issues with some WD's that appear ok in Winblows but acts weird under Linux... LibreELEC is actually Linux and Windows isn't exactly the same at partition or low level.


    I know the WD's will work as i have over a dozen 4terabyte wd drives in my network but usually if i buy a used drive from someone that had it on Windows i have issues with them on my devices... Usually running Linux fdisk at cli or use gparted will partition and format getting rid of the errors.


    If you've got no Linux box just use one of the Live Distro's on a usb stick on your pc to just boot to a live non-installed version of Linux and use gparted or fdisk within that environment to repartition the drive.d


    Sounds like when hooking up the wd on a running system LE is able to find the drive and mount it ok but when booting up theres something in the WD's partitioning that LE don't like resulting in the hangs...


    Not sure if thats the issue but based on trying to use Windows formatted drives in a Linux box thats giving me greif thats were i would start...

  • Hi, after installing libreelec and running the kodi ... when I start the movie it runs smoothly .... but after trying to jump or stop it freezes. Any advice? I tried versions 18.3 and 18.6..the same problem. I tried using the ares wizard to change the cache did not help

    Hi,

    you need to play with the "whitelist" and activate the "adjust refresh".

    Google is your friend to find how to set it up

  • Hi,

    you need to play with the "whitelist" and activate the "adjust refresh".

    Google is your friend to find how to set it up

    Hi, i have the same problem, but i can't set it up. Can you help me? Thanks


    I did it :)

    Edited once, last by Kveton ().

  • with the right dtb, it will works.

    i will check

    Can I use balbes150's Armbian dtbs? I tried your meson8m2_2G_old.dtb change to dtb.img but no lucks on Libreelec 9, and 17.6 final as same as default dtb.img. No wifi/bluetooth recognize only 1GB, What can I do something? Thank you

  • Can I use balbes150's Armbian dtbs? I tried your meson8m2_2G_old.dtb change to dtb.img but no lucks on Libreelec 9, and 17.6 final as same as default dtb.img. No wifi/bluetooth recognize only 1GB, What can I do something? Thank you

    dtb


    try this one

  • Quote

    I tried with anticipation, but unfortunately it failed. But thank you for your generous help. I will just stay at KitKat 4.4 with Jarvis. Thank you very much!

    Edited once, last by wowwoo ().

  • I have an old Minix X8-H that I updated with Finless Lollipop image recenty in hopes to use it for the latest version of Kodi but 1080p and 4K Video playback was basically unwatchable due to stuttering and audio going out of sync so I tried LibraELEC. Now I can watch higher resolutions without issues but any resolution lower than 720p will not play as it is not listed in the resolutions list, therefore not supported. This is a problem as I love the Earthcam addon and many cams from there are below 720p so I can watch very few of them now. Some work but most of them will not play. If I take the SD card off and boot normally to Lollipop, I can watch Earthcam through Kodi without issues. How can I add lower resolutions on LibraELEC so I don't have to switch to Lollipop Kodi when I need to use Earthcam?


    EDIT: It might not be due to resolution. Some cams play for a few seconds randomly but most will do nothing. Not sure what is the issue.


    Also realized 4K content will not play without stuttering. 1080p plays just fine. Tried smaller 4K files but they stutter a lot but even very large 1080p files play okay. Could this be due to HDMI cable being old?

    Edited 2 times, last by zewzeq ().