LibreELEC 8.90.x / Kodi 18 for Minix (x8,x8h,x8hplus), MX3(G,Plus) and S905/X/D/W

  • Hello,

    I have a neo x8-ha few years without touching the rom of origin OTA (4.4.2) and after this time i decide to see how the alternative roms were and I did not find anything special,

    however I found this forum with the hypothesis of installing Libreelec and after the reading the first post i tried to install and nothing :(

    I hope I'm not doing something wrong:


    1 install LibreELEC.USB-SD.Creator.Win32 (in windows 10)

    2 places an SD

    3 install with Libreelec.usb the img LibreELEC-X8-X8H.arm-9.0-devel-20181005064202-197066a.img

    4 go to sd and rename "boot_autoscript" to "boot.scr"

    5 copy from device_trees minix_x8h_sdhc.dtb to root dir and remane to dtb.img

    6 put the sd to minix neo x8-h and boot up with the system with the switch for 5 -6 sec


    and


    always goes to recovery screen ......


    Do I have to do something before this procedure?

    Is there any step missing?


    with the minix forum down I do not know what else to do, so Any help :)


    Thanks

  • not needed

    if it's a really old Minix firmware, i would update the Minix to FW009 (latest one i think). a too old android firmware may give troubles

    you're not doing something wrong


    Ok thanks, Im gone try to get last firmware and udate and then do the procedure.


    Minix quality/services is gone with Minix-Ken's departure.

    i would not recommend anymore to buy a Minix product....

    My po

    well, Sincerely if I can get libreelec runing well in the neo X8-h Im gone keep it but if not.... hello Raspbery Pie 3 :)


    PS: really thanks for the help

  • Hi Datrh,


    do you think you can update your Lakka build to be compatible with this one? I'm really missing it now. I installed emulators directly on Kodi, but the lag between the remote press and the real action just makes games unplayable.

    I also tried retropi with a RPI3, but to be honest your build was a lot better.

    What I really would like was a version I could dual-boot (LE, LAKKA), but booting from SD and reading from internal would also be great.


    Also, sometimes, mostly when opening internet streams I get a black screen with audio. Then I just skip back and video starts normally... Are you guys experiencing the same?


    Thanks a lot!

  • #1 and #2 updated

    Hi,

    in HDMI passthrough mode, i have no sound for video with 2.0 channels.

    Fixed : see post #1

    When playing DTS / AC3 video and pressing "o" key there is codecs summary

    In my case (Minix X8H) it says that audio channels have 8-bit depth while in Kodi running on Android it says 32 or 24 bits

    Is there any solution for this ? Am I doing something wrong ?

    Fixed

  • a few hours if you don't have a "file system full" :-/


    edit : need to make clean and rebuild :cry:, got some strange behaviours

    well... got problem with one package , need to figure out why.

    so meanwhile if you don't mind that the wifi will not be available you may use the x8-x8h img.

    just replace the dtb.img by the one from the X8HP LE-kodi 18 image.

  • Hello everyone, this is my first mail in this forum.


    I have a minix x8-h and ROM Finless 1.0 Android 5.1. I run LE from the SD card and everything seems to work correctly (except static IP) until I do not restart (option in Kodi) - all settings disappear (not saved) and I have a clean Kodi again. Has anyone encountered a similar case? How can you upgrade Kodi Leia to beta 5 and then to the final version (when it will be available)?


    Regards.

    Edited once, last by porthos ().