NUC7CJYH cannot boot LibreELEC from USB or SD

  • I have a shiny new NUC7CJYH and a lot of problems with that box. It behaves weirdly with Ubuntu (see for example NUC7CJYH Linux/HDMI issues |Intel Communities). I'll likely end up installing WIndows on that box (Intel Linux support for new devices is spotty) but I also wanted to try something other than Ubuntu so I tried to run OpenELEC on that. Unfortunately that does not work at all. I have made USB flash media with LibreELEC USB-SD creator and latest OpenELEC version (8.2.4). Flash drive is recognized by NUC and I can boot from it but boot gets stuck at some point and never finishes. I do get "boot:" prompt and even can type a command there but after hitting Enter nothing happens at all (except that blinking cursor disappears). Nothing works after that, even Ctrl-Alt-Del is not doing anything, had to long-press Power button to turn it off. (see attach for screenshot).

    I have also tried 8.2.0 image, and burning image to SD card, nothing helps, I observe exactly the same behavior. Tried to play with BIOS settings but no luck.

  • I have exactly the same problem as the thread creator. I cant get into the libreelec installer. I get stuck in the same thing as the thread starter. I get stuck at the wait for installer to start message. And thats even with milhouse builds. My other PC installs with out a problem.

    Also see this thread:

    Intel NUC Gemini Lake (NUC7CJYH) - HTPC - Hardware - LibreELEC Forum

    I have a ssd in the nuc. I already removed the ssd with no luck... Ive tried to boot from USB and SD Card with no change

    i changed the graphics ram to 512 ram already in the bios. But it has nothing to do with that.

    Is it some other Bios setting that has to be ajusted?

    Edit: I am returning the NUC... so i dont need help but maybe someone else needs help sometime

    Edited 6 times, last by Wordstar ().

  • Just in case we have more early adopters around... here's what worked on my NUC7CJYH:

    - Create bootable USB pen drive for generic x86_64, latest official 8.2.4 build using the LibreELEC USB-SD Creator

    - Replaced kernel and system files in target folder in root folder on pen drive with corresponding files from Milhouse alpha build tar (to be found in target folder), as suggested by Milhouse himself over at Kodi forums

    - Booted from pen drive and installed LibreElec to an SD card (installation to a USB pen drive worked, subsequent booting did not!)

    - Voila, LibreElec boots from SD card

    Using BIOS version 24 (haven't tested latest 27 yet) with the following settings:

    - Boot / Boot Configuration / UEFI Boot / OS Selection: Linux

    - Boot / Boot Configuration / UEFI Boot / Fast Boot: Off

    - Boot / Boot Configuration / UEFI Boot / Boot USB Devices First: On

    - Boot / Boot Configuration / Boot Devices / USB: On -- anything else off (yeah, no SD option here)

    - Boot / Secure Boot / Secure Boot Config / Secure Boot: Off

    [Edit] With BIOS version 37, installing and booting from USB pen drive works OK for me with above settings. Official LE 8.2.5 can be used as basis as well.

    [Edit] Corrected folder locations in above post.

    Edited 3 times, last by TheKraut ().

  • Here guys special build for gemini lake - based on latest kernel 4.17 drm-tip (intel)

    bumped xorg, mesa, vaapi, and couple of other packages frame rate switch working fine ;) Mobile File

    Installer working also fine ;)

    PS. for better GPU experience/speed of GUI etc. use custom xorg.conf

    just put file xorg.conf to /storage/.config/

    and reboot box

    please left comment after check if working better ;)

  • I tried out your build piotrasd. I was running current Milouse build on my j4105-ITX and had problems with frequency switching.

    I downloaded your file and put it into the update folder.

    But I have still issues with loosing video output when a video is stopped. Also I have problems when I put 25Hz to the whitelist with tv playback. If I start TV playback with 25Hz in the whitelist it will pick this, resulting in stuttering video. Only if I deactivate it, it chooses correct 50Hz. But sometimes I need 25Hz and when I go back from 25Hz to 60Hz of Kodi it looses output. Also the setting of some waiting time didn't help.

    Edit: Sry. the update didn't work properly, because I was missing an empty .nocompat file. But now with the successfull update to your build I get no video output. Even the xrandr trick doesn't work anymore. I have to unplug and replug the HDMI Cable. Frequency switching works better than before for starting a video. But again ending the video results in disconnection of video output.

    Edited once, last by tuep ().

  • After removing the xorg.conf my HDMI channels were renamed again from HDMI-1 eg to HDMI1 after that also xrandr switching is working again. However loosing connection after switching remains and also sometimes false frequency is detected.

    I have one movie here which needs 25Hz. Playback is set to 50Hz resulting in micro stuttering. Don't know why because its a multiple of 25 but it is like it is.

  • That driver/kernel issue - already reported I'm waiting on patch, when you loose picture Enough unplug HDMI cable and plug back. I will keep you update once I will get something to fix that,

    About 25Hz I don't have any issue, are you sure media files are with 25 not 24 or 23.98 ....?

    Did you tried make dump EDID and inject ?? Did you checked all supported freq by your TV ??

  • I really don't know about the stuff you mentioned last.

    I know that unplugging helps but it's a pain.

    The one file I used for testing is 25Hz. When I used Milhouse Buld and Whitelisted 25Hz it worked, but after stopping playback output was lossed.

    I am considering to send back the board. Downsizing to Apoll Lake or Uprading to AMD APU's.

  • Nope, I have an FHD-TV. I can register there and comment, but I don't know whether I want to stay with this. I can still get refund for it.

    At the moment this is not usable and I am afraid that I stay with this and it will take months to get this done. AMD seems to be more active in kernel contributions. But I am not really an expert.

  • read kodi forum but what is know before AMD used VDAPU now they testing VAAPI but it dosnt look so nice compare to intel - still in progress.

    special for new APU - here lrusak should know more

  • Sorry, I didn't got you. So you believe AMD will stay a longer time not usable than Gemini Lake?

    Apollo Lake is at least working as expected, but hasn't proper hdmi2.

  • APU from ryzen still don't have support in Kernel, mesa, xorg etc. I saw some commits but still they need few weeks or months

  • Would it help if I provide some logs for bugzilla too?

    I think it's not solely 23.9p same problem occurs at different frequencies for me. E.g. 25p material.