RPI 3B+ Wifi issue

  • Hi,

    I am not able to connect to wifi with latest RPI 3B+. It can search for available wifi's, but when I type password it wrote me following error. I have following router: CH7465LG. Anyone else have problems or not have problems with wifi on latest RPI? :) And let me know if I can debugg it even more :) And yes, using latest LibreElec :)

    1. Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

    Here is first connection, then I turn on debug log and try to connect two times (in Kodi it wrote "Operation aborted"):

    Edited once, last by CvH: just cut some log garbage ().

  • Wifi works fine for me on my RPi3B+. Perhaps the new RPi is a bit allergic to your router?

    Please use Pastebin.com - #1 paste tool since 2002! next time if you want to share logs, snippets or other long texts.

    We prefer not to litter our forum database with unnecessary bulky texts.

  • Hi,

    first of all, really sorry for the long log :) Next time I will use pastebin.

    I was also trying another router behind my router (TP-Link TL-WR702N) and same issue.

  • I've found on my new RPi3B+ that I was always getting a "Network Error" on new installs.


    WiiFi is disabled until wireless regulatory domain is set (Pi 3 B+ only)

    So you need to set country in Settings -> Interface -> Regional, first and then you should be able to connect as normal.

  • Country in Kodi has nothing to do with wireless regdomain. This is set by the kernel (or forced through kernel module 'options' settings via a conf file when associating to a network. For pi it's something we have wanted to expose in the LE settings addon for a while as channels 12-14 are not scanned-for unless you force the regdomain setting. Country in Kodi is used for clock offset from UTC only.

  • Hi.

    Until the time can be set, nothing will be installed while connecting to the router. Interestingly enough, an old TP Link stick has it all. WIFI of the 3B + model is not good? Why is that? Or the LE has not seen the 3B + model yet?

  • SSL certificates on our repo have a validity period (start date and end date) and until the time is set the system clock has datetime before the start date so the certs are invalid and connections (correctly) fail. In our testing the WiFi performance on 3B+ is reasonable and fully supported. The current beta has newer firmware that should perform better than the first (8.2.5) release. It's also possible that a USB device with a larger antenna may perform better in your environment.

  • I found this in search to make channel 12 and 13 available on libreelec with a RPI 3.

    chewitt I read about your hint of setting it as a kernel module option, however trying

    modprobe cfg80211 ieee80211_regdom=EU

    did not work.

    I tried to find out why, and stumbled upon the kernel description for the regulatory domain (en:developers:regulatory [Linux Wireless]), which hint to use userspace programs as iw and wpa_supplicant (Which as of my knowledge are both not available on libreelec?)

    Following the kernel info, you can also have the kernel do this. However it seems that a lot of configuration and setup needs to be done which are not available without recompile (en:developers:regulatory:crda [Linux Wireless]).

    Do you see any other way to activate channel 12 and 13 on libreelec?

  • wpa_supplicant exists but networks are configured through connman, and both are achieving the same result as the modprobe command. I'm not sure "EU" is a correct value since wireless regulations are normally country specific, hence DE/FR/UK etc. are used.

  • D'OH, that was it. Thanks!

    As a summary and reference for others struggling:

    1. SSH into your libreelec Raspi

    2. Create a .conf file in "/storage/.config/modprobe.d/" with content:

    options cfg80211 ieee80211_regdom=DE

    I named the file "enable-additional-wifi-channels.conf"

    3. Reboot

    After that you should be able to scan for WIFIs on Channel 12+13

  • Hi all,

    i've just had the same problem, what i did to fix it was to jump onto the management page of my WIFI router and change the channel setting the Router users and fixed it to a channel below 10 (it's an Asus dual band router and it phrases this as a control channel). If you then set the extension channel to use a channel below the control channel this should fix the problem too. if the extension channel goes into channels 12+13 then you'll probably see the you're PI working either slowly or not at all!

    This problem not only stopped my PI from working but also stopped a nannycam working as well!

    One security problem that you may encounter by fixing the channel if there are wifi routers nearby then they could interfere if both channels are set the same. there are other issues but that would make this post way to long.

    hope this helps