Does this dvb s2 tuner work?

  • The manufacturer promised to ship me a device so I can try to build a working driver for it. The way I see it, it should not be too difficult, but will probably take a couple of weeks (provided I find the time to do it).

    trsqr I don't mean to push you, but is there any update about this?


  • Hi Guys,

    i try to debug this problem to help to solve this problem.

    Here are all debug messages you need:

  • Thank you all trsqr  CvH  GDPR-7  Nelvin for still following and trying to solve this problem.

    I know that the manufacturer is not forced to support his device under Linux but he should not declare on his site and through support emails that the device is supported under Linux. I really feel sad and tricked because I cannot file a complain against him in his country or return the device back:(.

    I wish I have the minimum knowledge to start building a driver for it since I have the device. What do you think trsqr ? Is it too difficult to learn it? because I am willing to learn.:)


  • Hi,

    I recently purchased a Geniatech HD Star device. Output from 'lsusb -v' is the same as that posted on linuxtv, however I've had some trouble getting it to work. I've tried compiling kernel 4.11 with the patch available here and mentioned here. I didn't have any issues compiling the kernel, but the device failed to load. I've also tried the Ubuntu Xenial 4.13 kernel and OpenELEC 8.2.5. In each case there has either been a null pointer error or 'no frontend was attached'. The device always seems to be in a 'warm state', so no firmware is loaded. The Windows driver shipped with the device is dated December 2017. The only thing which seems to work is the remote control. Is there any way I can check if this problem is due to the new 'M88DS3103B' demodulator chip? If so, is there any information I can provide which may help?



  • I can only say that I've compiled kernel from updatelee / v4l-updatelee — Bitbucket and it works perfectly.

    Also my Astrometa T2 Hybrid (Dvb-t/t2/c) works with that drivers.

    Had problems with normal kernel drivers and with media build drivers (tvheadend coudn't scan or tune any channel).

    Didn't make a diff to the sources to see what's different though.

    By the way, it could be very useful to insert updatelee / v4l-updatelee — Bitbucket drivers as an option in the milhouse builds.

    Milhouse, do you think it could be possible?

    Thank you,


  • CvH

    Welchen Kernel hast Du benutzt? Ich versuche gerade den Patch in den aktuellen Kernel 4.17.4 einzuspielen, aber es kommen nur Fehlermeldungen.

    Ja, Du hast Recht. Ich habe es auch gerade gemerkt, dass es Dein Patch ist :)