S905x support, what is needed?


  • Also noticed, related to sound, that by default in this build the audio output device is defaulted to AML-M8AUDIO:ANALOG (AML: @ in config file) and I also have available AML-M8AUDIO:HDMI (AML:HDMI in config file.) I wondered if the HDMI setting should not be the default?


    This will change for the next build.


    koenkooi Can you try if rootwait in CMDLINE with my standard options helps booting?

    Edited once, last by kszaq ().

  • This will change for the next build.


    koenkooi Can you try if rootwait in CMDLINE with my standard options helps booting?


    This diff on top of HEAD..2016-08-03-devel.diff:


    Boots from uSD!
    [hr]
    I neglected to mention earlier: 4k playback issues on an 1080p TV are still the same: big buck bunny 2160p30 switches to 1080p60, black screen, sintel 2160p24 switches to 1080p24, black screen.
    FWIW I don't get the logic behind using a 100Mbit PHY for a 4k box, it is *just* enough for jellyfish 90mbit. I realize on s905x you get it for free, but still...

    Edited once, last by koenkooi ().


  • Boots from uSD!


    rootwait it is then!


    FWIW I don't get the logic behind using a 100Mbit PHY for a 4k box, it is *just* enough for jellyfish 90mbit. I realize on s905x you get it for free, but still...


    You don't watch Jellyfish every day in 120Mbps, do you? 100Mbps may be not enough for UHD BluRay but it's sufficient for UHD DVB-S which are ~30Mbps.

  • You don't watch Jellyfish every day in 120Mbps, do you? 100Mbps may be not enough for UHD BluRay but it's sufficient for UHD DVB-S which are ~30Mbps.


    I did watch it each day every day this past week :)


  • I neglected to mention earlier: 4k playback issues on an 1080p TV are still the same: big buck bunny 2160p30 switches to 1080p60, black screen, sintel 2160p24 switches to 1080p24, black screen.


    FWIW I don't get the logic behind using a 100Mbit PHY for a 4k box, it is *just* enough for jellyfish 90mbit. I realize on s905x you get it for free, but still...


    Just read this article: Tanix TX5 Pro TV Box Review – Part 2: Modding and Testing, under section 4K it said: 'The Amlogic S905X does not supports h.264 60 fps above 1080p'.


    I also don't get the logic of 4K h.264, which is supported by S905 but not by S905X while this format is now more and more popular in Asia. Not sure about what would happen with S912!

  • Just read this article: Tanix TX5 Pro TV Box Review – Part 2: Modding and Testing, under section 4K it said: 'The Amlogic S905X does not supports h.264 60 fps above 1080p'.


    I also don't get the logic of 4K h.264, which is supported by S905 but not by S905X while this format is now more and more popular in Asia. Not sure about what would happen with S912!


    Judging from the kernel sources s912 ('gxm') is an s905x ('gxl') with a different MALI and an extra a53 cluster.


  • For the adventurous people among us, the .3 build in the same dir as the diff is the one I'm testing.
    [hr]


    Device - Tanix Tx5 Pro (s905x 2GB RAM, 16GB eMMC)


    Tested from uSD card (LibreELEC-S905.aarch64-7.0.2.006.3.img.gz 2016-08-31 11:51 126M )
    4 consecutive boot
    Fails with the folowing error:
    *** Error in mount flash: mount common: Could not mount /dev/mmcblk0p1 ***


    With s905_autoscript from kszaq build it boots normally (tested with dtb.img from android and also with supplied dtb.img)


    dmesg STdE


    !!!
    After Power Off then Power On sometimes is hung and display
    *** Error in mount flash: mount common: Could not mount /dev/mmcblk0p1 ***
    and after disconnect power, wait 10 sec, connect power, sometimes it Boot normally.
    !!!

    Edited once, last by pm_mickey ().

  • Sorry TNS but I didn't do any kind of configuration or change in the build. My remote is working directly without any special setting.


    Did you try th kszaq's build? It also works perfectly in my box.


    Tks for your reply. Would it be possible for you to upload your remote.conf file.


  • After Power Off then Power On some times is hungs and display
    *** Error in mount flash: mount common: Could not mount /dev/mmcblk0p1 ***
    and after disconecti power, wait 10 sec, conect power some time Boot normaly
    !!!


    I get that as well when using the uSD card, that problem went away after installing it to eMMC, which I realize isn't an option for everyone.


  • Just installed my build on my A95X's NAND flash - working great. Did also test power off and power on via IR remote control, no issues here. So it appears to be safe (at least on the A95X) to install that build on the NAND flash.
    [hr]
    kszaq


    LibreELEC-S905.aarch64-7.0-devel-20160825131726-r23297-g5b935ef from SD is working fine on A95X / S905X


    pulsar
    Hi
    I flashed twrp on my Nexbox A95X / S905X (2/16) and all ok
    If I try to flash your img file (LibreELEC-S905X.aarch64-7.0.2.006.2.img) TWRP said that the destination has not enough space.
    I have the img file in a 4gb sd
    I select the sd to choose the img file to flash...........
    What I'm doing wrong ?


  • Just read this article: Tanix TX5 Pro TV Box Review – Part 2: Modding and Testing, under section 4K it said: 'The Amlogic S905X does not supports h.264 60 fps above 1080p'.


    I also don't get the logic of 4K h.264, which is supported by S905 but not by S905X while this format is now more and more popular in Asia. Not sure about what would happen with S912!


    4k with h.264 is useless, because the bitrate is far too high. so it makes sense not to support that combination. 4k will make heavy use of h.265/hevc which is supported by the S905X.


  • S905Xers, please test this build for booting issues: LibreELEC-S905.aarch64-7.0-devel-20160830160706-r23311-g51fe9ae.img.gz


    Compare
    LibreELEC-S905.aarch64-7.0-devel-20160826224219-r23299-g6fd2ccc
    Boot from uSD - OK
    HDR - OK
    VP9 - Not working
    Power off - Not working, Continue rebooting


    LibreELEC-S905.aarch64-7.0-devel-20160830160706-r23311-g51fe9ae
    Boot from uSD - Not working, EMMC is OK
    HDR - Not working
    VP9 - Not working
    Power off - OK


    HDR Demo file from Demo UHD-3D - Ultra-HD / 4K / HDR / 3D

    Edited once, last by garyang ().


  • pm_mickey Thanks for dmesg, I noticed 2 mistakes. Next build to test AP6255 (everything else = test5 build): s905x-ap6255


    Thank you for All your work. Much better than the junk original firmware. I also have the Tanix Tx5pro. I need this Image ^^^^^^^, but the link is dead. Maybe there is another link? Thanks in advance and I will be donating to your coffee funds.

  • Thank you for All your work. Much better than the junk original firmware. I also have the Tanix Tx5pro. I need this Image ^^^^^^^, but the link is dead. Maybe there is another link? Thanks in advance and I will be donating to your coffee funds.


    view?usp=sharing
    I've upload it on my g-drive.

  • Unfortunately, the latest 7.0.2.007 doesn't work at all on my Beelink MiniMX III with S905X. Pulsar's build boots just fine, but doesn't recognize the original remote. Does anyone have an idea how I can fix that?


  • Unfortunately, the latest 7.0.2.007 doesn't work at all on my Beelink MiniMX III with S905X. Pulsar's build boots just fine, but doesn't recognize the original remote. Does anyone have an idea how I can fix that?


    Isnt the "Beelink MiniMX III" a S905 chipset?

  • Isnt the "Beelink MiniMX III" a S905 chipset?


    No, not this model. I'm not allowed to post any AliExpress links, but this is the description: Beelink MiniMXIII II TV Box H.265 Full HD 4 K x 2 K KODI Media Center Amlogic S905X Quad-Core 64bit 2.4G WiFi Bluetooth 4.0 TV Box.


    Features:


    1.OS:Android 6.0
    2.CPU: S905X Quad-core 64-bit ARM Cortex-A53 tot 2 GHz
    3. GPU: Penta-core ARM Mali-450
    4. RAM DDR3: 2 GB
    5.ROM Flash:16 GB
    6. Supports Bluetooth 4.0 and Wifi


  • I think that's a bad sellers title/description.


    I think this is what you have:
    Beelink MiniMXIII II Amlogic S905x RAM 2GB EMMC 16GB Up to 32GB - Android TV BOX - Beelink - Powered by Discuz!
    (not a store link)
    I dont see a MiniMXIII S905x from them on their site.


    This is most likely part of your problem

    Edited once, last by Nathan909 ().