[solved] Can(not) connect to my NAS via SMB

  • So, I've installed LibreELEC-RPi2.arm-8.2.2.img on my Raspi 3 which runs Kodi 17.6 which is the same version I'm running on my cheapo Android Marshmallow box. However, when I try to connect to my NAS via SMB with my Raspi, I'm always asked to reenter the password and I cannot access the share. When I connect from Marshmallow to the same share however, it works fine (as well as when connecting fom my Windows 8.1 box). Setting my NAS to local master browser makes no diffence. I can't find any difference between the settings used


    Code
    1. <source>
    2. <name>MyNetN900C</name>
    3. <path pathversion="1">smb://10.10.10.5/</path>
    4. <allowsharing>true</allowsharing>
    5. </source>


    and since I've set Libreelec to use SMB1 to SMB3, I wonder what's causing this:



    while working just fine here:




    I've modified the sources.xml on my Raspi to this


    Code
    1. <source>
    2. <name>MyNetN900C</name>
    3. <path pathversion="1">smb://tecc:[email protected]/</path>
    4. <allowsharing>true</allowsharing>
    5. </source>

    but even adding the actual share to the path (10.10.10.5./Public/) doesn't make a difference either.


    Any suggestions? Thx!

  • As you will see from the Krypton 8.2.1 new post, samba has been upgraded (V4.x.x) read the note under heading in red for smb/samba, this also caused trouble for me and my asus dsl-ac68u, the reason the current firmware in the my router uses and older version of samba and so I get security issues from trying to login my 3tb hdd attached to the router.


    As there is no firmware for my router (smaba V3) that can match libre's samba version release, I have to use a workround on my android box and RPI3 which is to create a text file in notepad or equivilent containing the below information to a file called user.conf , and it need placing in the folder listed in first line of its text. (the /xxxxxx/, might will be different from machine to machine i think)


    ;# place following in a file called user.conf in this folder /home/xxxxx/.kodi/.smb/

    ;# in gui set max proto to smbv1

    [global]

    client NTLMv2 auth = no

    client use spnego = no


    USING this though will reduce security of the samba link between the devices.


    The last latest WD N900, firmware on their website is from 2015 i believe, so if it's built in smaba version is < v4 then this might explain your problem

    Hope this helps

    Andy

  • Or use LE 8.2.2 and set the "legacy security" option in the GUI (added in the 8.2.2 release). No need to visit the console.

  • System > service settings > SMB client > Use legacy security setting is greyed out, no matter what minimum/maximum protocol version I use. How come?

  • System > service settings > SMB client > Use legacy security setting is greyed out, no matter what minimum/maximum protocol version I use. How come?

    It becomes active when you set max = SMB1.

  • Stupid question: is there a way to set the used protocol on a per share basis? My NAS connects via SMB1 but I also have stuff on my desktop PC I'd like to connect to occasionally. It's Win10 and does not use SMB1 anymore. Don't know if I should add SMB1 to that PC, there's more important stuff on it than media files.

  • The short answer: No.


    Either you keep switching settings everywhere, or you harmonize your shares/sources as far as SMB versions go.

  • I'd say it's probably "no", but your welcome to get creative with variable substitution: smb.conf and see if that can work for you.


    Fur example, try creating /storage/.kodi/.smb/user.conf with the line:

    Code
    1.  include /storage/.kodi/.smb/%j.conf

    then in (for example) /storage/.kodi/.smb/192_168_0_20.conf you can try configuring the required client settings whenever you connect to the server that is 192.168.0.20.

  • Another approach would be using systemd mounts (see /storage/.config/system.d/ for samples) to locally mount the remote file shares. Each mount can use different options for protocol versions. Then set sources to the local mounts and scrap to the library.