Black border with NVENC

  • Hi all,


    I encoded a cropped video with Staxrip with NVENC H265 CUDA settings (and with nvencc64.exe command line, too, with native NVENC settings), and when I play it back on PC there is no problem.


    But when I try to play it back on my media player, there is a black bold line at the bottom of the video and after that all NVENC encoded videos has a black border (even the Open Matte movies, the image also becomes smaller because of this border) like it would cause some kind of "windowed mode". Only a reboot solve this.


    I'm not sure but I think the crop causes it (I tried command line crop and .avs script crop as well), because when I encoded videos without cropping, there wasn't any problem with them, or at least I didn't saw any black lines.


    I tried with a 4:3 video, too, I cropped the black areas from its sides, and there is the black line at the right of the image when I play it back, and after that the same effect, the black border around other NVENC encoded movies.


    On the PC there is no problem at all (in MPC-HC, and I just tried in VLC, too), only on my media player, which is an Eminent EM7680 4K TV Streamer (CPU: AArch64 Processor rev 4 (aarch64), Hardware: Amlogic, Revision 020a, GPU: Mali-450 MP) with the newest LibreELEC (8.2.1 kernel: Linux 3.14.29) and Kodi 17.6 (Git: a9a7a20). There is no option to upgrade only the Kodi to 18, so I can't test with that version.


    I uploaded a few minutes of the video:

    Zippyshare.com - a4.mkv


    I don't really know if this a bug or NVENC isn't fully supported?


    Thanks in advance!

  • with the newest LibreELEC (8.2.1 kernel: Linux 3.14.29)

    FYI, v8.2.2 is the newest version, although that will make little difference with the problem at hand.


    The video plays fine here too on Ubuntu + Nvidia graphics on both 21:9 and 16:9 screens.


    which is an Eminent EM7680 4K TV Streamer

    Eminent does have its own helpdesk, and Eminent also releases their own builds of LibreELEC. Hence they might be behind in version numbers.


    So I suggest you contact them first, since you also paid them for the Eminent box. :)

  • Thanks, but unfortunatelly I can't select newer version, there are only 8.2.1 and 8.1.1 in the dialog box, there are no other options.


    I didn't get a response from them yet that's why I thought maybe I'll find the solution here, in the middle of the development of LibreELEC.

  • Yet? How long ago? They may not be as snappy as we are, but I'd give them some more time.

  • Klojum: Since Wednesday. I wrote them again yesterday evening (and I added the 4:3 info which I encoded since then), but it's weekend already so I guess I have to wait for Monday to see if they answer.


    chewitt: So, if I understand right, even if someone find an error and fix it here, I'll not get the fix on my player too easily? :(


    ps: (I found another bug since yesterday evening: with saved non-smart movie/episode playlists (I wanted to create a multi-series episode viewing order), you can't set the watched flag, but I don't even know if it's LibreELEC or Kodi or a player bug, and if it's fixed in the newer versions or not, or if it's fixable at all, so I guess I will add it to my Eminent letter if they answer.)

    Edited once, last by Mamzi ().

  • If you can understand and isolate where the issue is:


    a) OS things should be resolvable through a software update. Eminent (or their maintainer) can choose to fix anything they like as this is under their direct control and they can release their software as required. That said, in recent times they have been loosely tracking our releases, and 8.2.2 is the last release we intend to make for Krypton so I wouldn't expect miracles.


    b) Kodi issues will not be resolvable in the current (Krypton) codebase. All fixes in the last ~6 months have gone into the Leia codebase and this will require Eminent to create/ship an image based on Leia in the future.


    Make sense?

  • Yeah, maybe I will just buy another player which supports newer updates. Although my nvenc problem still could be there, too, so it's not a safe bet neither.

  • Well, Eminent replied and they said the problem with the codec. Nothing else. No fix, no promise for a fix, nothing, just that "the problem with the codec". So... I don't know what to do.

  • One thing I noticed that you used a pretty old version of MKVmerge, version 10.0. Is the rest of your video tools equally outdated?

    Right now, MKVtoolnix is 10 version further as v20.0, and I imagine that MKVmerge has had some upgrades as well. There have been fixes for HEVC videos over time.

  • Thank you for the suggestion, I installed and tried v20.0 now, but unfortunately it doesn't solve the problem. :(


    And I asked Eminent about a fix and they just replied that they can't fix it.


    Can someone recommend me a good network media player which is always up-to-date with LibreELEC and Kodi and has no problem with my file or at least has better (or actual) support? Thanks in advance.

  • Thanks, but I can see only the same 8.2 version of LibreELEC here:

    LibreELEC Alpha/Beta Preview Builds – LibreELEC


    I learned how to upgrade firmware from a usb drive manually, but It's the same version which plays the video wrong on Eminent right now. So I don't know what to do.

    Or am I looking for it at the wrong place?*


    I tried out the Plex add-on, too, and after a half minute waiting time the video plays fine there if I use the cpu (but of course it's almost at 100% cpu usage so it's not a too good solution), and if I enable h265 in the settings (so Eminent plays it from hardware), there is the black border again. But at least I surely know now that it's not a Kodi issue, even if it's only v17 and not the newer v18.


    *Yeah, okay, I'm stupid, sorry, I found some other community builds:

    [INDEX] LibreELEC community builds for Amlogic

    I will try it.


    edit: well, I can't. I downloaded and tried all of them, it says:

    "Verifying update package..."

    "footer is wrong"

    "signature verification failed"

    "installation aborted"

    :(

    Edited 3 times, last by Mamzi ().

  • A friend of mine checked the videos on an android tablet yesterday evening and they play fine there, too.


    So I'm more sure it's an Eminent-only problem. And without support to fix it and without the ability to change the firmware to these newer ones it's a useless player. :(


    I really wish someone could recommend a good Kodi media player for me.

    I know that the Dune is working, but it's rather expensive and there is a subscription for the jukebox, which is ridiculous.