Mecool M8S Pro+ // not able to to run or install LibreELEC

  • Dear folks,




    just received a M8S PRO+ S905X // 2Gig Ram / 16Gig Flash



    As you know the toothpick method is not possible...



    I downloaded: LibreELEC-S905.arm-8.2-8.2.1.2.img.gz and used the LE tool to put it on a micro SD.



    So i tried the following as recommended:



    • recovery method: boot into Android, insert card/thumb drive and choose Reboot to recovery. Your box should boot into LibreELEC.

    I did not find "reboot to recovery" - where or how to do this recovery methodon my device?



    • recovery method (2nd variant): if you have "Update" app pre-installed open it, insert SD card with LE/connect USB drive, and choose anyZIP file in the app for update. Your box should reboot to LE.

    Ok did that. but once i am choosing local and not OTA in order to enter the sd card there will be nothing displayed. only a screen with no dirs or files (but usin the android file explorer works - there i can see the content of the card)

    • recovery method (3rd variant): enable ADB (Google it) and issue adb reboot update command

    I install android terminal app and typed su / reboot update. reboot starts but theMECOOL screen freezes and nothing happend. So i removed the sd card and the android boots again






    Looking really forward to any help.

    My A95x device was easy but this is tricky for me

  • Damn - just removed the cover and the sticker says S912 not S905x...


    foto20.12.17203422nys8v.jpg


    No I am a bit confused. on the outside there is the same sticker with S905x.. how to continue and solve my problem?


    EDIT:

    meanwhile tried this img LibreELEC-S912.arm-8.90.10-K.img.gz - but same findings like the above

    I think it is a S905x cpu as promised. but need help now to proceed please


    Edited 2 times, last by biesa ().

  • Will this help?

  • It seems that there is the wrong sticker inside. it should still be a s905x -- should be...

    Yes, others have had the same issue of sticker, inside the box, saying S912 instead of really S905x.

  • ja - but your video does not realy help. because i have already tried using a terminal app and doing reboot update

    see above

  • Have you tried installing the app "Reboot to LibreELEC" (via AppStore)? That worked for me on all boxes, even one where I could not find the reset button either.

    Cheers,


    chessplayer



    Formerly: Intel Atom, Dockstar/Pogoplug (headless PVR Server)

    Production: Wetek Play, RPi3, Cubietruck (headless PVR Server), Nvidia Shield client, XBOX ONE Tuner, Sundtek Media TV Sticks

    Experimental: Various AMLogic S905X (W) devices


  • I had same problem as this. There is only one valid way to install LibreElec on the M8S Pro+ (as noted in the install text):


    The trick is to read the install instructions which says you must insert the SD Card with LibreElec AFTER you have booted to Android! Booting with the SD card in will remove the LibreElec and DTB files from the SD.


    Once you do run the Terminal App and inserted the SD card, then run 'reboot update' once - then everything will work as described

  • Remeber to use a correct device tree and use the method that got you to stuck Mecool logo.

    can be closed.


    it is a s905x cpu.



    kszaq nailed it. device tree was not right.thanks man


    please keep your work up!