Weird Problem!

  • I had LibreElec on this same hardware before...not that long ago. I switched back to Windows 10 with Kodi installed for a while due to some network trouble that had popped up. Yet, today I decided I would give it another shot. So, I created a USB with the latest version, and tried to boot from it. It loads up the installer fine, but when I select to actually install it, it says "No devices were found". Seems it is not finding the Intel NUC's M.2 Internal SSD. Yet, like I said...it did before. Is it a problem with the latest version? Should I redo the USB with the previous?

  • If the old(er) installation works, you could after that try to upgrade manually to v8.2.1.

  • Have you tried (again) to install the older version as asked?

    Is Windows supposed to remain on the m.2 ssd?

    The LE creator/installer (if it works) will wipe the entire SSD for the LE installation.

  • I have tried it again with other versions. Same result.


    I do realize Windows will be wiped. I am okay with that.