Bootable USB not working

  • Trying to install LibreELEC or OpenELEC on Wintel Pro box.


    I always get the same error, unable to boot from usb drive. And in boot drive selection it does not show usb drive label, as it would if it was working.


    Steps tried:


    - Installed Ubuntu 17.10 from the same USB drive using Rufus to write image file. Success. But no sound, so decided to switch to ELEC, because of information that it has working sound on Cherry Trail CPUs.

    - Downloaded USB SD Creator, and used Generic image. Created media. No luck. Error.

    - Used miniTool to remove all partitions and format with empty FAT32 partition (without any partitions creator does not work either). Tried again. Same error.

    - Tried to use Win32DiskImager to write it. Same thing.

    - Wiped USB again

    - Tried Win32DiskImager with OpenELEC. Same thing.


    Any ideas?

  • Ok, my fault. I had to go and run bootable media manually from file inside EFI\Boot folder, apparently BIOS could not find it.


    Yet after installation it can not boot, it just goes into a loop of trying to boot, then restarting over and over, the screen just keeps turning on and off, unless I press F2 at some point, which takes me to BIOS.

  • This is a guess, but an educated one: I'm not sure LE 8.2 supports 32-bit boot devices (some CT devices are 64-bit but only support 32-bit boot) but LE 9.0 (development images) do - via grub, which is also what Ubuntu uses. Grab a current milhouse development build from the Kodi forum and use this to install so you have a working bootloader, then downgrade to the normal 8.2.0 release using the manual update function in the LE settings add-on, and then perform a hard reset to remove any stray Milhouse/Leia configuration bits. Make sense?

  • Well, no, it's 64-bit only device. I dunno if it uses 32 bit boot or 64 bit boot.


    But the thing is. I think that installation of LibreELEC bricked my device. I know that this Wintel box is a fragile thing, but I did not expect LibreELEC installation to brick it.


    Because now nothing boots. I can only go into BIOS. But I can't enter any setup from there. I can see USB drives, but nothing would start from it. Before I could get into EFI shell, now I can't. I suppose it was on the internal mmc memory, but LIbreElec installation wiped the whole disk. Maybe, I'm not sure.


    It also does not save any BIOS settings, battery change does not help either.


    So, whenever I try to boot anything (Any bootable usb, ubuntu, libre elec, windows, and believe me, i tried at least 3 different USB sticks, and I used them multiple times before with other PCs, they do work) - it just starts turning connected screen on and off, like if it's going into a boot loop after bios. Looks like it goes to bios\uefi boot, tries to boot some system, then reboots and does it again, over and over, until I press F2 and go into bios settings.


    The verdict is, I suppose, do not buy Wintel boxes, they're a piece of.. work. Very fragile and turn to bricks. They do come with a nice box though.