[SOLVED] -Update to 8.1.0 on Generic Failed - "XZ-compressed data is corrupt - system halted​"

  • Hi all,


    I have an Acer Revo3700 (ION2) HTPC. I have tried to upgrade from 8.0.2 (which runs perfectly) to 8.1.0 and have been unsuccessful. The update starts and completes as normal and the system reboots. On reboot I get an onscreen message stating: "XZ-compressed data is corrupt - system halted" and the system has frozen. As a result I created a USB stick with 8.1.0 to try a fresh install however I got the same error message after booting from USB. I was unable to even start the install process.


    As I have been unable to install 8.1.0 I did a fresh install of 8.0.2 using a USB stick and that installed as expected. I also then as a final check tried to update to 8.1.0 from within this fresh install and that also appeared to complete successfully but I was left with the error message screen as described above after reboot.


    Any help would be greatly appreciated.

    Kind Regards.

    ceekdp.

  • One of the project staff has a Revo3700 and has tested it with the official 8.1.0 image without issues. We can't think why you're seeing messages about decompressing an XZ kernel because the official Generic image uses gzip compression. Our current guess is you're not using an official image?

  • Hi chewitt,


    Thanks for your reply.

    The images I have used have all come from the libreelec.tv website. Could it be a problem with mirror I have used? I am in the UK.

    Last night I also tried updating to 8.1.0 from within Libreelec and again that seemed to install fine, rebooted and then resulted in the same error. (again I was able to reinstall 8.0.2 from USB afterwards with no issues)


    It does seem very strange. Tonight I will have a look in the Bios settings and check everything is ok.


    Any futher thoughts would be greatly appreciated.


    Kind Regards,

    ceekdp

  • Thought I would update on a few things I tried tonight.

    Upgrade from 8.0.2 to a Milhouse Leia build 0815 and same problem.

    I also created a new USB stick with 8.1.0 and the installer won't start. The same message appears.

    I suspect it could be some kind of kernel issue? Could there be some reason why the kernel is not compatible with my Revo3700?

    Does the USB installer app format the hard drive (suspect not)? Would it be worth a complete reformat?


    Kind Regards,

    ceekdp

  • Formatting won't achieve anything. I'm told we compress the kernel with xz (and overall squashfs with gzip) but we can't think up a scenario where this problem could occur. Milhouse (btw) is the staff member with a Revo3700. He reports no problems with his Leia images.

  • I've installed 8.0.2 on my Revo3700 and upgraded to 8.1.0 without any problem (using both img.gz and .tar for the upgrade).


    I also regularly deploy my test builds (.tar) to my Revo 3700, again without any issue.


    Have you installed 8.0.2 to the internal hard disk of the Revo 3700? It all sounds like you're somehow booting from the wrong media, possibly a BIOS issue?

  • Yes. 8.02 installs to the internal hard disk perfectly. The bios is set to boot from the internal hard drive first so I have to access the boot menu to boot from USB. It seems as if the new kernel on 8.1 will not unzip whether it is on a USB stick or installed on the internal hard drive(after I have updated from 8.0.2) When the installer starts from USB where does it try to extract the kernel to? USB or internal hard drive?


    I have used my Revo running Openelec/Libreelec for years with regular updates to beta and RC releases and never had an issue.

    Have you upgraded any part of your Revo? Are you still using the original HDD? Could this be a hardware issue with the HDD?


    I had a look at the bios and I couldn't see anything that looks out of the ordinary. Would you have any suggestions?


    Thanks again for looking into this for me. It is much appreciated.


    Kind Regards,

    ceekdp

  • When the installer starts from USB where does it try to extract the kernel to? USB or internal hard drive?

    Neither, the compressed kernel is booting in RAM (read from the USB). You should be able to boot the USB without a hard drive being attached.

    Have you upgraded any part of your Revo? Are you still using the original HDD? Could this be a hardware issue with the HDD?

    No upgrades, it's still got a 250GB HDD. Haven't made any changes to it in the 7 or 8 years I've had it.

    I'd need to look at my BIOS, but if 8.0.2 installs normally then in theory 8.1.0 should too. Can you try a different USB memory stick, it's _very_ unusual for the USB to not boot - either the KERNEL file is corrupt or the USB memory stick is corrupt.


    When you are upgrading, you are dropping the new tar file into the Update Samba share and rebooting? You're not extracting the contents of the tar manually (which you no longer need to do).


    I'll also write the 8.1.0 img to a USB and try booting the installer in my Revo3700.

  • The 8.1.0 installer booted without a problem from a cheap old USB memory stick. At the moment, other than corruption/hardware failure, I'm not sure what else to suggest. Maybe run memtest86+ to test your RAM?


    Edit: Just to add I used the "LibreELEC USB-SD Creator" (Windows, 64-bit) application to create USB memory stick. Don't write the 8.1.0 img.gz file directly to the USB memory stick (as that won't result in a bootable memory stick) - it needs to be uncompressed to .img, and then the .img written to the memory stick (the "USB-SD Creator" application handles all of this automatically). You probably know all of this already as you have a working 8.0.2 system but just in case... we've all done it. :)

  • Problem solved! - It turned out to be a faulty RAM module. I have now updated 8.02 to 8.1 with no issue.


    As suggested I ran memtest86+ and it noted that there were errors. I then changed the RAM with some spare I had from an old laptop and ran the update from within 8.0.2 and hey presto! It looks like the Revo3700 has some life left in it after all :)


    Thanks so much for your help guys! You create amazing software and I'm grateful you take the time to help users out to solve our problems.


    Kind Regards,

    ceekdp