OpenPHT - Plex Home Theater 1.9 FOR S905 S805 S912 WeTek Play 2 and other devices based on LibreELEC 8.2

  • ok i will try force resolution after i build all weteks

    Edited 2 times, last by veisen ().

  • I've got an old Sony surround amp and I normally connect the optical out directly into that but with OpenPHT and my Minix Neo U1 I only get stereo.

    Is there anyway to get 5.1?


  • Haha. Quoting "Eugene just changed name and compile". Funny, really!! You released incompele port to the public with lots of mistakes and no support. Got back 6 months later accusing somebody in copiing your work. Both sources for Libreelec and OpenPHT are free source project available to public and made available by very talanted programmers free of charge. In the github source I copied there is not a string of your own proprietary source code. Do you find it normal for using Kszaq's and Kwiboo sources? Don't you just copy and compile?

    Xtreamer Whizz S905-H AP6335 2GB Ram 16GB Rom

  • tell me please where to download open pht and device tree for s912?

    how to install?

    on the SD card or inside?

    Thank you

  • Does this work for Libreelec/CoreELEC 9.0?

    To answer your question, from the first post edit: new version of OpenPHT 1.9 is based od LibreELEC 8.2 by kszaq and it can be updated form LibreELEC 8.2

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 X96 Max+, Fire TV 4K Stick (Bedroom)

    Synology DS920+ Plex Pass


  • I originally tried this with pht 1.8 on a Beelink S905, that seemed to work.

    I have now tried pht 1.9, I created the Libreelec image with the device tree, & it booted from the latest

    That worked, I then put the pht 1.9 version into the update folder & rebooted, after initially extracting the archive, it then rebooted, & just hangs at the Pht logo.

    I previously tried to created the image of pht from the img.gz, but that still hangs.

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 X96 Max+, Fire TV 4K Stick (Bedroom)

    Synology DS920+ Plex Pass


  • Massive thanks to Veisen for making LE work as it should with regards to UpNP/DLNA.

    I was trying to make the stock LE work as a DLNA renderer on a NUC, but their implementation of DLNA is flaky at best.

    Tried to bring it up here, but got zero meaningful response from the local apparatchiks - LE as DLNA/UPNP Renderer Player only (no media server)

    I stumbled on OpenPHT and installed (using LE SD creatotr) the generic 86 version (img.gz) from here - Releases · Veisen/OpenPHT · GitHub

    I don't care for Plex, so I skipped the Plex account login (I don't hve one), and as a bare bones DLNA renderer (DIY media player) this OpenPHT is rock solid!! The only criticizm is that USB mouse support is disabled by default, so instead of trying (in vain) to click "Next" the workaround is to press Escape on k/b which lets you make all config settings via GUI.

    THANK YOU Veisen, you're the MAN

  • does anybody here know how update (compile) the LibreELEC base OS to latest, so far i have installed/ tried openpht from Releases · RasPlex/OpenPHT · GitHub base on libreelec 8.0 and Releases · Veisen/OpenPHT · GitHub base on 8.2 howvwer i would like to update/ compile it to have the latest libreelec stable version 8.2.5 or even try libreelec 9 (8.2.9 i think is call). any info will be appreciated, thanks

    original post:

  • Thanks for this OpenPHT build. This is what I'm looking for.

    I often use Plex's "Watch later" and only OpenPHT can play videos shared from Google drive without transcoding.

    So with this I can add my Google drive to Plex?

  • is OpenPHT 1.9 for s912 working i cant get it to work? i have tried differents dts but nothing

    Same here . Tried to install on Minix U9. It rebooted and stayed on the Open PHT screen

  • Same here, not working on my T95Z device, gets stuck at "openPHT" splash, i presume 1.8 doesn't work on s912 either?