8.0.2 to 8.2.0 update problem(s)

  • Yes plus Windows shares need credentials added if needed. In my case, I added a second windows user with credentials since my main user did not have a login and password assigned and then I added that user to the windows "share with" settings. Then every path in Kodi needed to be re-written to include the credentials. It seems there are many ways of doing this task and I think a built-in wizard would really help.

  • Finally I succeeded to create a local user in windows 10 with username and password and now I am able to access my samba shares from my X96.

    But when disable smb1 now I do not have access to the LE files on my windows 10. I created a registry key to enable smb2 but i am not able to access LE folders because windows 10 does not see my LE folders and also windows 10 stopped access to my SEAGATE Central folders. So it's the other way around.

  • If I understood blueribb's plight correctly you did not want to password protect your admin account because you wanted to reboot Windows without having to enter a password?


    That is solved by netplwiz and having just one (admin) account.


    Linux people are obsessed with accounts and passwords for security, they don't understand that most home users don't care about security; Windows has ways to get around that stuff, for now.

    Edited once, last by donbrew ().

  • No I am just wondering why my windows 10 does not see the LE folders and my nas after disabling smb1 and enable smb2 in windows....

  • That is an entirely different question. Mine did that, then suddenly they popped up in file explorer when I was starting to search here. I think it has something to do with which machine gets elected master. Try rebooting everything in a different order.


    I don't know why you would try to disable samba 1, the creator update did that.

  • Linux people are obsessed with accounts and passwords for security, they don't understand that most home users don't care about security; Windows has ways to get around that stuff, for now.

    Good advice will always be inclusive of users and will push, direct or persuade them towards better security habits. If you want to preach insecure habits we'd prefer you to keep quiet and not offer the advice. Fortunately Microsoft is also (finally) taking security more seriously. Feel free to note their current dislike of anonymous access and general direction towards everything being properly password protected, like Linux.

  • I have a shared folder on my LE from HDD connected to my router. It require login and password. After upgrading to 8.2.2 I can't get access to this folder. Just continuous tab with entering password which doesn't saves.

  • I have a shared folder on my LE from HDD connected to my router. It require login and password. After upgrading to 8.2.2 I can't get access to this folder. Just continuous tab with entering password which doesn't saves.

    This question was answered in other threads. Older routers may not support newer SMB protocols. You may need to update the firmware on your router or buy another router.

  • Old routers may require SMB1 and the legacy security option to be forced. It's a simple change in Kodi SMB client settings.

  • Old routers may require SMB1 and the legacy security option to be forced. It's a simple change in Kodi SMB client settings.

    I'm using ASUS RT-AC68U with the latest official firmware.

    Yes, I tried to set SMB1 in Kodi SMB client settings but it didn't help me. It still wants me to enter the password over and over again.

    When I go back to 8.0.2 everything works again.

  • I'm using ASUS RT-AC68U with the latest official firmware.

    Yes, I tried to set SMB1 in Kodi SMB client settings but it didn't help me. It still wants me to enter the password over and over again.

    When I go back to 8.0.2 everything works again.

    Try set both to "None" should work

  • Did you set legacy security (not just SMB1)? .. the reason that option was added in 8.2.2 was that we had reports of ASUS routers could not handle NTLMv2 and this option forces NTLMv1. Someone reported that the latest firmwares still contained ancient versions of Samba.

  • Did you set legacy security (not just SMB1)? .. the reason that option was added in 8.2.2 was that we had reports of ASUS routers could not handle NTLMv2 and this option forces NTLMv1. Someone reported that the latest firmwares still contained ancient versions of Samba.Ok

    OK, now it works. I didn't know it was in kodi service settings, I was changing only LE settings.


    Thank you.