Posts by Iridium

    Unless you see a yellow lightning bolt on boot then you *should* not have a problem.


    To be SURE:


    vcgencmd get_throttled.


    If 0x0 then you are fine.


    However that is just the RPi, not an overall quality. Check dmesg for -7xx issues.


    I've ALWAYS used official RPi power supply without any issues.

    I tend to use "native" NFS not SMB for preference but if that is not possible - try the SMB native, Also 5GHz if not already (Depends on location, distances etc.)

    To test the Wifi strength use:


    watch -n 5 iwconfig or use one of the many apps on your phone.


    If you want more detailed information, boot Raspbian and install wavemon.


    Also you didn't explain what your NAS is - maybe that is the issue.


    Can you also explain what USB Wifi you are using. If using a "small" dongle, then you're not going to get much better reception than the internal one. Get one with a big antenna.


    Try to move the adapter (with a extension cable) so that it is not blocked by anything - eg. TV, bookcase.


    As TonP mentioned No. 4 is the one to go for if you have to, but Kodi, with all their years of experience probably know more than us mere mortals.

    Generally mucking about with the video cache will have little effect unless you know what you are doing. Any changes usually have a knock on event elsewhere.


    In you case, you have memorysize of 0. So unless you have LE booting from a USB HDD/SSD with at least 16GB of free space, you will run into issues with Kodi stalling or even crashing. If booting from SD then you are putting a lot of wear and tear on your card, which could also be causing problems.


    I would remove your changes in advancedsettings.xml and look at your SMB server and Wifi connection.


    I had similar issues which was resolved by buying a decent Wifi adapter (With a large aerial) and using 5GHz


    You could also try "native" SMB connections Wiki rather than the Kodi internal SMB connection.

    I managed to recreate the error - but still no idea what is causing it.


    2019-11-08 09:41:34.809 T:3011690512 INFO: loading settings

    2019-11-08 09:41:34.809 T:3011690512 ERROR: CProfileManager: error loading special://masterprofile/profiles.xml, Line 0

    Failed to open file

    2019-11-08 09:41:34.809 T:3011690512 NOTICE: special://profile/ is mapped to: special://masterprofile/

    2019-11-08 09:41:34.809 T:3011690512 FATAL: unable to load profile

    Edit the SD card on *another* machine.


    Code
    1. cd /storage/kodi/userdata
    2. cp profiles.xml profiles.xml.origrm profiles.xml
    3. touch profiles.xm


    Place SD card in RPi and boot. It should start up in safemode.


    To return to normal operation:


    Code
    1. cd /storage/kodi-FAILED/userdata
    2. rm profiles.xml
    3. cp profiles.xml.orig profiles.xml

    Now reboot and Kodi should start normally.

    Even *if* it was possible to compile RPI4 for Kodi 17 I doubt anyone would bother to "downgrade" their release.


    CoreELEC is Amlogic only so no use.

    OpenELEC is *dead* AFAIK

    Raspbian *might* work but I doubt it - the only way to find out is to try.

    GeeXboX seems to be dead also.


    I guess your *best* solution is to use an older RPi3.

    @edjalmo Sorry no idea. Never experienced the "Safe Mode" nor did I know about the Wiki entry before this.


    Error was:

    Code
    1. 2019-11-06 07:31:07.251 T:1936753312 ERROR: CProfileManager: error loading special://masterprofile/profiles.xml, Line 0
    2. Failed to open file
    3. 2019-11-06 07:31:07.251 T:1936753312 NOTICE: special://profile/ is mapped to: special://masterprofile/
    4. 2019-11-06 07:31:07.251 T:1936753312 FATAL: unable to load profile


    Do you run with profiles?

    Try creating profile.xml in ./kodi/userdata

    With


    Save and reboot.

    I've tried to duplicate your issue but cannot get any sort of crash. I played a .mkv file over SMB without issues.


    I have a feeling it may be the way the file was created/decoded that is causing the problem, Can you provide a snippet of the offending file (IF LEGAL) so we can try and duplicate the issue.


    Yes: If you disable H/W acceleration, then it is decoded in S/W and thus the CPU has to work a lot harder - and WILL get hot,