Videoplayer issue on playback VC-1 Videocodec with AMD Mobility Radeon HD 5430

  • * all Matroska-Videos with VC-1 as Videocodec has fragments/jitter on playback, same Video on RPI- and RPI2-Hardware works
    * System: Arctic MC001
    ** ARCTIC MC001 | Media Center | TV Tuner and Recorder | Mini PC | Home cinema | Blu-ray | Silent
    ** CPU: Intel(R) Atom(TM) CPU D525 @ 1.80GHz
    ** GPU: AMD Mobility Radeon HD 5430
    * Libreelec Version: 7.0.2
    * File Infos: Matroska File with VC-1 Video-Codec
    ** Codec-ID: V_MS/VFW/FOURCC
    ** private Codec-Data, length 74 (FourCC: WVC1, 0x31435657)
    * guisettings.xml (VC-1 Hardware acceleration is enabled)
    <videoplayer>
    <adjustrefreshrate default="true">0</adjustrefreshrate>
    <autoplaynextitem default="true">false</autoplaynextitem>
    <errorinaspect default="true">0</errorinaspect>
    <hqscalers default="true">0</hqscalers>
    <pauseafterrefreshchange default="true">0</pauseafterrefreshchange>
    <preferdefaultflag default="true">true</preferdefaultflag>
    <prefervaapirender default="true">true</prefervaapirender>
    <quitstereomodeonstop default="true">true</quitstereomodeonstop>
    <rendermethod default="true">0</rendermethod>
    <stereoscopicplaybackmode default="true">0</stereoscopicplaybackmode>
    <stretch43 default="true">0</stretch43>
    <useamcodec default="true">true</useamcodec>
    <usedisplayasclock default="true">false</usedisplayasclock>
    <usedxva2 default="true">true</usedxva2>
    <useomx default="true">true</useomx>
    <useomxplayer default="true">true</useomxplayer>
    <usevaapi default="true">true</usevaapi>
    <usevaapimpeg2 default="true">true</usevaapimpeg2>
    <usevaapimpeg4 default="true">true</usevaapimpeg4>
    <usevaapivc1 default="true">true</usevaapivc1>
    <usevda default="true">true</usevda>
    <usevdpau default="true">true</usevdpau>
    <usevdpaumixer default="true">true</usevdpaumixer>
    <usevdpaumpeg2 default="true">true</usevdpaumpeg2>
    <usevdpaumpeg4>true</usevdpaumpeg4>
    <usevdpauvc1 default="true">true</usevdpauvc1>
    <usevideotoolbox default="true">true</usevideotoolbox>
    </videoplayer>

    Files

    • kodi.log

      (127.26 kB, downloaded 203 times, last: )

    Edited once, last by deepeye ().

  • I suffer from the same problem. I believe I can shed a little more light on it:


    While the problem persisted in all of the OE6 versions, it was finally gone in OE7 betas (6.95.x). I don't remember for sure about beta 1 or 2, but it worked 100% in 6.95.3.


    Then, Libreelec 7.0.x reintroduced the problem for me. So something must have changed there. I hope that helps you track down the cause.

    Edited once, last by Psych05 ().

  • I would suggest trying the latest LibreELEC x86 test build from this thread: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - these builds are more bleeding edge than 7.90.003.


    Once you have confirmed you still have a problem with VC1 material, post a full debug log after playing one of your VC1 movies - enable debug logging, reboot, play your movie, then "cat /storage/.kodi/temp/kodi.log | pastebinit" and paste the link in the test builds thread with a detailed explanation of the problem. One of the Kodi VideoPlayer developers will hopefully then be able to suggest a solution, which will be to post a bug on freedesktops.org, wait for AMD to fix their driver, or if you're lucky there will be a bug fix in VideoPlayer.