How can I disable IPV6?

  • Hi Guys,


    I have LibreELEC on a Pi3, I need to SSH in and disable IPV6... what should I be looking for?


    Thanks

  • Add ipv6.disable=1 to /flash/cmdline.txt.

    Thanks for your reply!


    I was setting this value:

    net.ipv6.conf.all.disable_ipv6=1


    And it was resetting back to 0 after every restart, driving me insane!


    Will try when I get home from work.

  • You could do that too and put it into /storage/.config/sysctl.d/ipv6.conf to have it set each boot.

  • Sorry, confused. What is the command I need to permanently disable IPV6 on each boot. (and to which file)


    Thank you.

    4GB ODROID N2 64GB eMMC, Asus i3 Chromebox 128GB, Nvidia Shield, Wetek Hub, AFTV
    CoreELEC Nightly, LibreELEC 9.2, Kodi 18.5

    LG 65" OLED C9 and Onkyo TX-NR636 Atmos 7.2

  • Run this command from ssh:

    Code
    1. echo "net.ipv6.conf.all.disable_ipv6=1" >/storage/.config/sysctl.d/ipv6.conf

    Thank you. Can you please also provide the command to undo this? In the event that I do want to use IPv6.

    4GB ODROID N2 64GB eMMC, Asus i3 Chromebox 128GB, Nvidia Shield, Wetek Hub, AFTV
    CoreELEC Nightly, LibreELEC 9.2, Kodi 18.5

    LG 65" OLED C9 and Onkyo TX-NR636 Atmos 7.2

  • One more question.... shouldn't disabling IPv6 on my wifi SSID settings also suffice?


    IPv6 is currently off there, but at random times, whenever I check my public IP address, sometimes it shows me my IPv4 address and other times it shows my IPv6 address. ?

    4GB ODROID N2 64GB eMMC, Asus i3 Chromebox 128GB, Nvidia Shield, Wetek Hub, AFTV
    CoreELEC Nightly, LibreELEC 9.2, Kodi 18.5

    LG 65" OLED C9 and Onkyo TX-NR636 Atmos 7.2