TVheadend not loading m3u file

  • Hi,


    I installed Libreelec 8.0.2 and tvheadend 4.2, when I tried to load my m3u it keeps saying 'no such file or directory'


    I used the same m3u file when tvheadend was on lubuntu, so I know the file is good. When using Libreelec, I copied the files to the picons folder. From the file manager it stated the file location was at libreelec.local/picons/. In tvheadend, I put the m3u file location as file:///libreelec.local/picons/prime.m3u to load my local channels from hdhomerun prime. But all it says is 'unable to open file 'libreelec.local/picons/prime.m3: no such file or directory'


    Is tvheadend not able to view this directory?


    Can somebody please tell me what I'm doing incorrectly?


    Thanks in advance.



  • I tried file:///storage/picons/prime.m3u but still nothing happens. I see nothing updating in the logs. is storage an external drive because I'm using an internal drive?


    Any other suggestions?


    Thanks

    Edited once, last by pepe999: update ().

  • I tried file:///storage/downloads/prime.m3u and I also tried copying the file to a usb drive and did file:///sdb1-usb-sandisk_extreme_/prime.m3u and both time I still got no such directory or file.


    I'm using an Asus chromebox.

  • The path to the usb drive will likely be something like:


    file:///var/media/sdb1-usb-sandisk_extreme_/prime.m3u


    assuming sdb1-usb-sandisk_extreme_ is the correct name of the drive (trailing underscore??)


    For the downloads folder - try:


    file:///downloads/prime.m3u

  • Thank you all for your help, it finally worked.


    When I had the maximum number of streams to 3, it could not find the file. It's strange because when I used it for Lubuntu it had not issues but with Asus chromebox it didn't work. I then set the maximum number of streams to 0 and it found 3 channels and 2 failed. I set the maximum number of streams back to 3 and scanned again and now it has all 5 channels.