Help with networking issue please.

  • Hello. I hope this is the correct forum for this question. Not sure what information is needed.


    I am using LibreELEC on my Raspberry.

    I am using a wired network.


    I have a gateway router provided by ISP (192.168.1.1) with my own router serving as a Switch (?) actually two one on each end of house (old house and wifi doesn't work very well).

    The "switches" are 192.168.1.111 and 192.168.1.112.


    Raspberry is connected to the switch.


    I can SSH to the Raspberry. But from the device I can't seem to see the network - pinging gateway or switch or any device times out

    There is no /etc/network or /etc/networking directory so not really sure where the networking settings are store...


    This is the networking information I can see...

    LibreELEC:~ # route -n

    Kernel IP routing table

    Destination Gateway Genmask Flags Metric Ref Use Iface

    0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0

    192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0

    192.168.1.1 0.0.0.0 255.255.255.255 UH 0 0 0 eth0

    LibreELEC:~ # netstat -rn

    Kernel IP routing table

    Destination Gateway Genmask Flags MSS Window irtt Iface

    0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0

    192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0

    192.168.1.1 0.0.0.0 255.255.255.255 UH 0 0 0 eth0



    I swear this all worked at one point.


    Thanks for any advice.

  • More info needed


    What are you using to ssh to the pi? and what ip/nm/gw does that have?


    what IP does the pi have? /nm/gw


    Are you using DHCP?


    if you and the pi are on the same switch then that can have an impact

    3 NUC's, 3 Pi's, Android Beelink R38, Odroid C2, 2 original XboX's and now a Amlogic T95m S905 2/8