intel NUC6CAYH no audio out via HDMI in LE (Linux)

  • Affected : intel NUC6CAYH


    Expected behavior :

    HDMI audio output to 4k TV via HDMI 2.0 port.


    Observed behavior :

    Librelec 8.02 : No HDMI audio at any resolution. Sound works through Ear phone jack.

    Xubuntu 17.04 (Kernel 4.10x) : No HDMI audio at any resolution. Sound works through Ear phone jack.

    Windows 10 (+/-Kodi 17.3) : No HDMI audio output at all resolutions. Sound works through Ear phone jack.


    Actions :

    Checked BIOS sound is set to 'ON' (it was).

    Updated BIOS to latest AYAPLCEL.86A.0038 (Download HDMI 2.0 Firmware Update Tool for Intel® NUC Kit NUC7i3BN, NUC7i5BN, NUC7i7BN, NUC6CAY)

    Updated Megachip HDMI Firmware to 1.66 via Windows only software (Download BIOS Update [AYAPLCEL.86A])

    Repeat test observed behavior:

    Librelec 8.02 : No HDMI audio at any resolution. Sound works through Ear phone jack.

    Xubuntu 17.04 (Kernel 4.10x) : No HDMI audio at any resolution. Sound works through Ear phone jack.

    Windows 10 (+/-Kodi 17.3) : HDMI audio output as expected at all resolutions. Sound works through Ear phone jack.


    Reference:

    MCDP28x0 DisplayPort1.2a-to-HDMI 2.0 Converter

    MCDP28x0 DisplayPort1.2a-to-HDMI 2.0
    NUC6CAYH Product Change – Up-to-date Firmware Out of the Box
    NUC6CAYH Product Change – Up-to-date Firmware Out of the Box – The NUC Blog
    PCN115449-00.pdf

    Filed a bug at Linux DRI, sourly informed 'it works for everybody'.


    Clearly it doesn't...Suggestions?


    T

  • Not sure if this is to any help, but I have had some HDMI audio trouble with the NUC6CAYH as well.


    Tried several Linux distros, and the only one that had audio working out of the box was Linux Mint, this was on a 34" Dell monitor.


    Decided to try installing Kodi on the NUC, connected it to my Panasonic TV and installed Libreelec 8.02, no audio with the default setting, had to change audio setting in Setting > System settings > Audio to the following.


    Another thing, I tried to change the Video Settings in the BIOS on the NUC, and found that if I change IGD Minimum Memory to 512 MB and IGD Aperture Size to 512 MB the Audio on Video playback was missing, but GUI sounds was ok. Changed IGD Minimum Memory to 64 MB and IGD Aperture Size to 256 (Default) and the audio was back.


    So if you have changed the Video Setting in the BIOS, try change it to the above.


    I am on the latest BIOS (38) and HDMI Firmware 1.66

  • Did you set audio output channels to 2.0? then enable passthrough. That works for me. I had problems in the past on an older NUC when channels not set to 2.0.

  • Did you set audio output channels to 2.0? then enable passthrough. That works for me. I had problems in the past on an older NUC when channels not set to 2.0.

    First thing one tries. No dice. Thanks anyway.

  • Thx thansen,

    Suggestion 1) : I don't have those devices to choose from.

    Suggestion 2) : I tried your setting - no difference. I will leave the video settings on default for now.

  • Today I installed Xubuntu 17.04 + kodi 17.1 from the repos.

    journalctl --dmesg output attached.

    alsa info attached.

    kodi.log attached.


    The target device is a Polaroid 49" UHD (4K) Television. HDMI v1.4 HDCP v2.2

    [A second 4K television from a different manufacturer was tested & also had no sound]


    The problem seems to be that the Linux drivers do not see the TV on the HDMI at all.

    Before we blame the TV, WIndows10 drivers work as expected.

    I have a bug running with freedesktop DRi dev's.

    Files

    • dmesg.txt

      (73.55 kB, downloaded 100 times, last: )
    • alsa-info.txt

      (40.05 kB, downloaded 117 times, last: )
    • kodi.log

      (201.25 kB, downloaded 153 times, last: )

    Edited once, last by Tubod ().

  • This what I had to do to get sound out through HDMI put from an Ubuntu 16.10 system on Intel NUC6CAYH. I hope it helps the dev's

    Its very, VERY flakey. Breathe on it & sound stops working again. Totem kills the sound reliably so uninstall it & use VLC.

    Note 1 : The package 'oem-audio-hda-daily-dkms' does not exist in the Graphics drivers PPA.

    Note 2 : Ubuntu 16.10 is the most recent being packaged for by the ALSA PPA guys.

    Note 3 : Keep your resolution no higher than 1920x1080 or no sound via HDMI again..

    Note 4 : When sound via inevitably stops, Log out & back in. Check sound mixer settings & return them to HDMI/Display port/Stereo etc again.


    Follow these steps to resolve the issue:


    1. Make sure that your system is up-to-date using the Update Manager.


    In a Terminal window, run the following:

    sudo apt-get update && sudo apt-get upgrade

    Reboot the system.


    2. Add the following groups to your account:

    audio, pulse, pulse-access, video, voice


    ( Install the better user/groups gui to manage this:

    sudo apt-get install gnome-system-tools )


    3. Add the Graphics Drivers PPA

    [ Oibaf : Updated and Optimized Open Graphics Drivers repo ]

    [ Updated and Optimized Open Graphics Drivers : Oibaf ]


    In a Terminal window, run the following:


    sudo add-apt-repository ppa:oibaf/graphics-drivers

    sudo apt-get update

    Reboot the system.


    4. Add the ALSA PPA (all versions of Ubuntu up to 16.10, 17.04 NOT supported)

    [ ALSA daily build snapshots repo ]

    [ ALSA daily build snapshots : “Ubuntu Audio Development Team” team ]


    In a Terminal window, run the following:


    sudo add-apt-repository ppa:ubuntu-audio-dev/alsa-daily

    sudo apt-get update && sudo apt-get install oem-audio-hda-daily-dkms

    Reboot the system.


    5. Make this directory if it does not exist under /etc/X11:

    sudo mkdir xorg.conf.d


    Create this new file:

    sudo nano /etc/X11/xorg.conf.d/20-intel.conf


    Paste this content into the newly created file:


    Section "Device"

    Identifier "Intel Graphics"

    Driver "intel"

    # Option "SwapbuffersWait" "true"

    Option "AccelMethod" "SNA"

    # Option "AccelMethod" "UXA"

    Option "TearFree" "true"

    Option "DRI" "3"

    EndSection



    To revert to standard Ubuntu graphics drivers type the following in a prompt shell:

    $ sudo apt-get install ppa-purge

    $ sudo ppa-purge ppa:oibaf/graphics-drivers


    To revert to standard Ubuntu ALSA drivers type the following in a prompt shell:

    $ sudo apt-get install ppa-purge

    $ sudo ppa-purge ppa:ubuntu-audio-dev