Worked great on SD card, install to NAND failed

  • Sorry if this question is asked over and over, but I've been searching for days now and really can't figure it out on my own.


    I have 2 MQX Pro's which are pretty crappy the way they come out of the box, so I soon started experimenting with LibreELEC on SD cards created with the LibreELEC SD card tool. One of them gave me some headaches because the remote.conf I extracted from the android root didn't work for LibreELEC. Eventually I got it working by using the remote.conf for a Mini M8S II and remapping some keys.


    In the end I got 2 fully working boxes that worked great with their own LibreELEC SD card and I was ready to install it to NAND.
    I opened up terminal on OS X, SSH’d into LibreELEC’s IP, entered installtointernal followed by a yes and a y if I remember correctly, and in the end I got this message:


    All done! You can now continue using your LE system or type "rebootfromnand" to reboot from internal memory.WARNING: If your internal memory layout is different from standard Amlogic, you have to reboot and perform this operation again!


    So I rebooted with rebootfromnand with the SD card still inserted, when it was booted I turned it off with my remote, took out the SD card and fired it up again. Only, nothing happened :p The screen just stayed black. I tried booting from SD card again and that works, but my remote no longer works and the Kodi displayed is not my custom Kodi but a fresh start with no addons.


    Now I don’t know if LibreELEC is installed on the NAND and just won’t boot without the SD or if I’m running LibreELEC from the SD card. I can still login with terminal and Filezilla but how to tell if I'm accessing the NAND or the SD card?


    At this point I don’t really know what to do since the tutorial I followed doesn’t cover this. Should I try starting all over again with a fresh SD card and the toothpick method or can I still fix this through SSH with terminal or Filezilla?


    Any help or link to a tutorial that works for my box is greatly appreciated!


    EDIT: I just checked the SD card and my remote.conf is still present so I don't understand why it doesn't work. There are also 2 new files created on the SD card during the process: recovery20170427215040.img & dtb20170427215040.img


    EDIT 2: after checking my SD card on my laptop, I unplugged the box, inserted the card and plugged it back in and now I'm seeing my custom Kodi again so I did run it from NAND before, it just doesn't boot without the SD card present. I'm guessing I have to ssh the correct device tree and remote.conf to some folder on the NAND before it runs without the SD card?


    EDIT 3: I tried installtointernal again but this time chose no when asked if I wanted to copy user data to internal memory. When entering rebootfromnand it booted into a fresh start with working remote! I rebooted without the SD card and now it works with remote and everything so my problem is solved :)


    However, I'm curious if it has something to do with this line: 'WARNING: If your internal memory layout is different from standard Amlogic, you have to reboot and perform this operation again!'. Can someone tell me more about it?

    Edited once, last by freekdl ().

  • Interesting, I had the exact same issue with my MXQ Pro, but I already tried your fix and it didn't work. No matter what I do, it always needs the sd card (or usb drive) inserted to work. I also tried running installtointernal twice as instructed, but only ended up with the same result. I'm going to reflash my box's firmware (doesn't boot to anything anymore), create a new sd card and try again.