Cannot access settings

  • So, I have a media streamer (Nexbox a95x s905x) and I did the spinztv lite fresh install (v2.8) and since then it has screwed up my kodi. I went to the settings and tried to do a channel update to upgrade my kodi from 16.1 to 17 and since I clicked "channel update 8.0" my settings disappeared and now I cant even do a system reset. Anyone ever have this issue? Is there a way I can perform a system reset on my box? update to 17 is turning out to be a lot of trouble :(


    Disclaimer: Im very new to media streamers/kodi/libreelec. This is literally my first time doing any of this so keep that in mind :)

  • via ssh,

    Code
    rm /storage/.kodi/userdata/addon_data/service.libreelec.settings/oe_settings.xml

  • "Via SSH" are the operative words, basically your access via the backdoor.


    See Accessing LibreELEC - LibreELEC for more info.


    alright but how do I open the terminal is what im asking? im not using kodi through a desktop computer but rather directly from the media box. Can't find the SSH anywhere unless im just too blind to see it. Like I previously mentioned, very new to these things and easy things for other people seem to be difficult for me
    [hr]


    "Via SSH" are the operative words, basically your access via the backdoor.


    See Accessing LibreELEC - LibreELEC for more info.


    alright so its my understanding now that I can download Putty on Mac (my OS) and through there I can access the SSH

    Edited once, last by oddbrandon ().

  • You don't need putty on a Mac, just open the terminal and you can use ssh directly


  • alright so its my understanding now that I can download Putty on Mac (my OS) and through there I can access the SSH


    additionally what lrusak says....just open a terminal (console) on the mac and enter the following:


    Code
    ssh [email protected]<ip.of.LE-device.here>


    you will be asked for a password after which is: libreelec


    If you will get something like "connection refused", you have to enable SSH in the LibreELEC service settings:
    LibreELEC Settings - LibreELEC


    and then try again. If you have got it managed to log in, then do the command lrusak told you in posting #2