8.0.1 freezing

  • I run rpi2 with 7.0.2 very stable but addons, etc need never version so I must upgrade. But I find 8.0.1 is freezing up playing video over local network.


    The only thing I think is my config.txt overclocking and memory gpu 320? But if hardware going fine with setting on old build, new build should not change this?

    Edited once, last by wanderlei ().

  • I would try without your O/C settings - I can't honestly believe it makes a lot of difference.
    Post you original config.txt as well.


    It's also possible that advancedsettings.xml was overwritten by the upgrade.

  • Thanks lads.


    I have reverted for moment back to 7.0.2. I will get 8.01 running with stock config.txt, enable all logging and try get something I can consistently replicate and not waste your time.


    This is my config.txt, I was rocking like 6 months uptime with it.


    force_turbo=1
    hdmi_force_hotplug=1
    hdmi_drive=2
    arm_freq=950
    sdram_freq=450
    gpu_freq=350
    gpu_mem=320


    My advanced settings I manually replaced because I read then naming convention changed and I like to avoid buffering issues.


    <advancedsettings>


    <cache>
    <memorysize>104857600</memorysize>
    <buffermode>1</buffermode>
    <readfactor>10</readfactor>
    </cache>


    </advancedsettings>


    From info panel while watching video it was usually saying 20% memory used.

    Edited once, last by wanderlei ().

  • With a new Kernel some things might change. Personally, I've never seen any reason (apart from the can do factor) for O/C the RPi2. Go back to default and I reckon everything will be stable again.

  • I think advanced setting might be cause.


    I use stripped back 8.0.1 version free my of addons, etc.


    Playback over local network.


    A) No advancedsettings.xml - buffering issues - playback slowing right down to slow motion.


    B)
    <cache>
    <memorysize>104857600</memorysize>
    <buffermode>1</buffermode>
    <readfactor>10</readfactor>
    </cache>


    Also not great not playing video correct speeds, like in prolonged slow motion at points.


    C)
    <cache>
    <memorysize>54857600</memorysize>
    <buffermode>1</buffermode>
    <readfactor>4.0</readfactor>
    </cache>


    Seems better from what I test.


    Here is logs
    ################################################################################ - Pastebin.com
    Do5slt isydqifmrH TE=

    Edited once, last by wanderlei ().

  • I changed routers to rule that out and added new advancedsettings.xml to my full setup of 8.0.1 and video playback has been perfect again so far.


    Sorry to trouble you with stupid end user.

    Edited once, last by wanderlei ().

  • My working video cache is:
    <advancedsettings>
    <cache>
    <buffermode>1</buffermode>
    <memorysize>524288000</memorysize>
    <readfactor>20</readfactor>
    </cache>
    </advancedsettings>


    This is for a 2G Cubox so halve the memory for a 1G Rpi.