8.0.1-9.0.2 x86: Incorrect default aspect ratios on refresh rates other than 60Hz [SOLVED]


  • It's already set to 1.000000 everywhere here...


    Upgrade or Clean install? Because LE 7.0.3 didn't have this issue. I suppose that all the settings preserved during the upgrade procedure. This can be verified by doing full config reset on LE 8.0.1.

    ASUS N3150I-C

    Edited once, last by Teppopups ().


  • Unfortunately changing the settings directly in the guisettings.xml file did not work for me, as it won't save the values i put in there and will always revert back to the wrong settings once a video is played or after a reboot.
    Also tried overriding these values with the advancedsettings.xml file but still no luck there, it won't override the guisettings.xml in this case.


    The only way to make it work here was to play a video file of every refresh rate which gives me the wrong aspect ratio, bring the OSD, go to video settings then "video calibration".


    Today I realized that my aspect settings also reverted to original wrong values :(


    Edit:
    Seems that you need to stop the Kodi before modifying the file, otherwise it will revert back on reboot/restart:


    1. stop the Kodi, so it will write the config from memory to a file:
    # systemctl stop kodi


    2. edit the guisettings.xml file, then start the Kodi again so it will read the configuration:
    # systemctl start kodi


    3. verify if the file changes preserved after restart:
    # systemctl restart kodi


    It worked for me, even after several reboots the aspect is still correct: 1.000000

    ASUS N3150I-C

    Edited once, last by Teppopups ().

  • Upgrade or Clean install? Because LE 7.0.3 didn't have this issue. I suppose that all the settings preserved during the upgrade procedure. This can be verified by doing full config reset on LE 8.0.1.


    Clean install on 7.90.x then upgrade since then.


  • Thank you for this! While my LE installation works (and looks) just great, I was always slightly annoyed that after a fresh install I had to go into the Video Calibration section and tweek my pixel ratios to get them to 1.000 and it would often jump from .998 to 1.001 or something like that while using the left/right buttons on my remote. It took several attempts to hit 1.000. Now I can just edit the guisettings.xml file.


    Gratitude!

    Krypton v7.90.007 ALPHA, Aeon Nox 5 SiLVO


    HP Pavilion Mini 300-230, i3-5005U, Intel HD Graphics 5500, 8 GB ram, 120 GB SSD


    Samsung F6300 46" LED LCD TV, Onkyo HT-RC430 AVR, Pioneer HPM-100 speakers (old school!)


    Synology DS215j NAS fileserver


    Bacon is the King of Meats


  • Stopping Kodi before making these changes worked here also.
    Again Thank you

  • LibreELEC version 8.2.4 - the problem persists ! No one noticed? Everyone is using plain 60Hz?

    ASUS N3150I-C

  • Teppopups

    Changed the title of the thread from “8.0.1-8.2.4 x86: Incorrect default aspect ratios on refresh rates other than 60Hz [SOLVED]” to “8.0.1-9.0.2 x86: Incorrect default aspect ratios on refresh rates other than 60Hz [SOLVED]”.
  • O, come on guys!!! Versions come and go, LE v9.0.2 - still the same problem with default aspect ratios. Again! (see the solution above)

    ASUS N3150I-C

  • Thanks for this, I noticed the little black bars left and right on 25fps material and managed to fix this using this.