Can't Set Time

  • I've installed the latest and greatest LibreELEC on my S905 device (2/16 memory configuration).


    Everything works beautifully, but I can't, for the life of me get the time to correctly display.


    I have gone into LibreELEC settings, Network and set up ntp servers and set the wait time to 10 seconds (and as much as 60), but the display seems to pick a correct time for the minutes but the hour will be randomly set 2 to 8 hours ahead - it varies from boot to boot, it seems.


    I have entered various ntp servers - from pool.ntp.org to 1.north-america.pool.ntp.org to military servers and others I've found via google. I have also tried pointing to my router, which supplies everything else with the time.


    I have used both text and IP addresses. No fix.


    The device is on a wired network and the wireless has been turned off. All of my other computer equipment gets


    The build I'm using was under: LibreELEC 8.0 (Kodi 17 Krypton) community builds from kszaq:


    Thanks for any assistance anyone can provide.

  • Go to Libreelec configuration program addon....
    click on connections-
    click on wired interface....
    click on edit...
    click on Ipv4..
    click on ip address method...set to manual...
    scroll down to ntp servers...
    set :
    timeserver 1 to 0.pool.ntp.org
    timeserver 2 to 1.pool.ntp.org
    timeserver 3 to 2.pool.ntp.org
    then you can set back to dhcp
    [hr]
    Also you dont have to touch any of the network settings...just make sure active is enabled...wait for network before starting kodi disabled assuming you have internet always on..ntp servers leave empty as you are setting them directly from connection.

    Edited once, last by Mario77 ().

  • I have a similar problem: often time and date reset to 1-1-2015/2:00 (I assume time is GMT+2, my time zone).


    Network is already set as Mario77 advised and "wait for network" is enabled. I use a wired powerline connection.

    Running kszaq's LibreELEC 8.2.2.3 and adamg's LibreELEC 9.x 1.0.6 on Cooleme MB1 (S905X - 2GB/8GB)


  • I have a similar problem: often time and date reset to 1-1-2015/2:00 (I assume time is GMT+2, my time zone).


    Network is already set as Mario77 advised and "wait for network" is enabled. I use a wired powerline connection.


    You have to set ntp servers from the Connections menu not Network menu

  • Did anyone ever get a fix for this problem. I also have this using the latest build from kszaq. I have set the ntp servers (actually they were already set in Connections but still no time update unless I manually enter into a time server and click OK to save.

  • Hi all,

    While I'm an old nerd, I'm new to this forum. I too was bothered by the time not being correct. I have a RPi3 with a new install of LibreELEC (Version 8.0.2). After searching through everywhere it seemed obvious it would be, I happened to check the "Interface settings". Once there, the second item in the menu is "Regional". There it has all the various things to set the clock as well as the format and such. Hope this helps.


    Edit: should have mentioned that when you click on "Interface settings", you'll need to change from "Basic" (the gear wheel to the bottom left"). Each level gives you different options. Going at least to "Advanced" gives you most all the options; certainly enough to get the time and date displayed however you would prefer.