WOL is not working

  • Hello all
    I upgraded my OpenELEC 5.0.3 Nvidia Legacy build to LibreELEC 7.0.1 Generic Build, and it went very well


    However since the upgrade the WOL (Wake-On-LAN) is not responding, it used to work fine under OpenELEC 5.0.3 Nvidia Legacy build.
    And there was no change in the hardware or my network.


    I’ll appreciate any suggestions / investigation directions.
    Thanks a lot
    Dan

    Technical details:
    I use Yatse remote app --> details?id=org.leetzone.android.yatsewidgetfree
    And my hardware is Xtremer Ultra (1) --> Xtreamer Ultra specs
    I use the LAN connection (not Wi-Fi)

  • could you please show use the output of


    Code
    1. ethtool eth0 | pastebinit


    "eth0" might be different on your system. So please check with


    Code
    1. ifconfig


    which NIC is in use and change the first command to the matching one.


    A first thought might, that your power settings are different now on LibreELEC and therefor it behaves different than OE does. So please check your BIOS and your power settings once again if something is different in there.

  • Thanks DaVu
    Here is the output NRLZ
    can you please guid me what to look for in the BIOS, and where to check the power settings that you mentioned ?


    Thanks Dan

  • I reviewed the entire BIOS settings but could not find the power options
    In any case if I restore to OpenELEC it works and on LibreELEC it doesn’t (I’m not changing anything on the BIOS)

  • I would say CvH has figured out your issue. I had the same problem, my IP address did not change and the host could still be controlled by YATSE but the WOL and power options wouldn't work until I deleted the host and added it as a new host to YATSE. This seem to happen because you upgraded versions of Kodi not because of changing from OE to LE or even upgrading OE or LE.

    gracious anarchy @ 17mph

    Edited once, last by yort ().

  • Thank you CvH & yort, you are right.
    After I removed the host from my Yatse remote and readded it, WOL is working :-)

  • Sorry to poke on an old thread, but i have the same issues when changing from kodibuntu to LE.
    Trying to activate WOL via SSH or reconfiguring into Yatse sofar is not working for me.


    Running the following:
    ASrock E350M mainboard
    Yatse on Android (Galaxy S5)
    EL (latest version with krypton)


    Any pointers?
    [hr]
    I have noticed when accessing with SSH and entering the command: "

    Code
    1. ethtool -s eth0 wol g


    " the system responds correctly to WOL.
    However when putting it back to sleep it stop responding, checking the status then sets setting "Wake-on" to d resulting in no WOL trigger untill i set it again for one time.


    Any way to get this permanently on the g setting?

    Edited once, last by soest009 ().

  • Dear CvH thanks for your reply, i am still a bit of a noob concerning linux.
    Can you please explain how this can be done using an SSH session?


    Many thanks in advanced.

  • Code
    1. cd /storage/.config


    Code
    1. nano autostart.sh


    with that commands you will change to the /storage/.config folder and the "nano" command will open an editor to enter the needed things to the file "autostart.sh" (which will be created automatically). After you did your changes, save and exit the file.


    Not really needed, but it doesn't hurt, make that file executably with:


    Code
    1. chmod +x autostart.sh


    Then, everytime you boot up LibreELEC, the commands inside that script are executed.

  • Dear DaVu, i have added the line to autostart.sh however situation remains unchanged, after one successfull suspend followed with WOL wakeup the system no longer responds to WOL requests.
    Also after checking the setting it's back to disabled mode.

  • Been looking around some more and found out that the PCI deviced linked to my ethernet adapter shows as S4 state disabled.
    when using code cat /proc/acpi/wakeup This shows me that: PCE4 S4 *disabled pci:0000:00:04.0 which resembles my nic.
    I figure this has to do with the fact that ethtool keeps switching back to disabled wol, is this true?


    Furthermore i doublechecked bios settings and virtually everything that could invoke remote wakeup is on.
    Any suggestions?

  • Been a while again and discovered (more dumb luck t.b.h.) that WOL from suspend doesn not function, however when powering down WOL does respond to the WOL command from Yaste correctly.
    No clue how it is like this but i am happy, so the way i see it: stay away from suspend :P

    Edited once, last by soest009 ().