Posts by soest009

    Been a while again and discovered (more dumb luck t.b.h.) that WOL from suspend doesn not function, however when powering down WOL does respond to the WOL command from Yaste correctly.
    No clue how it is like this but i am happy, so the way i see it: stay away from suspend :P

    Been looking around some more and found out that the PCI deviced linked to my ethernet adapter shows as S4 state disabled.
    when using code cat /proc/acpi/wakeup This shows me that: PCE4 S4 *disabled pci:0000:00:04.0 which resembles my nic.
    I figure this has to do with the fact that ethtool keeps switching back to disabled wol, is this true?


    Furthermore i doublechecked bios settings and virtually everything that could invoke remote wakeup is on.
    Any suggestions?

    Dear DaVu, i have added the line to autostart.sh however situation remains unchanged, after one successfull suspend followed with WOL wakeup the system no longer responds to WOL requests.
    Also after checking the setting it's back to disabled mode.

    Dear CvH thanks for your reply, i am still a bit of a noob concerning linux.
    Can you please explain how this can be done using an SSH session?


    Many thanks in advanced.

    Dear community,


    I recently swichted from Kodibuntu towards EL (Krypton 17) and am very happy about the way this is build.
    However since this moment i am having issues with the WOL function, this has functioned perfectly in the past with Kodibuntu.
    When i switch the WOL function using ethtool towards the g setting this functions for a single suspend, after turning the system back on with WOL the setting magically returns to disabled state (d).


    How can this be altered to WOL will keep functioning and the setting does not return to disabled state?


    Specifications:
    Mainboard: Asrock E350M1 (AMD Zacate APU)
    Controlling tool: Yatse on Android (Galaxy S5)


    Thank you all in advanced!

    Sorry to poke on an old thread, but i have the same issues when changing from kodibuntu to LE.
    Trying to activate WOL via SSH or reconfiguring into Yatse sofar is not working for me.


    Running the following:
    ASrock E350M mainboard
    Yatse on Android (Galaxy S5)
    EL (latest version with krypton)


    Any pointers?
    [hr]
    I have noticed when accessing with SSH and entering the command: "

    Code
    1. ethtool -s eth0 wol g


    " the system responds correctly to WOL.
    However when putting it back to sleep it stop responding, checking the status then sets setting "Wake-on" to d resulting in no WOL trigger untill i set it again for one time.


    Any way to get this permanently on the g setting?