[SOLVED] Build with libvorbisenc (for Retroarch)

  • Hi,

    i am testing my self-compiled master of LE. I`ve checked it out about two weeks ago.

    All runs fine except when I want to use the "Retroarch" addon (by ttsemek) from here:
    retroarch-openelec - Browse Files at SourceForge.net

    I did already test it some months ago in Openelec (it was version 6 i think) where it ran without any problems.

    When I installed the plugin into my LE installation the same way (retroarch-full-1.3.3) the plugin was activated successfully but when i try to start it after that nothing happens.

    I tried to go into ssh and try to start the retroarch.sh executable from there.

    This is the error message i get:


    /storage/retroarch/default/bin/retroarch: error while loading shared libraries: libvorbisenc.so.2: cannot open shared object file: No such file or directory

    I already tried to activate the "libvorbis" package for my build by adding it to the package dependencies but the library did not turn up (but it was built) in /lib.
    I tried to install the Vorbis Encoder addon from the repository but it did also not help.
    And I also tried to turn on vorbis in ffmpeg compilation options (--enable-libvorbis for .configure) but nothing changed.

    I am at the end of my ideas.

    What can i do to get libvorbis / vorbisenc back into the build (i guess it has been dropped since?).

    Thank you !

    Edited once, last by Thomas233 (September 30, 2016 at 12:42 PM).

  • Please don't post the same thread twice, ask for it to be moved if necessary, and be patient for replies.

    Hey chewitt, sorry I thought it may be better placed here and therefore removed/moved it from the addons section. Sorry !


    libvorbis is now linked statically, so you will need to recompile retroarch or copy over the shared library from somewhere else.

    Ok, thank you for the information. I already guessed there may have been some changes.

    However btw, what`s the difference between libvorbis and libvorbisenc and is there a package for the encoder also (or do I have to activate the encoder addon) ?