LibreELEC ODROID-U2/U3 support

  • The only file you need to download for a fresh install is LibreELEC-Odroid_U2.arm-8.0.0.img.gz in the eMMC folder for an eMMC install or in the SD folder for a SD card install.
    Then you use the LE graphical installer to install it on the destination of your choice.


    The .tar file is for updating an already installed ODROID-U3 box and the others for developers.

  • Thanks, works really well. little bit of a line through some videos but barely noticeable and having cec issue even though connected to hdmi 1

  • Code
    1. 12:07:40.962 T:2915038112   ERROR: CecLogMessage - Write: write failed !12:07:41.222 T:2305815456   ERROR: Previous line repeats 1 times.12:07:41.222 T:2305815456  NOTICE: Creating Demuxer12:07:42.453 T:2915038112   ERROR: CecLogMessage - Write: write failed !12:07:42.602 T:2305815456  NOTICE: Opening stream: 0 source: 25612:07:42.602 T:2305815456  NOTICE: Creating video codec with codec id: 2812:07:42.697 T:2915038112   ERROR: CecLogMessage - Write: write failed !12:07:42.859 T:2305815456  NOTICE: CDVDVideoCodecMFC::Open - MFC Setup succesfull (1920x800, linesize 1920, format 0x32314d4e), start streaming12:07:42.859 T:2305815456  NOTICE: Creating video thread12:07:42.859 T:2305815456  NOTICE: Opening stream: 1 source: 25612:07:42.859 T:2305815456  NOTICE: Finding audio codec for: 8601812:07:42.860 T:2527589280  NOTICE: running thread: video_thread12:07:42.861 T:2305815456  NOTICE: Creating audio thread12:07:42.861 T:2255483808  NOTICE: running thread: CVideoPlayerAudio::Process()12:07:43.426 T:2255483808  NOTICE: Creating audio stream (codec id: 86018, channels: 2, sample rate: 44100, no pass-through)12:07:43.614 T:3034296320  NOTICE: Using GL_TEXTURE_2D12:07:43.640 T:3034296320  NOTICE: GL: Selecting Single Pass YUV 2 RGB shader12:07:43.665 T:3034296320  NOTICE: GL: NPOT texture support detected12:07:43.941 T:2915038112   ERROR: CecLogMessage - Write: write failed !14:05:37.327 T:2255483808   ERROR: Previous line repeats 9511 times.14:05:37.328 T:2255483808  NOTICE: CVideoPlayerAudio::Process - stream stalled14:05:37.342 T:2305815456  NOTICE: CVideoPlayer::OnExit()14:05:37.342 T:2305815456  NOTICE: VideoPlayer: eof, waiting for queues to empty14:05:37.342 T:2305815456  NOTICE: Closing stream player 114:05:37.342 T:2305815456  NOTICE: CDVDMessageQueue(audio)::WaitUntilEmpty14:05:37.342 T:2305815456  NOTICE: Waiting for audio thread to exit14:05:37.352 T:2255483808  NOTICE: thread end: CVideoPlayerAudio::OnExit()14:05:37.352 T:2305815456  NOTICE: Closing audio device14:05:37.352 T:2305815456  NOTICE: Deleting audio codec14:05:37.353 T:2305815456  NOTICE: Closing stream player 214:05:37.353 T:2305815456  NOTICE: CDVDMessageQueue(video)::WaitUntilEmpty14:05:37.389 T:2305815456  NOTICE: waiting for video thread to exit14:05:37.389 T:2527589280   ERROR: Got MSGQ_ABORT or MSGO_IS_ERROR return true14:05:37.389 T:2527589280  NOTICE: thread end: video_thread14:05:37.389 T:2305815456  NOTICE: deleting video codec14:05:37.450 T:3034296320   ERROR: Control 50 in window 10025 has been asked to focus, but it can't14:05:37.647 T:2915038112   ERROR: CecLogMessage - Write: write failed !14:05:37.973 T:3034296320   ERROR: Previous line repeats 1 times.14:05:37.973 T:3034296320  NOTICE: CVideoPlayer::CloseFile()14:05:37.973 T:3034296320  NOTICE: VideoPlayer: waiting for threads to exit14:05:37.973 T:3034296320  NOTICE: VideoPlayer: finished waiting14:05:37.976 T:3034296320  NOTICE: CVideoPlayer::CloseFile()14:05:37.976 T:3034296320  NOTICE: VideoPlayer: waiting for threads to exit14:05:37.976 T:3034296320  NOTICE: VideoPlayer: finished waiting14:05:39.134 T:2915038112   ERROR: CecLogMessage - Write: write failed !01:28:04.059 T:3034296320   ERROR: Previous line repeats 55067 times.01:28:04.059 T:3034296320   ERROR: WinSystemX11::RefreshWindow - failed to query xrandr01:28:04.657 T:2915038112   ERROR: CecLogMessage - Write: write failed !01:28:06.829 T:3034296320   ERROR: Previous line repeats 3 times.01:28:06.829 T:3034296320 WARNING: CXRandR::Query - output HDMI-1 has no current mode, assuming disconnected01:28:06.829 T:3034296320   ERROR: WinSystemX11::RefreshWindow - failed to query xrandr01:28:07.632 T:2915038112   ERROR: CecLogMessage - Write: write failed !06:32:44.025 T:3034296320   ERROR: Previous line repeats 24580 times.06:32:44.025 T:3034296320   ERROR: WinSystemX11::RefreshWindow - failed to query xrandr06:32:44.243 T:2915038112   ERROR: CecLogMessage - Write: write failed !06:32:46.747 T:3034296320   ERROR: Previous line repeats 2 times.06:32:46.748 T:3034296320 WARNING: CXRandR::Query - output HDMI-1 has no current mode, assuming disconnected06:32:46.748 T:3034296320   ERROR: WinSystemX11::RefreshWindow - failed to query xrandr06:32:46.974 T:2915038112   ERROR: CecLogMessage - Write: write failed !


    Do you have some errors about CEC in kodi.log (in /storage/.kodi/tmp/)?


    That HDMI input is normally used for ARC.

  • Got the download to work, was very slow but I am now updated.
    So far everything looks good.
    Thanks for all the hard work.

  • The errors are very strange, it look like the HDMI link to the TV is down. Is your TV up and running when you have this kind of errors ?

  • I'm having regular crashes with the following symptoms:
    - ethernet is down (the lights are off)
    - the interface is dimmed out, and I cannot interact with it, but the time is correct, so things are still running


    The only way to solve it is to do a hard reboot (since I cannot ssh in the odroid nor use the interface to reboot).


    How can I help find the source of this bug?


  • Are you using the latest version of the LE ODROID portage ?


    Plugin a keyboard and Ctrl + Alt + F1/F2/... do not switch to a console prompt ?


    The only way then is to plug a serial to USB cable to be able to log in while the ethernet is down and then view all relevant logs.


    To ensure that the problem is LE only, you can also restore an old know to work image on the eMMC module. If there is no Ethernet sudden shutdown, then the bug is in the LE portage to ODROID.

  • Hi,


    Lately I decided to update my U3 to newer release. I have used an mmc version since and whole cloning process went smoothly (have used dd as installation software). The platform has lunched successfully and seems to be working fine. But I have noticed couple of issues:


    - I do see significant frame drop during animations of UI and even more during playback. running top I do see really high load on processor > 150%. Don't see any warning regarding decoding in log file. The rendering method is grayed out and set on Autodetect. Based on all of those symptoms I wonder if MFC is used during playback?


    kodi.log
    CDVDVideoCodecMFC::Open - MFC Setup succesfull (1920x808, linesize 1920, format 0x32314d4e), start streaming


    top:
    533 root 20 0 770376 231928 25672 R 145.4 11.2 47:02.80 kodi.bin


    - I do see some screen tearing, but since it is known issue, it is kinda expected.


    Any help?
    Thanks.


  • - I do see significant frame drop during animations of UI and even more during playback. running top I do see really high load on processor > 150%. Don't see any warning regarding decoding in log file. The rendering method is grayed out and set on Autodetect. Based on all of those symptoms I wonder if MFC is used during playback?


    kodi.log
    CDVDVideoCodecMFC::Open - MFC Setup succesfull (1920x808, linesize 1920, format 0x32314d4e), start streaming


    It is used but only for supported codecs. For example, HEVC/H.265 is not a supported codec by the MFC on ODROID-U3 and then everything is done by software, then no hardware offloading for decoding.
    [hr]


    How can I get CEC on U3 working? Or is it perhaps not supported on U3?


    It is supported and working here.


    You must first setup the HDMI port in the file: /storage/.config/cec-hdmi-port.conf that *must* match the HDMI port on the TV *and* the one setup in Kodi. Once you have the right HDMI port setup on the file and in Kodi, CEC should work fine.

    Edited once, last by fraggle ().


  • It is used but only for supported codecs. For example, HEVC/H.265 is not a supported codec by the MFC on ODROID-U3 and then everything is done by software, then no hardware offloading for decoding


    Interesting, probably I should mention I am upgrading from older 14.2 opelelec build and all my videos had been 100% hw accelerated. No drops to software decoding. Is this new platform limitation?


    BTW As far as I can see hardkernell have released kodi 16 for the platform, but I assume this issue has been solved not on driver side but probably by patching the kodi source.

  • Interesting, probably I should mention I am upgrading from older 14.2 opelelec build and all my videos had been 100% hw accelerated. No drops to software decoding. Is this new platform limitation?


    BTW As far as I can see hardkernel have released kodi 16 for the platform, but I assume this issue has been solved not on driver side but probably by patching the kodi source.


    Official OpenELEC has never released a version for ODROID-U3, so you probably have used an unofficial OpenELEC portage to ODROID-U3.


    I'm using the very same patch for Kodi to support MFC hardware decoding in this unofficial LibreELEC portage to ODROID-U3. Your high CPU usage is not reproductible here.


  • Official OpenELEC has never released a version for ODROID-U3, so you probably have used an unofficial OpenELEC portage to ODROID-U3.


    I'm using the very same patch for Kodi to support MFC hardware decoding in this unofficial LibreELEC portage to ODROID-U3. Your high CPU usage is not reproductible here.


    Yes,it was unofficial OpenElec release. And developer of the that have image is referring to your image now. :)


    Do I understand correctly you don't see same issues in your case?
    But strangely I see same issues on regular h264 encoded videos as well, occasional frame drops, high load.
    Lurking around odroid forums I have seen developers clames having problem with implementation of Kodi for the platform. And since we don't see 17.1 for the U3 I assume the problem is still there. They have released 17 for C1 though, but that is a different story.
    Any chance eMMC image might differ from SD version?

  • Do I understand correctly you don't see same issues in your case?
    But strangely I see same issues on regular h264 encoded videos as well, occasional frame drops, high load.
    Lurking around odroid forums I have seen developers clames having problem with implementation of Kodi for the platform. And since we don't see 17.1 for the U3 I assume the problem is still there. They have released 17 for C1 though, but that is a different story.
    Any chance eMMC image might differ from SD version?


    The eMMC and SD version are the same.


    I'm somewhat busy at the moment but give me in private a link to a problematic video. I will try to dig this issue further.