Estuary MOD

  • Hi,


    I have some questions about the Estuary Mod (Estuary MOD - KODI 17 (UPDATED 02/04/17)) using LE8.0 on s905x (minimxIII-II).


    I'm trying using it but the device seems to struggle, it's not fluent and it takes seconds to open new pages.


    I'm using a SanDisk Extreme Plus micro SD card, I'm wondering if installtointernal can provide better performance.


    Does anybody use this wonderful skin with s905 and give me a feedback about it plz?


    Do you know if s905 devices can handle it ?


    Thanks

  • It happens on a Wetek HUB too. I still have no idea if the skin is to blame or Kodi in general.
    Best is to pester Guilouz about it. Though he is a bit 'stand-off'ish' about strange problems. In general he says "It works fine here".

    Edited once, last by Klojum ().

  • The skin is overloaded with features and our boxes struggle with it. Good looking but not really usable in low-powered devices.

    Running kszaq's LibreELEC 8.2.2.3 and adamg's LibreELEC 9.x 1.0.6 on Cooleme MB1 (S905X - 2GB/8GB)

  • I had similar experience on both S905 and S905X boxes, especially when open the setting pages, e.g. LibreELEC. I don't know whether it's the skin or the box is to be blamed.

  • If you are running 8.0.0c you can try driving mali at a bit higher frequency:

    • standard running frequency is 500MHz: echo 3 > /sys/class/mpgpu/cur_freq
    • you can bump the clock to 666MHz: echo 4 > /sys/class/mpgpu/cur_freq


    I will also upload updated device trees that will allow 750MHz (S905X) or 792MHz (S905).


  • I had similar experience on both S905 and S905X boxes, especially when open the setting pages, e.g. LibreELEC. I don't know whether it's the skin or the box is to be blamed.


    The skin runs fine on my laptop (i3 5005 CPU).
    All those dependencies you see in the skin's forum page slow it down when running on our boxes.
    [hr]


    If you are running 8.0.0c you can try driving mali at a bit higher frequency


    I don't think is a GPU problem. Even the simpler transitions (for example, from settings main screen to the interface settings screen) take 3-4 seconds.

    Running kszaq's LibreELEC 8.2.2.3 and adamg's LibreELEC 9.x 1.0.6 on Cooleme MB1 (S905X - 2GB/8GB)

    Edited once, last by minimoe ().