S905 builds - general discussion

  • Hello Kszaq,

    Thank you very much for all the work you put into developing the S905 builds of LibreELEC.

    I was wondering if you are aware of the following Bluetooth issues:

    1. Cosmetic: My Bluetooth devices each appear twice in the device list (System > LibreELEC > Bluetooth). Both sets of duplicates show the same address.

    2. Fatal: My iSimple BluClick device is successfully added when I initially select "Trust and Connect", but after 10 minutes of inactivity the BluClick automatically goes into sleep mode, and when I press a button on it to wake it up, it fails to reconnect with LibreELEC either automatically or manually. When I return to the LibreELEC Bluetooth settings, selecting "Pair" generates a "Page Timeout" error message, and selecting "Connect" generates a "Input/Output Error" message. Then if I attempt to "Delete" one of the two BluClick devices in the device list, KODI hangs for several seconds and then restarts. After KODI has restarted the Bluetooth list no longer sees the BluClick device at all, until I reboot LibreElec. I am then able to "Trust and Connect" the BluClick and it works fine until it goes back into sleep mode again.

    I have duplicated the issue on both my NexBox A95X (S905x), and my Beelink GT1 (S912), using the following builds:


  • Greetings,

    I bought a Beelink MiniMX III (2GB/16GB) many months ago, but the ports of LibreELEC available for it at that time were still a bit, um, raw, so I set the thing on the shelf for a long while.

    Yesterday I downloaded the latest kszaq build, LibreELEC-s905.arm-8.2-8.1.9.img.gz, put it on an SD card, and the Beelink seems to be working great with that. But I have a few questions, and have noticed one apparent bug that may perhaps be something I need to report to the Kodi people, rather than to kszaq or to the LibreELEC people.

    So, my questions:

    1) Just curious: How come I need to use Rufus to transfer the .img file to the SD card? Could I just as well have DD'd it to the card instead?

    2) I've noted that if I do a power down of the Beelink, via the LibreELEC interface, my TV shuts off too. I would prefer that it didn't. How can I disable whatever magic (CEC?) is causing this?

    And now, the bug:

    Sadly, I own a VERY annoying TV. This is a Panasonic 50" Plasma which was one of the last inexpensive ones they ever made. It has a very annoying non-feature -- It does a 2.5% overscan along all egdes, and there is really no way to disable this. (Believe me, I am sure.) Thus, no matter what Kodi device I hook to this TV, I have to get in and do the Video Calibration, right at the start, so that Kodi will do scaling to compensate for the TV's annoying overscan.

    With this latest kszaq build for the s905 loaded onto my Beelink Mini MX III, I did perform the video calibration, and that makes almost everything display OK, however it appears that certain parts of the OSD that appear, e.g. if I move the mouse or skip forward (under Confluence) while watching a video are not being properly scaled. The results is that some bits of the OSD are actually only partially visible on the screen. (This is apparently true under both Estuary and Confluence.)

    So, what do you folks think? Is this a kszaq/s905 specific problem? Or is it perhaps a LibreELEC-specific problem? Or is it a generic Kodi problem?

    I'll report it, formally, and with all of the usual and required information (i.e. logs and such) but at this point I don't even have any clear idea who I should be reporting it to, specifically.

    Any help in determining that would be appreciated.

  • 1) Just curious: How come I need to use Rufus to transfer the .img file to the SD card? Could I just as well have DD'd it to the card instead?

    You can use any tool you like, Rufus is there as an example (to not tell people "Google an app that can burn image to SD card").

    2) I've noted that if I do a power down of the Beelink, via the LibreELEC interface, my TV shuts off too. I would prefer that it didn't. How can I disable whatever magic (CEC?) is causing this?

    Go to CEC settings in Kodi and disable it.

  • Thanks for the quick reply kszaq. What about the OSD scaling issue? Is this just me, or can you reproduce it?

    Maybe I just screwed up and didn't do an adequate job when I did the video calibration. I'm going to go back now and do the calibration one more time, just to be sure. But I really don't think I messed that up, so I really do think there is an issue here with the OSD scaling.

    So far, this is the one and only issue that will cause me to wait before discarding my trusty old x86 book-sized home theater / Kodi box and switching over for good to the Beelink. (Everything else seems to be working perfectly.)

  • NEVERMIND! It appears now that I did actually screw up the calibration. I got the calibration set properly now and everything looks terrific.

    Sorry. My bad. my mistake.

    This is really awesome. Thanks for all your hard work on this kszaq. These are terrific little boxes, and cheap too! Now I can finally make some good use of this, rather than as a mere dust collector.

  • I have set up my device perfectly (s905X). And copied to the internal memory, it is possible to clone the file system to another system. Then I'll save myself the trouble of setting up again.

  • Back again... And now it appears that there actually is an issue relating to video calibration/scaling. (It wasn't just my imagination, and despite what I might have said awhile ago, I actually didn't fix it.)

    Here's the story in a nutshell. As I said, I've got a Beelink MiniMXIII (original version) w/ 2G/8G, Gigabit ethernet, and (apparently) the Realtek WiFi. I just downloaded and fresh installed to a microSD card the latest and greatest 8.2- kszaq build and a proper device tree. I switched the thing to Confluence skin and did the video calibration, which I always have to do on account of the fact that I have a POS Panasonic flatscreen that does a 2.5% overscan, all the way around, and I can't disable that unfortunate "feature" in the TV. So I always have to force Kodi to do scaling (underscan?) to work around this annoyance.

    Anyway, I got the video nicely calibrated to do the underscan so that all of the normal Confluence menus & stuff shows up just perfect on the screen. But then I went and tried to watch one of my ripped DVDs, and I jiggled my mouse to get the OSD to come up and overlay the DVD that was playing... which it did.

    The problem is that it is clear and evident that the OSD stuff around the edges is only partially displaying. It is partly obscured by the physical edges of my flatscreen TV. In short, although the scaling (underscan?) that I set up when I did the video calibration is working perfectly, that scaling is apparently not being applied to the OSD display, when it is activated. The result, in my case, is that the OSD is mostly unusable, and most of its bits and pieces appear half-way off the physical screen.

    I didn't check to see if this is a problem also for Estuary, but I kind-of-suspect that it isn't, or else a lot of people would have reported it already.

    Anyway, I hope this can be fixed. It would appear that the calibration/scaling information is just being stashed in some place where the OSD code (in Confluence, at least) isn't picking it up.

  • Another issue that I feel obliged to mention also...

    After putting the latest kszaq build onto my Beelink MiniMXIII, and after lodaing the "stock" Confluence skin on top of that, I went bonkers for a short while. desperately trying... and failing... to find out how to make adjustments to the type of the Internet connection being used.

    Slowly, it dawned on me that the "stock" Confluence skin, quite rightly, lacks the special interface button to get at all of the LibreELEC-specific settings. So I had to switch back to Estuary to get at those. :(

    I have no idea what a "good" fix for this problem would look like. Maybe kszaq needs to bribe the Confluence maintainer to get him to auto-detect when his skin is running on LibreELEC and in that case add in the extra button and controls. Well.. just a thought. :)

    All I know is that I'm probably not the only person who is going to be using LibreELEC with skins other than Estuary, either now or in, the future, and thus, logically, it is unlikely that I will be the last person to ever raise this issue.

    It would thus be Good if there were to be a generic sort of solution developed, but I understand that this is far easier said than done. (This seems like a classic N x M problem... you have N different versions of standalone Kodi implementations and M different skins to worry about. I'm not sure if there is even any way to insure that all of the N always work perfectly with all of the M.)

  • Another issue that I feel obliged to mention also...

    Apparently, the Realtek WiFi chip in the Beelink MiniMXIII is crap. Or at least some comments I read today say it is. And having just tried to use it myself, I can say that that does in fact appear to be the case.

    The good news is that I had/have my trusty old TrendNet TEW-684UB dual-band USB WiFi adapter lyiing around. So I plugged that into the Beelink's free USB socket, power cycled the box, and yes, I am now seeing lots of SSIDs that are reachable from either wlan0 or wlan1. (So I'm guessing that wlan0 is the built-in Wifi and that wlan1 is my external TEW-684UB.)

    Assuming that I'm correct about that part, there is just one small fly in the ointment... I am *not* seeing my router's 5GHz band SSID anywhere in the available connections list. Bummer.

    I was going to ask the question: "In general, do the kszaq builds include in-built support for a variety of USB WiFi adapters?" But it seems now that the answer to that question is "yes". The only disappointment is that it appears that only the 2.4GHz radio in my TEW-684UB WiFi adapter may be supported, and not also the 5GHz radio.

    If so, I don't imagine that this is an issue that would be appropriate to raise with kszaq, or even with the LibreELEC team. I guess that if I want to report this non-feature I have to go off and try to locate whoeever is currently maintaining the relevant Linux kernel driver, yes?

    P.S. For awhile there, I was going to report that the latest kszaq build was locking up my Beelink box. It sort-of seemed to be doing that. But in fact I think that the box was just getting really slow sometimes on account of the dirt-cheap wiFi chip in this thing. (When Kodi starts to do buffering over a slow link, it seems like it really doesn't want to be interrupted part way through doing that. Or maybe it's just me.)

  • I have no idead how to do that. If you instruct me, I'll try.

    In Confluence main screen the second to last option (to the right) should be Programs (unless you have hidden it in Settings).

    I don't have an access to a box ATM so I can't guarantee LibreELEC Configuration let's you adjust what you want but it's worth to check anyway.