How to switch HW keyboard typing language

  • Hi all,


    I have RPI 3 with LibreELEC 7.95.3 and I faced with problem - not able to switch language for typing text from HW keyboard.
    In interface settings i have already added different keyboard layouts and i am able to switch typing text on Virtual keyboard but HW USB keyboard continues using English language.


    How to switch between languages for HW keyboards ? combinations like Alt+Shift, Ctrl+Shift not working.


    Thanks in advance.

    Edited once, last by Urrys ().


  • In the LibreELEC settings addon you can set the keymap.


    Do you mean keyboard layout in LibreELEC settings ?


    I set layout ru_win but inputting from HW keyboard still in english. My idea is to make possible switch between english and russian language (like in Windows) when inputting from HW keyboard.


    Also i noticed that on my LibreELEC setting there is only one keyboard variant, see photo 20170213_101758_1.jpg in attachments. But on screenshot from LibreELEC wiki (LE-settings-system.png) there are more keyboard settings (two variants of keyboard layout.

  • AFAIK there is no way to use external keyboard with national characters (like nordic chars: åäöÅÄÖ), it's US layout only.
    These still appear on the OSC, but not handled by physical keyboard.
    This seems to apply to all Raspberry versions, regardless of OpenElec/LibreElec settings.


    IS this fixable? No idea, I gave up this question a while ago since I never got any answer understandable for a 'non Linux user', just some technical mumbo-jumbo... ;)

  • is switching supported in android box (amlogic) versions? i'm also looking for the solution how to switch input language on hardware usb keyboard.

  • How to add the support of 2 different layouts switching for hardware keyboards? Why is it supported for x86 and disabled for amlogic?