Beta 7.95.3 Cubox pro and OneForAll Remote

  • hi all,
    first, i know that the cubox is not official supported.
    i did a clean install with the latest beta provided.
    the problem is that i can't use my oneforall Remote. the cursor is
    too sensitive, and when moving it with the rows. got not respond.
    when i tick to the right it moves to the end etc'.


    this problem doesn't exists in the beta-2, which is the one that i'm using.


    thx in advanced.


  • Also having a similar problem with Harmony Remote. Moving to next item on screen (up or down, side to side) usually works okay. Moving to the second one over skips one or more items and ends up on the third (or last) item over. Only happens on 7.95.3 ... 7.95.2 and earlier work fine.


    Thanks also...

  • +1 with the Harmony Remote too :(


    I have a similar problem since 7.95.3 and also on the 8.0. I have a Harmony One remote and the inputs are often registered double. I press on the cursor to the right and 2-3 times it gives me one step in the menu which is fine but then everz 2nd or 3rd time the cursor jumps 2 menu items instead of one. Didn't have this issue in 7.95.2 or prior version.

  • Repeats can be adjusted like this (so I heard): Fixing Repeats
    I hope someone more qualified will complement my answer.

    Better support for Amlogic devices: use CoreELEC

    Blu-ray Disc Java menus support - forum thread, Github

    my lamp addon (unofficial/community with limited support)
    my touchscreen support and instructions by Grruhn (now touchscreen addon exists in repository)


  • Repeats can be adjusted like this (so I heard): Fixing Repeats
    I hope someone more qualified will complement my answer.


    Thanks for your answer.


    Certainly a solution could be (in case it even is a solution to this problem in this case) to use a workaround in now adjusting the remote to these changed circumstances (will look into it) however in my humble opinion it would be more a task to fix whatever got broken since 7.95.3 that was working perfectly fine in all other releases up to 7.95.2. Reason being even if the adjustments work who is to say something dosen't get broken again in a future release if the developers are not aware of what is causing this issue to begin with.

  • From my understanding all those changes are improvements for something else and nothing is broken. But I assume some adjustments must be made.

    Better support for Amlogic devices: use CoreELEC

    Blu-ray Disc Java menus support - forum thread, Github

    my lamp addon (unofficial/community with limited support)
    my touchscreen support and instructions by Grruhn (now touchscreen addon exists in repository)


  • From my understanding all those changes are improvements for something else and nothing is broken. But I assume some adjustments must be made.


    In any case i will look into the proposed solution. Thanks.

  • Sorry to say...the adjustment of the repeat suggested as a fix to this problem does not work. I went from default (3) to 0 (trying each step in between) and it still skips on the second or third press. I agree with Captain Hero...something was broken in the LIRC work that occurred in 7.95.3 and needs to be fixed there, not in the Harmony remote (or All-in-One if even possible, there).


    Steve

  • Can you open ssh session and check with ir-keytable command how much is repeat delay? Before it was 200 ms but now it is 500 ms.
    You can set back to 200 with this command:

    Code
    1. ir-keytable --delay=200
    2. or
    3. ir-keytable --delay=2000


    Then check again with ir-keytable command if time was set. You can also try to increase repeat rate with --period=


    If this doesn't help can I make you one test image (with kernel 4.4 or with 3.14)?

    Better support for Amlogic devices: use CoreELEC

    Blu-ray Disc Java menus support - forum thread, Github

    my lamp addon (unofficial/community with limited support)
    my touchscreen support and instructions by Grruhn (now touchscreen addon exists in repository)

    Edited once, last by vpeter ().


  • I think I was able to find and change from 500 to 200...still no joy... what follows is the info from ir-keytable (after the change)...please make sure I did it right :D


    LibreELEC:/usr/bin # ir-keytable -D --device=/dev/input/event1
    Found /sys/class/rc/rc0/ (/dev/input/event1) with:
    Driver gpio-rc-recv, table rc-rc6-mce
    Supported protocols: unknown other lirc rc-5 rc-5-sz jvc sony nec sanyo mce-kbd rc-6 sharp xmp
    Enabled protocols: lirc nec rc-6
    Name: gpio_ir_recv
    bus: 25, vendor/product: 0001:0001, version: 0x0100
    Repeat delay = 200 ms, repeat period = 125 ms


    If building an image, please use kernel 4.4...I'm on 8.0.0 at present...(also, the above change did not appear to last through a reboot?)


    Steve

  • Ok, then update with this version LibreELEC-imx6.arm-8.0.0-test-ir-01.tar and report if there is any change. Seems it does behave little different even for me.


    No need for ir-keytable changes.

    Better support for Amlogic devices: use CoreELEC

    Blu-ray Disc Java menus support - forum thread, Github

    my lamp addon (unofficial/community with limited support)
    my touchscreen support and instructions by Grruhn (now touchscreen addon exists in repository)

    Edited once, last by vpeter ().


  • Ok, then update with this version LibreELEC-imx6.arm-8.0.0-test-ir-01.tar and report if there is any change. Seems it does behave little different even for me.


    No need for ir-keytable changes.


    Well, it seems that fixed the Harmony Remote problem. I tried 10 or more directories and the all worked properly --- 1 press = 1 icon moved in each direction up/down/right/left, including the slider bar on the right and the pop-out on the left. (using Confluence skin). Looks like you got it...BTW...I installed by dropping the 4 files into "update" folder and rebooting.


    Steve

  • Good, then I will try to include this in v8.0.1.


    And btw: to update libreelec you can put those 4 files in update folder, or just .tar file or just .img.gz file :rolleyes:

    Better support for Amlogic devices: use CoreELEC

    Blu-ray Disc Java menus support - forum thread, Github

    my lamp addon (unofficial/community with limited support)
    my touchscreen support and instructions by Grruhn (now touchscreen addon exists in repository)

  • The last weekend I tried the xbian image. The remote worked fine. So I think that the problem is not with the kernel (4.8)and not with kodi. Something is wrong in le image. The comparison were between the two official builds.


    Sent from my SM-G900F using Tapatalk

  • Remote works fine in libreleec too after this kernel patch (confirmed by spschneer).
    Also kernel 4.8 was never affected with this bug.

    Better support for Amlogic devices: use CoreELEC

    Blu-ray Disc Java menus support - forum thread, Github

    my lamp addon (unofficial/community with limited support)
    my touchscreen support and instructions by Grruhn (now touchscreen addon exists in repository)

    Edited once, last by vpeter ().


  • Remote works fine in libreleec too after this kernel patch (confirmed by spschneer).
    Also kernel 4.8 was never affected with this bug.


    OK, Can You Tell Me Wich Kernel Use The "official" image of cubox, posted in the main page?
    Whick Kernel Is Implemented in your Directory?(i'm talking about the image of 22.2.2017 not the solidrun kernel)


    do you suggest to use this image?
    LibreELEC-imx6.arm-8.0.1-xbian-4.8.img.gz
    does it different from the one posted in main page?

    Edited once, last by danielk ().