RemoteControl repeats(holding down button) don't work (7.90.001 ALPHA) > works in LE7

  • milhouse
    Thanks for the information. So i'll keep the patches.


    I don't know if it's a useful information, but your build 0617x with the lirc bump did not affect the kernel 4.6.2 broken remote repeats. Just tested without knowing, if it's really technically related... So. As said, just fyi - if even valid


  • milhouse
    Thanks for the information. So i'll keep the patches.


    I don't know if it's a useful information, but your build 0617x with the lirc bump did not affect the kernel 4.6.2 broken remote repeats. Just tested without knowing, if it's really technically related... So. As said, just fyi - if even valid


    Thanks for the confirmation, but #0617x wasn't expected to fix that.


  • While holding down a remote control button (UP or DOWN for example), the the keypress gets not repeated, so you have to do scrolling (for example) row by row, one button press at a time.


    Could you please upload kodi debug logs, both of a build which has that issue (eg a recent milhouse build) and your working (kernel 4.4) build?


    Also please post some details about your setup. Which modules are loaded (both working and non-working), are you using userspace lircd (i.e. manual setup via lircd.conf), any other settings/options/config-files you had to change?


    so long,


    Hias

    Edited once, last by HiassofT ().

  • Just ordered some extra usb 3.0 sticks to be more flexible testing multiple clean installs without affecting my live-systems. (which work too good atm) Happy to provide logs then, if still needed.


    If i read correctly in you 17x build thread, Milhouse, you tried out some (linux kernel) fixes/patches with 4.6 and 4.7 kernel, which had some success, but are reverted for now? Am i right that means narrowing down the issue makes slight progress? :) For now i'm still using kernel 4.4.13 with KODI 17 which works identical to kernel 4.4.7 as you would expect.

  • Yes, we identified the 4.6.x kernel commit that causes the auto-repeat failure. Reverting this commit fixes the auto-repeat issue but causes other more serious lirc issues so not really sure what the solution is right now. Assuming the kernel commit is in fact correct, perhaps the lirc system requires a tweak to accommodate the kernel change - reverting the kernel commit probably isn't a long term solution, and it already requires a rework for the 4.7 kernel.

  • Yesterday i switched my "old" custom build from


    - kernel 4.4.13
    - lirc reverted @ 0.9.0


    to latest nightliy with:


    - kernel 4.7 + autorepeat-kernel-commit-revert-patch
    - lirc 0.9.4


    Result:
    - No problems so far
    - Auto-repeat works on both Intel Haswell NUC and Desktop
    - Reaction/processing times of IR button presses feel slightly different then before - it may be only a few ms. If i had to say something i'd guess it's some barely noticeable ms faster in reacting to IR presses. But maybe thats a placebo effect.


  • So you only switched to V 7.90.003? Because in V 7.90.003 the auto-repeat is not working for me

  • we reported the auto-repeat issue (and problem commit that caused them) to upstream Kernel devs and a fix was provided a week or so ago, so this should be resolved in v7.90.004 which is due soon-ish


  • we reported the auto-repeat issue (and problem commit that caused them) to upstream Kernel devs and a fix was provided a week or so ago, so this should be resolved in v7.90.004 which is due soon-ish


    Thanks chewitt, that's great news! So, I'll wait for v7.90.004.

  • Just to confirm again: Still no problems with daily kernel 4.7 LibreELEC nightly after some time of daily use. Both Intel Haswell test systems work without problems in terms of IR remote usage.