tvheadend, ATSC and epg...


  • Please post a screen grab of the channels tab. Also - open the log window...and from the epg grabber tab press the rerun internal grabber button and post the log result.


    Here you go...
    2016-08-06 03:22:15.819 spawn: Executing "/storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml"
    2016-08-06 03:22:23.010 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: grab took 7 seconds
    2016-08-06 03:22:23.024 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: parse took 0 seconds
    2016-08-06 03:22:23.024 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: channels tot= 19 new= 0 mod= 0
    2016-08-06 03:22:23.024 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: brands tot= 0 new= 0 mod= 0
    2016-08-06 03:22:23.024 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: seasons tot= 0 new= 0 mod= 0
    2016-08-06 03:22:23.024 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: episodes tot= 1 new= 0 mod= 0
    2016-08-06 03:22:23.024 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: broadcasts tot= 1 new= 0 mod= 0



    Dropbox - channels.png

  • for now - on the channels tab try turning off the automatically map epg source buttons and manually select the epg source for each channel - then post that screen again.
    [hr]
    It is likely that the channel is not mapping to teh epg source since you have the automatically name the network button checked - which is using the names that the stations want and not the call letters that are in the epg data. Hopefully if you manually map the epg source it will solve that issue.


  • for now - on the channels tab try turning off the automatically map epg source buttons and manually select the epg source for each channel - then post that screen again.
    [hr]
    It is likely that the channel is not mapping to teh epg source since you have the automatically name the network button checked - which is using the names that the stations want and not the call letters that are in the epg data. Hopefully if you manually map the epg source it will solve that issue.


    When I turned the check boxes off and set them manually the correct feeds were checked. I unchecked and rechecked them. Don't know that it helped any.


    Dropbox - epg4.png

  • sorry. i missed it.
    2016-08-06 03:39:11.400 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: grab /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml
    2016-08-06 03:39:11.409 spawn: Executing "/storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml"
    2016-08-06 03:39:18.894 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: grab took 7 seconds
    2016-08-06 03:39:18.909 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: parse took 0 seconds
    2016-08-06 03:39:18.909 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: channels tot= 19 new= 0 mod= 0
    2016-08-06 03:39:18.909 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: brands tot= 0 new= 0 mod= 0
    2016-08-06 03:39:18.909 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: seasons tot= 0 new= 0 mod= 0
    2016-08-06 03:39:18.909 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: episodes tot= 0 new= 0 mod= 0
    2016-08-06 03:39:18.909 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: broadcasts tot= 0 new= 0 mod= 0

  • another way to make sure they are connected is to enable the update channel name button on the epg grabber tab - you should see the channel names change to the station number/name that is in the xmltv file.
    [hr]
    also - I think you'll need to turn off the automatically name from network button on the channels tab.


  • another way to make sure they are connected is to enable the update channel name button on the epg grabber tab - you should see the channel names change to the station number/name that is in the xmltv file.
    [hr]
    also - I think you'll need to turn off the automatically name from network button on the channels tab.


    Ok. I turned off the automatic name from network. Rebooted and got the log below. I don't recall seeing the scanfile lines before.
    2016-08-06 04:00:58.784 tvhdhomerun: Found HDHomerun device 10374f4b with 2 tuners
    2016-08-06 04:00:58.796 tvheadend: Using Network type : ATSC-T
    2016-08-06 04:00:58.796 tvhdhomerun: Created frontend 10374F4B tuner 0
    2016-08-06 04:00:58.796 tvhdhomerun: Created frontend 10374F4B tuner 1
    2016-08-06 04:00:59.272 scanfile: DVB-S - loaded 1 regions with 113 networks
    2016-08-06 04:00:59.272 scanfile: DVB-T - loaded 44 regions with 1106 networks
    2016-08-06 04:00:59.272 scanfile: DVB-C - loaded 17 regions with 55 networks
    2016-08-06 04:00:59.272 scanfile: ISDB-T - loaded 2 regions with 1000 networks
    2016-08-06 04:01:01.746 htsp: Got connection from 192.168.1.22
    2016-08-06 04:01:01.748 htsp: 192.168.1.22: Welcomed client software: Kodi Media Center (HTSPv25)
    2016-08-06 04:01:01.750 htsp: 192.168.1.22 [ Kodi Media Center ]: Identified as user ''
    2016-08-06 04:02:58.000 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: grab /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml
    2016-08-06 04:02:58.007 spawn: Executing "/storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml"
    2016-08-06 04:03:06.992 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: grab took 9 seconds
    2016-08-06 04:03:07.008 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: parse took 0 seconds
    2016-08-06 04:03:07.008 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: channels tot= 19 new= 0 mod= 0
    2016-08-06 04:03:07.008 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: brands tot= 0 new= 0 mod= 0
    2016-08-06 04:03:07.008 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: seasons tot= 0 new= 0 mod= 0
    2016-08-06 04:03:07.008 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: episodes tot= 0 new= 0 mod= 0
    2016-08-06 04:03:07.008 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: broadcasts tot= 0 new= 0 mod= 0


    I'm still not seeing anything in the Electronic Program Guide

  • can you post the channels tab screen grab with the epg source field in the screen?
    [hr]
    the scanfile stuf is the predefined mux data for the other regions in the world. You likely didn't see them as you didn't have the log window open early enough in the past. It's not relevant for us. :-)


  • can you post the channels tab screen grab with the epg source field in the screen?
    [hr]
    the scanfile stuf is the predefined mux data for the other regions in the world. You likely didn't see them as you didn't have the log window open early enough in the past. It's not relevant for us. :-)


    I think this is what you are asking for...


    Dropbox - channels2.png

  • ok good - BTW you can have that field displayed in the channel tab window...not sure why it's missing on yours. Just click on the drop down icon on one of the column names and select the field to have it appear in the window.
    [hr]
    OK everything looks right here. I would suggest leaving it like it is overnight. It will autoupdate the guide overnight and if we're lucky start pulling the program data. NOt sure why it isn't just working now, but it looks like all your settings are right. The only other setting I see different from mine is on the epg grabber tab. I have the Channel Numbers (heuristic) setting disabled. I don't know why that would cause any issue but if you want to disable it and set the priority to 1 before you leave it for the night - that's my last suggestion for now. :-(


  • ok good - BTW you can have that field displayed in the channel tab window...not sure why it's missing on yours. Just click on the drop down icon on one of the column names and select the field to have it appear in the window.
    [hr]
    OK everything looks right here. I would suggest leaving it like it is overnight. It will autoupdate the guide overnight and if we're lucky start pulling the program data. NOt sure why it isn't just working now, but it looks like all your settings are right. The only other setting I see different from mine is on the epg grabber tab. I have the Channel Numbers (heuristic) setting disabled. I don't know why that would cause any issue but if you want to disable it and set the priority to 1 before you leave it for the night - that's my last suggestion for now. :-(


    Thanks! I will disable it just in case and give it a shot. Fingers crossed.

  • I did some additional testing on another box that I have...when I used the TVguide data I had the same issue you are having. When I switched to zap2it data the programs loaded. Looks like there is a code issue in my program for tvguide that is keeping tvheadend from loading the programs.


    If you change to zap2it in the zap2xml addon. You'll need to reboot...then go into the tvheadend web interface and change the epg source to the zap2it listing instead of the tvguide listing. Once you do that, you can rerun the internal grabber (might take two times) and you should see programs load.


    I'll take a look at my tvguide code and see what is going on there - but let me know if this works for you!


  • I did some additional testing on another box that I have...when I used the TVguide data I had the same issue you are having. When I switched to zap2it data the programs loaded. Looks like there is a code issue in my program for tvguide that is keeping tvheadend from loading the programs.


    If you change to zap2it in the zap2xml addon. You'll need to reboot...then go into the tvheadend web interface and change the epg source to the zap2it listing instead of the tvguide listing. Once you do that, you can rerun the internal grabber (might take two times) and you should see programs load.


    I'll take a look at my tvguide code and see what is going on there - but let me know if this works for you!


    Hallelujah! That did it.


    What a PITA! Of course,99.9% was me not having any idea what I was doing.


    I can certainly understand you wanting to make this process easier. On the bright side I now understand the process of setting it up much better than I would have.


    I owe you one. If I can ever help, just let me know.

    Edited once, last by ekincaid ().


  • I certainly don't want my PITA statement being misinterpreted. I appreciate what you and others have done.

  • No worries - this really is much harder than what it should be. Trying to get all of this working with the variety of boxes, tuners and other variables is quite a mess.


    Glad you have it running. Not sure why the TVguide data is not loading into tvheadend. It is downloading and building the xmltv file correctly. I'll see if the original code writer has any thoughts.


    You can feel free to try out all of the other settings in zap2xml now that you have it working. :-)

  • I'm having a bit of an issue with tvheadend. Everything is working great with zap2xml. However, about every other day I will pull up tvheadend in my browser and find nothing listed under Electronic Program Guide. When I check the configuration I see that the EPG source list is completely blank and I will have to set each one again. After I reboot the box everything will be back up and running fine. At least for the next couple of days. Thoughts? :huh:

  • I have quick queztion


    why come webgrab addon changes guide.xml back to original all the time & how can I use tvheadend's tv_grab_file to pull the correct guide.xml ?


    can't seem to get a working EPG pulled in from in kodi


    how is it suppose to all work ? blody setting up the tvheadend service XML from file in there ? strange setup

    Edited once, last by highkick05 ().