tvheadend, ATSC and epg...

  • You have confirmed what I was thinking... Even though everything looks correct under the configuration there must be something not working quite right. The Electronic Program Guide on the web interface never did show anything. I'll look at it again tonight.


    I did try 4.2 previously and never could get the list of muxes to populate the dropdown list when I was first setting it up so I reverted back. I'll try it agin and see what happpens.

  • You are correct about the muxes...something happened to their build system that removed the ATSC-T muxes from the addon.


    You can install this version first: Dropbox - service.tvheadend42-7.0.100 (1).zip


    That should have the ATSC-T muxes in it as it is the original LE version.


    Then install the updated version from here: 4.1-2141-14.07.2016



    -- Even with the 4.0 version, you should be seeing the guide data...so if you want, we can troubleshoot that version when you get home.

  • I can load 4.2 from the repository and can get to it through the web interface just fine.


    Of course, no muxes are listed.


    If I go the path you just listed of installing it and then updating I can't access it through the web interface.


    It tells me the site can't be reached.


    What gives? My frustration level is starting to grow!

  • That may be happening because you have two versions installed. No worries - you can use the 4.0 version and we'll get the guide up and running. If you have the web interface up (using 4.0 I ssume) and you have scanned your channels, installed and setup zap2xml and connected the channels to the epg source. Check to see if you have a guide (really just program listings) in the tvheadend web interface.
    [hr]
    Also - I can't remember if this version had the muxes or not - but you can install and check. Make sure if you do - you first uninstall any other versions.


    Dropbox - service.tvheadend42-7.0.101-1933.zip

  • I have been careful to have only one version at a time load so I'm not sure what the problem was. If I look for the silver lining I believe I'm starting to understand tvheadend a little better.


    I now have 4.0 loaded.
    All of the muxes have been mapped.
    I set the internal mapper to zip2xml under the EPG Grabber tab and rebooted.
    I then set the EPG Source for each of these to zip2xml under the Channel / EPG tab.


    Now it seems I have a couple items showing up on the Electronic Program Guide which is a first. Both are for the same channel. Will more show up in time? Still uncertain it's working 100%. But it's progress.

  • Do you have more than 1 epg grabber enabled?
    [hr]
    Also - as a starting point. Limit the days to 3 on the zap2xml config screen and turn off the other options like extra details and picons. We want to make sure you get a full guide load without the zap2it server timing out.

  • How do I manually initialize a scan from an internal grabber? I think what I was seeing is from OTA. Slow as molasses. Looking at the log file I am sure of it.

    Edited once, last by ekincaid ().

  • On the EPG GRABBER tab there is a button for rerun grabbers...on later versions (4.2) there is a button for internal and OTA...I think you'll only see the OTA button, but it should force the other to run. If you have an OTA grabber enabled, make sure you set the priority for the zap2xml to a lower number (higher priority) or it will likely just pull the OTA data.


    If the rerun OTA grabber button doesn't work. Just reboot - that forces it to rerun.

  • OK....


    On a reboot I see the following in the System Log
    2016-08-04 21:09:52.614 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: grab took 9 seconds
    2016-08-04 21:09:52.628 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: parse took 0 seconds
    2016-08-04 21:09:52.628 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: channels tot= 19 new= 0 mod= 0
    2016-08-04 21:09:52.628 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: brands tot= 0 new= 0 mod= 0
    2016-08-04 21:09:52.628 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: seasons tot= 0 new= 0 mod= 0
    2016-08-04 21:09:52.628 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: episodes tot= 1 new= 1 mod= 1
    2016-08-04 21:09:52.628 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: broadcasts tot= 1 new= 1 mod= 1


    Still nothing in the Electronic Program Guide

    Edited once, last by ekincaid ().

  • Perfect - that shows that you are getting the channel download. It also means that the channels are not actually connected to the zap2xml grabber as the epg source. If you have any other grabbers on, you may have selected the wrong source on the channels tab under epg source.


    Take a look at this screen grab and make sure yours is showing zap2xml in the epg source column for each channel.


    Dropbox - Screengrab EPG.jpg


    You're getting very close! :-)

  • Something still isn't right. The System log is showing the grab...


    But nothing ever makes it to the Electronic Program Guide.


    I have tried switching it from TVGuide to zip2it and it didn't change the results...


    In the config for tvheadend inside kodi there are options for xmltv configuration. Don't suppose that has anything to do with it?

  • no - you only use the xmltv configuration if you're doing the xmltv file separate from your backend (tvheadend)


    If the system log is showing the grab - you should see it list not only channels but it should list the number of programs added as well. You don't need to worry about kodi until we see program guide info in the tvheadend epg tab.


    do you have an account setup with tvguide and/or zap2it? Do you have a set of favorite channels or just grabbing the whole list of channels?


    Can you post your last tvheadend log info from the grab like you did a few posts ago?

  • Yeah I know... It's got to be something simple.


    I do have Accounts on both zap2it and tvguide with favorites setup. Here is my last log...
    2016-08-04 22:21:27.541 htsp: Got connection from 192.168.1.22
    2016-08-04 22:21:27.541 htsp: 192.168.1.22: Welcomed client software: Kodi Media Center (HTSPv25)
    2016-08-04 22:21:32.986 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: grab took 7 seconds
    2016-08-04 22:21:32.999 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: parse took 0 seconds
    2016-08-04 22:21:32.999 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: channels tot= 19 new= 0 mod= 0
    2016-08-04 22:21:32.999 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: brands tot= 0 new= 0 mod= 0
    2016-08-04 22:21:32.999 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: seasons tot= 0 new= 0 mod= 0
    2016-08-04 22:21:32.999 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: episodes tot= 0 new= 0 mod= 0
    2016-08-04 22:21:32.999 /storage/.kodi/addons/tools.module.zap2xml/bin/tv_grab_zap2xml: broadcasts tot= 0 new= 0 mod= 0

  • Can you post a screen grab of your EPG GRABBER tab and have the zap2xml grabber selected so it opens the parameteres window on the right.
    [hr]
    one other thing...it looks like you have other channels listed in your epg source dropdown... you might want to give that a good scroll and make sure there isn't another version of the same channel further down or up the list. The newer version of tvheadend lets you access that list and erase the old/unneeded grabber channels.


    I had a setup once where I had three versions of the same channel leftover from previous zap2xml setups and I had to make sure I had the right one selected.


  • I not seeing the parameters you speak of... Maybe because I have 4.0 instead of 4.2


    Dropbox - Untitled2.png


    right - forgot about that difference. It does look like ther are OTA grabbers enabled at the bottom of your screen grab. You should turn all of those off to speed up grabs. Most of them are for Europe. You can leave on the ATSC one if you like.
    [hr]
    If you find you have multiple occurences of the same channels in the epg source (that I mentioned above)...you can delete them and start over you can connect to your LE system over the network in windows explorer. You'll want to delete the files in the following folder: \\LIBREELEC\Userdata\addon_data\service.tvheadend42\channel (replacing the 42 version with your 40 folder)


    Then you can setup the epg source again once the grabber runs the first time.